LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-12-2011, 06:37 PM   #1
adraganov
LQ Newbie
 
Registered: Apr 2011
Location: Edinburgh
Distribution: SL
Posts: 5

Rep: Reputation: 0
Packages data dependencies


Hi everybody,

I am trying to install a piece of software that requires a specific versions of several packages. I am using Scientific Linux 5.5 and yum for managing the apps.
The problem is that I need, for example ruby >= 1.8.7, but the package for ruby that is the official repositories for SL 5.5 is 1.8.5 and therefore yum says it's up to date.
There are other repositories for SL 6.0 that have ruby-1.8.7. Initially I ignored the fact that they are not for 5.5 and tried to install it manually with rpm. But there was an increasing number of data dependencies for the packages so I gave up.
What can I do to avoid this? I suppose installing packages for newer OS version should be ok and they will be compatible with other older libs. But do you really install packages in this manner?
Any help will be highly appreciated!

Cheers
 
Old 04-12-2011, 11:22 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Quote:
Originally Posted by adraganov View Post
Hi everybody,

I am trying to install a piece of software that requires a specific versions of several packages. I am using Scientific Linux 5.5 and yum for managing the apps.
The problem is that I need, for example ruby >= 1.8.7, but the package for ruby that is the official repositories for SL 5.5 is 1.8.5 and therefore yum says it's up to date.
There are other repositories for SL 6.0 that have ruby-1.8.7. Initially I ignored the fact that they are not for 5.5 and tried to install it manually with rpm. But there was an increasing number of data dependencies for the packages so I gave up.
What can I do to avoid this?
Your best bet is to upgrade to SL 6.0.

Quote:
Originally Posted by adraganov View Post
I suppose installing packages for newer OS version should be ok and they will be compatible with other older libs. But do you really install packages in this manner?
No, they are built against newer libraries.
You either need to upgrade to 6 or you need to get the source packages for all the dependencies and build them on SL 5.5.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Packages with unmet dependencies archieval Linux - Software 18 04-23-2010 08:04 PM
Packages, dependencies, and other confusion mefizto Debian 8 04-22-2009 08:55 PM
[SOLVED] How do I install packages with dependencies edentonjr Linux - Newbie 5 04-01-2009 04:17 PM
packages dependencies. varaonsite Debian 2 07-18-2006 07:36 AM
Where are dependencies in Slackware packages? sbassi Slackware 2 01-15-2004 05:24 PM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration