Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-05-2009, 10:30 AM   #1
LQ Newbie
Registered: Mar 2009
Posts: 6

Rep: Reputation: 0
Openvpn problem OS: CentOS 5.2

Hello guys I have a very strange problem i can not find anything about it in google. So i want to ask here can someone help me. I have installed and configured everything as i should lzo and openvpn are installed. I have generated all the keys for the server and i have done the server.conf file like this:
dev tun
proto tcp
port 1194

ca ca.crt
cert server.crt
key server.key
dh dh1024.pem

user nobody
group nogroup


#status openvpn-status.log
#verb 3

push “redirect-gateway def1″

#log-append /var/log/openvpn

my crt and key files are in the same directory as my config file. but when i do
]# openvpn –config server.conf
Options error: Unrecognized option or missing parameter(s) in server.conf:5: ca (2.0.9)
Use –help for more information.

I get this unusual error and i can not find out why it this happening whats wrong with ca ca.crt line
Please help me.
Old 03-05-2009, 01:57 PM   #2
Registered: Nov 2008
Location: Lower Saxony, Germany
Distribution: CentOS, RHEL, Solaris 10, AIX, HP-UX
Posts: 731

Rep: Reputation: 137Reputation: 137

the line looks good. Not sure what seems to be wrong.

Check the file with
for strange characters, eventually this will help.
Old 03-06-2009, 10:34 AM   #3
LQ Newbie
Registered: Mar 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Hi again,

mesiol thanks for your reply.

I found a solution so in case someone has the same problem this i help i hope.

I dont really get why this was not happening. But when i was installing openvpn via YUM and make certs and stuff everything went good till that point when i get this error :
Options error: Unrecognized option or missing parameter(s) in server.conf:5: ca (2.0.9)
Use –help for more information.

I dont know for what reason it was not working maybe it was not compiling the way it should. All i did was get the openvpn-*.tar.gz and just untar the file.
tar -zxf openvpn-*.tar.gz
cd openvpn
make install
all went good then i made certs and conf files and everything is fine.

Well i hope this will help to someone who has the same problem if it does pls post reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenVPN client has not default gateway when connect to OpenVPN server sailershen Linux - Security 3 03-04-2010 03:20 AM
OpenVPN issues on CentOS 4.7 sseeker Linux - Server 1 01-31-2009 07:50 PM
OpenVPN Question : connecting 5-6 comps with OpenVPN duryodhan Linux - Networking 7 02-15-2007 11:28 PM
OpenVPN problem Rognon Linux - Networking 2 09-25-2006 07:33 PM
Openvpn problem kingisthebest Linux - Networking 1 03-07-2006 06:23 AM

All times are GMT -5. The time now is 09:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration