LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2007, 03:05 PM   #16
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112

There are few things worth knowing

(1) The "#" infront of any line in menu.lst is to disable it. Such line is used for commentary only and will not be executed by Grub.

(2) This line
Code:
gfxmenu /boot/grub/message.cristal
should be disabled temporarily by a "#" like this
Code:
#gfxmenu /boot/grub/message.cristal
The reason is simple . You need a Grub prompt to help you to resolve the booting problem but the gfxmenu robs you of the possibility to activate the Grub prompt.

Once the above line has been disabled, on a reboot you can activate a Grub prompt by pressing the "c" key on seeing the booting screen.

(3) The instruction I have given in Post #7 has not been follow. In particular
Code:
mkdir /mnt/sda1
if you do not make a subdirectory /mnt/sda1 of course Linux would complain "No such file or directory". The idea is you mount the sda1 device (with xp partition inside) on a temporary subdirectory of your the LInux filing system.

If you correct Item (2) you should be able to get a Grub prompt.

Your XP is being booted by these lines in menu.lst
Code:
# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1
You can manually boot XP by the similar commands in a Grub prompt
Code:
root (hd0,0)
chainloader +1
boot
The statements that I did not use are optional but the "boot" statement is needed for every manual booting. I can't guarantee it will boot but Grub will inform you any line that it cannot comply with and so this will enable for you to pin point the exact command that is causing the problem

Please report the finding.
 
Old 07-07-2007, 06:32 AM   #17
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Re: Beats me?

Very sorry for the redundancy of my menu.lst, but since I have an well defined idea about what is important or not, I've reported it as it is.
I've tried both your suggestions. I've commented out the statements "Other operating systems" and "root" and rebooted. No effect. Ntfs partition remains blocked. In rescue mode, I've changed the statement "root (hd0,0) to (hd0,1)and rebooted. As I choose Windows XP i have this output:
"
root(hd0,1)
filesystem type is fat, partition type 0xc
savedefaults
makeactive
chainloader +1
Non system disk press any key...
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER"
So I have restored the old root (hd0,0).

Thanks anyway, and hope to have your suggestions.
The forum is great!
unconcrete

PS.: Now this is my current menu.lst. I hope to have reported the right lines.
gfxmenu /boot/grub/message.cristal
# menu.lst - See: grub(8), info grub, update-grub(8)
...
## default num
default 0
## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
...
timeout 10
...
# Pretty colours
color cyan/blue white/blue
...
### BEGIN AUTOMAGIC KERNELS LIST
...
## ## End Default Options ##
#
title Ubuntu, kernel 2.6.17-10-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/sda6 ro quiet splash
initrd /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title Ubuntu, kernel 2.6.17-10-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/sda6 ro single
initrd /boot/initrd.img-2.6.17-10-generic
boot

title Ubuntu, memtest86+
root (hd0,5)
kernel /boot/memtest86+.bin
quiet
boot
### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1
 
Old 07-07-2007, 07:52 AM   #18
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
enrico_dvchp,

I don't think we understand each other.

Let's try your bits first

In the Post #16 I have suggested to you to disable the fgxmenu statement temporary by adding a "#" in front. This allows you to claim it back at any future time by removing the "#" when everything works OK. Without the fgxmenu statement you can manually boot up XP, by instructions supplied in the latter part of post #6. Your menu.lst tells us that you don't want to do that. The fgxmenu, according to your post #1, seems to have caused all these problems but you apparently rather stick with it.

When you manually boot a system Grub interprets each line and shout out an error message if it can't complies. That would have enabled you to identify the exact line Grub has found the error.

No you rather not to have the capability of manual booting by keeping the fgxmenu.

In your post #17 you tell Grub the root is (hd0,1), which is your second partition sda2 and Grub reported a fat partition Type "c" has been found. There is no boot loader inside it and so Grub failed. My proposed instruction is to boot to root (hd0,0) and I don't know why you choose a different one.

You said you restored the old (hd0,0) but we are in the dark as to if it boots successfully now or not and if not what error did you get.

Now the bit that I have difficulty with

Linux, or more precisely Grub, has been able to see sda1 and knows it is a ntfs partition with partition ID 7. There is no error reported by Grub and you can use Linux to post all the necessary information here. Therefore you can in Linux mount the sda1 partition manually as suggested in post #12 (which you missed out the mkdir statement so it didn't work).

Your last post keeps saying "Ntfs partition remains blocked". Does this means in Ubuntu you can see the ntfs folder but it is locked by Ubuntu? or you just have a fundamental problem of booting the XP up?

My confusion is Ubuntu in a standard installation disallows you log in as root and so without root privilege the ntfs folder is "always" locked to an ordinary user. That is the security feature of Ubuntu and no doubt that must have been the reason why you go to bed with it.

Have you tried to mount it and take a peek inside as a root user(which you can obtain by command "sudo su" at the terminal)?

In my suggestion in Post #12 of
Code:
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1
ls /mnt/sda1
the red line is meant to confirm if you can actually see the ntfs partition or not.

Thus without confirmation and more relevant information we are powerless to advise you further because your ntfs partition may be accessible but you didn't used the suggested commands. Your XP boots but you varied the command or not reporting the response.

You must help us with the appropriate information first so that we can help you.

Last edited by saikee; 07-07-2007 at 07:53 AM.
 
Old 07-07-2007, 07:59 AM   #19
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
re to Post 7

I've commented out /boot/grub/message.cristal in menu.lst and created /mnt/sda1. At reboot, i can now have a grub console by pressing c so i've entered the command:
root (hd0,0) =>> Filesystem type unknown, partition type 0x7
chainloader +1
boot
escape and try grub again but nothing to do. Can't access ntfs and Windows XP. I've rebooted my system but it works as before.


unconcrete
 
Old 07-07-2007, 08:08 AM   #20
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
OK If I understand it correctly Grub has no complaint but nothing was delivered. Grub can't read a ntfs partition so it always report it as Filesystem type unknown, but by saying the partition type 0x7 means it is a ntfs partition and so the correct one has been picked up by Grub.


Now you also confirm /mnt/sda1 was made successfully. Did you mount it and can you "list" its content by the "ls" command?

If you get anything at all from "ls /mnt/sda1" that means the internal content is alright.

Lastly I take it XP doesn't boot and there is no error message if you boot it automatically by pressing the choice in the Grub menu.

My current thought is if XP doesn't respond to Grub then the XP partition may have been damaged/overwritten at the front end. You could be in serious trouble if the sda1 cannot be mounted because that implies the filing indexing system may have been damaged to the point Linux cannot find the files for you.

However if sda1 can be mounted then there is a good chance your personal data is salvageable.

Last edited by saikee; 07-07-2007 at 08:13 AM.
 
Old 07-07-2007, 12:47 PM   #21
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
I've successfully created /mnt/sda1 but I can't mount it. I fact as I type ls /mnt/sda1 no output is reported:
armonica@persik-desktop:~$ ls /mnt/sda1
armonica@persik-desktop:~$

When I try to mount sda1 the system reports the following message:

armonica@persik-desktop:~$ sudo mount /dev/sda1 /mnt/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

armonica@persik-desktop:~$ dmesg | tail
[17182825.720000] NTFS-fs warning (device sda1): is_boot_sector_ntfs(): Invalid boot sector checksum.
[17182825.720000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17182825.720000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17182825.720000] NTFS-fs error (device sda1): ntfs_fill_super(): Not an NTFS volume.
[17182865.172000] NTFS-fs warning (device sda1): is_boot_sector_ntfs(): Invalid boot sector checksum.
[17182865.172000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17182865.172000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17182865.172000] NTFS-fs error (device sda1): ntfs_fill_super(): Not an NTFS volume.
[17183031.716000] Inbound IN=ppp0 OUT= MAC= SRC=17.82.29.158 DST=81.211.187.99 LEN=391 TOS=0x00 PREC=0x20 TTL=53 ID=55308 PROTO=UDP SPT=30738 DPT=1026 LEN=371
[17183107.500000] APIC error on CPU0: 40(40)
armonica@persik-desktop:~$
---
The row "[17182825.720000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Primary boot sector is invalid." tells me big troubles.

I think I have to recover the whole Windows partition.
I'll search for software to do it if possible.
Thanks for your patience.

Enrico_Dvchp +
Unconcrete

 
Old 07-07-2007, 06:38 PM   #22
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
enrico_dvchp,

I think that is the end of the road for the Linux side. You may want to try the Windoze side by running the hard disk in another Windows computer to see if it can be read but I doubt that very much.

The error messages suggest the filing index in the superblock or boot sector is "dodgy". You can only inflict damage to this secure area by commands operating on the hardware directly like "dd". If you can remember how you did it you stand a better chance to rescue that partition.

Good luck to your rescue work and let us know if you overcome it as we all come here to learn.
 
Old 07-08-2007, 04:05 AM   #23
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Rescue ntfs

I'll try to recover ntfs but i think i'll be forced to reinstall first XP and after Edgy.
Anyway thanks for now.

enrico_dvchp
 
Old 07-10-2007, 03:28 PM   #24
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
ntfs disappaired after grub reinstall

I've followed your suggestion and now I'm using my old Hiren-BootCD -All in One and I have good news and bad. The good one is that now Grub starts XP as before I reinstalled it. The bad is that NTFS is still not visible inside Ubuntu environment. I've followed this steps.
1) I've checked my hd sectors for defects, and it seems there is no error.
2) I've used the cd utility Partition Table Disk Doctor 3.0 to try a partition restore.
Actually PTDD had found some partition errors. Now I've modified only the ntfs partition since the others works well. in details:
ntfs partition = C starts at Cyl 0 Head 1 Sector 1 and ends to Cylinder 9248 Head 254 Sector 563 I've choosed the fixboot option and now Windows works! Wow! Victory, I thoght. Unfortunately once Ubuntu has started /mnt/sda1 opens an empty window. More work to do. Maybe it depends on a n error in my etc/fstab. This is the current fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda6
UUID=a6515639-89a1-4753-a488-94309cc1ec80 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=E4C0300AC02FE212 /media/pippo ntfs defaults,nls=utf8,umask=0222,gid=46 0 0
#
# /dev/sda2
UUID=1006-16B2 /media/pluto vfat defaults,nls=utf8,umask=0000,gid=46 0 0
#
# /dev/sda3
# UUID=c0ec6d7e-f4b4-40d5-ab11-a04b99ec3392 /media/sda3 ext3 defaults 0 2
# /dev/sda5
UUID=9206b41a-6f52-477e-8394-bdfadc71329e none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdc /media/cdrom1 udf,iso9660 user,noauto 0 0
# /dev/sda2 /media/pluto vfat defaults,nls=utf8,umask=0000,gid=46 0 0
/dev/sda5 /media/sda5 swap defaults 0 0
...

It seems Edgy Eft needs the statements UUID. I'm studing the meaning of these instructions not present in Dapper. The strange is that /media/pippo (ntfs works well and /media/pluto (vfat) works only as a link to the sda2 directory.
When I try sudo mount -a the output is :
armonica@persik-desktop:~$ sudo mount -a
Password:
mount: wrong fs type, bad option, bad superblock on /dev/disk/by-uuid/1006-16B2,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
I'd like to know if I am doing a basic error in fstab setting for pluto.

Thanks in advance

Enrico_dvchp
 
Old 07-12-2007, 01:40 PM   #25
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Hi again.
I've tried more ways to make visible on the desktop myvfat partition but it's enough frustrating. I know the partition is mounted. This depends on this terminal output:
armonica@persik-desktop:~$ sudo mount /dev/sda2 /media/pluto
mount: /dev/sda2 already mounted or /media/pluto busy
mount: according to mtab, /dev/sda2 is already mounted on /media/pluto
I know the fat partition has some problem caused probably by Partition Magic, that once I had the bad idea to use. Maybe the best thing is to delete and make another fat32 partition. This is my last attempt on fstab to make my Edgy able to understand the fat32 partition as a volume not as a directory. Failed.
# /dev/sda2
UUID=1006-16B2 /media/pluto vfat defaults,utf8,umask=007,fmask=0111,dmask=0000,gid=46 0 0
...
Other suggestions?

Enrico_dvchp
 
Old 07-12-2007, 02:18 PM   #26
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
When you say your partition invisible in /media/pluto what exactly do you mean?

Are you just complaining you cannot access its content because you have no permission to do so?

You can view its content in a terminal by command
Code:
sudo ls /media/pluto
Your fstab indicates the partition to be mounted for access by groups with gid=46. Unless you belong to that group or in root the content should be denied to you.
 
Old 07-12-2007, 05:21 PM   #27
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Rebuilding Grub after Gfxboot

I can see now the content of my windows partitions then the main problem is solved. But even if the computer recognizes /media/pippo, and report it on the desktop not the same worths for /media/pluto (fat32). I know I can access pluto and pippo but I don't understand why pippo is displayed as a proper icon on the desktop and pluto can't do it. I can access it only in this way:
armonica@persik-desktop:/media/pluto$ cd /media/pluto
armonica@persik-desktop:/media/pluto$ ls /media/pluto
*.*
... or by using a file manager.

Can I create an automatic icon for my fat 32 partition?
Before reformatting it, I'd like to know if this bug can be solved by a fstab command I don't know.
Thanks a lot anyway. Sorry for my terrible english.

Bye, Enrico_dvchp


 
Old 07-12-2007, 06:17 PM   #28
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
The correct way to find file is always by the file manager.

If you want to see the device sda2 icon in the desktop of user , say, armonica instead of /media/pluto just change
Code:
# /dev/sda2
UUID=1006-16B2 /media/pluto vfat defaults,nls=utf8,umask=0000,gid=46 0 0
to
Code:
# /dev/sda2
UUID=1006-16B2 /home/armonica/Desktop vfat defaults,nls=utf8,umask=0000,gid=46 0 0
 
Old 07-14-2007, 02:45 PM   #29
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Solved!

I've saved my Fat32 partition and I've proceeded to fix the Partition Table Disk Doctor bug on it. I remember PTDD claimed Fat32 partition started at sector 16418430 even if its correct value was 184585185. Once rebooted, I've entered Ubuntu and used System>Adm.>Gnome Partition Editor.
I've deleted my old fat 32 partition and created another one.
Rebooted and followed the steps:
sudo mkdir /media/pluto
opened fstab to check sda2 settings:
UUID=1006-16B2 /media/pluto vfat defaults,utf8,umask=0000,fmask=0111,dmask=0000 0 0
Then: sudo mount -a
UUID=1006-16B2 /dev/sda2 not found.
So angrily, I've typed vol_id -v /dev/sda2
and the result is...
ID_FS_USAGE=filesystem
ID_FS_TYPE=vfat
ID_FS_VERSION=FAT32
ID_FS_UUID=4699-0A13
...
Finally, I've changed the UUID value in fstab and rebooted.
Now Ubuntu recognizes the id of Pippo and Pluto.
I ask myself... what was so wrong in the old-fashioned Dapper fstab way? That's true, personal values don't worth for all, but it is the beauty of Linux.
Anyway,
bye soon.

Enrico_dvchp
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost NTFS partition? Jongi SUSE / openSUSE 12 07-04-2005 10:21 AM
HELP PLEASE!!! Lost NTFS Partition frijj2k Linux - General 9 05-27-2005 11:44 AM
I lost my NTFS partition by mistake using GRUB yoonsangkyun Linux - Newbie 6 06-03-2004 08:53 PM
I lost my NTFS partition by reinstalling GRUB yoonsangkyun Linux - General 4 01-22-2004 03:25 PM
Lost XP HPFS/NTFS partition ajkhan Linux - General 3 09-19-2003 08:54 AM


All times are GMT -5. The time now is 04:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration