LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-03-2007, 01:21 PM   #1
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Rep: Reputation: 15
Ntfs partition lost after reinstall grub


Hi all,
I have an Athlon 64 3700+\Nvidia Geforce FX5500 + Ubuntu Edgy Eft.
I have dual booted well both Linux and Windows XP until yesterday. The prob arose as I installed gfxboot to have a Suse-like Grub. I have not had the good idea to take a backup of my mbr by using the dd command.
I hope it is possible to recover my XP partition with your suggestions.
I can give you some information about my o.s..
---------------------------------------------------------CURRENT PARTITIONS ----------------------------------------
armonica@persik-desktop:~$ sudo fdisk -l
Password:
Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/sda1 * 1 9249 74292561 7 HPFS/NTFS # I can't have any access to it. The others works well now.#
/dev/sda2 9250 11531 18330165 c W95 FAT32 (LBA)
/dev/sda4 16145 24321 65681752+ 5 Extended
/dev/sda5 16145 16291 1180746 82 Linux swap / Solaris
/dev/sda6 16292 24321 64500943+ 83 Linux
---------------------------------------------------------CURRENT EDGY FSTAB----------------------------------------
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda6
UUID=a6515639-89a1-4753-a488-94309cc1ec80 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=E4C0300AC02FE212 /media/pippo ntfs defaults,nls=utf8,umask=0222,gid=46 0 0
# /dev/sda2
UUID=1006-16B2 /media/pluto vfat defaults,utf8,umask=0000,gid=46 0 0
# /dev/sda3
# UUID=c0ec6d7e-f4b4-40d5-ab11-a04b99ec3392 /media/sda3 ext3 defaults 0 2
# /dev/sda5
UUID=9206b41a-6f52-477e-8394-bdfadc71329e none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdc /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/sda2 /media/pluto vfat defaults 0 0
/dev/sda1 /media/pippo ntfs nls=iso8859-1,users,umask=0222,user,ro 0 0
/dev/sda5 /media/sda5 swap defaults 0 0
------------------------------------ MOUNT ERRORS-------------------------------------------------------------
armonica@persik-desktop:~$ sudo mount -a
Password:
mount: special device /dev/disk/by-uuid/E4C0300AC02FE212 does not exist
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
----------------------------------------------DMSG OUTPUT ----------------------------------------------------------
armonica@persik-desktop:~$ dmesg | tail
[17180099.296000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180099.296000] NTFS-fs error (device sda1): ntfs_fill_super(): Not an NTFS volume.
[17180216.748000] NTFS-fs warning (device sda1): is_boot_sector_ntfs(): Invalid boot sector checksum.
[17180216.748000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180216.748000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180216.748000] NTFS-fs error (device sda1): ntfs_fill_super(): Not an NTFS volume.
[17180247.524000] NTFS-fs warning (device sda1): is_boot_sector_ntfs(): Invalid boot sector checksum.
[17180247.524000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180247.524000] NTFS-fs error (device sda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180247.524000] NTFS-fs error (device sda1): ntfs_fill_super(): Not an NTFS volume.
---------------------------------------------------------------------------------------------------

Thanks in advance,

unconcrete
 
Old 07-04-2007, 10:09 PM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
According to your fdisk -l listing, it doesn't look like the partition structure is whacked. If you have ntfsprogs installed, you could check it out with
ntfsinfo -m /dev/sda1

There is an ntfsfix program which might be able to fix it enough for the windows program to check the partition and repair it.

You can also try the "errors=continue" option instead of "errors=recover". ( These two options are listed in the kernel's ntfs.txt file, but not in the mount manpage.)

Last edited by jschiwal; 07-04-2007 at 10:12 PM.
 
Old 07-05-2007, 01:54 PM   #3
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Hi,
this is the output of ntfsinfo:
armonica@persik-desktop:~$ ntfsinfo -m /dev/sda1
Unknown option '/dev/sda1'.
You must specify exactly one device.

Usage: ntfsinfo [options] -d dev
-d dev --device dev The ntfs volume to display information about
-i num --inode num Display information about this inode
-F file --file file Display information about this file (absolute path)
-m --mft Dump information about the volume
-t --notime Don't report timestamps

-f --force Use less caution
-q --quiet Less output
-v --verbose More output
-V --version Display version information
-h --help Display this help

Developers' email address: linux-ntfs-dev@lists.sourceforge.net
Linux NTFS homepage: http://linux-ntfs.sourceforge.net
----------------------------------------------------------------
At the time the utility doesn't recognize my hard drive or at least, it finds a linux partition and a hard drive but it can't find the first partition of the only hd (sda1) the ntfs one.
Other suggestions?

unconcrete
 
Old 07-05-2007, 02:19 PM   #4
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Partition structure isn't showing sda3 and there is a hole in the partition structure evident from fdisk. However fstab is showing sda3. Also fstab has two entries for sda5. Not sure what happens here.

You might try commenting out the fstab entry for sda1 and replacing it with a line like this:
Code:
/dev/sda1 /media/pippo ntfs user,umask=0,noauto,exec,iocharset=is
o8859-1,owner 0 0
I don't know if that will help you, but it is the "classic" way to mount a drive and therefore might be more reliable than the UUID method which, after all, is claiming that the device doesn't exist.

Last edited by jiml8; 07-05-2007 at 02:21 PM.
 
Old 07-05-2007, 03:05 PM   #5
Enochs
Member
 
Registered: Jun 2007
Location: Georgia
Distribution: Fedora
Posts: 50

Rep: Reputation: 17
Does the new Grub start Linux?

Good news. The new Suse-Grub would not have altered your partions at all so your data is still there...safe and sound. You just have to find it. Is the new Suse-Grub working?...Can you boot into Linux? If so then please post your /boot/grub/menu.lst file? You may just need to identify your Windows OS in this file if it was over written when you installed the new Grub.

Last edited by Enochs; 07-05-2007 at 04:54 PM.
 
Old 07-05-2007, 03:18 PM   #6
Enochs
Member
 
Registered: Jun 2007
Location: Georgia
Distribution: Fedora
Posts: 50

Rep: Reputation: 17
A Link...

Here is a link from someone with a similar problem. Near the bottom there are several good sugesstions.

https://bugs.launchpad.net/ubuntu/+s...rub/+bug/21175


When you install grub in the first sector of Windows partition, ex. /dev/sda1 or /dev/hda1, you will get an error 17, which means grub does not recognize the NTFS (Windows) file system. These are the errors I see above. Grub should be installed in /dev/sda and not sda1. please post your boot/grub/menu.lst file.

If your menu.lst file is correct and Grub wasn't loaded in /dev/sda1 by mistake then I would rebuild my master boot record by running the fixmbr command followed by the fixboot command. This will kill GRUB and boot you into Windows using the Windows default bootloader.

Jay

Last edited by Enochs; 07-05-2007 at 04:57 PM.
 
Old 07-05-2007, 03:59 PM   #7
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I would do two things

(1) I would try to boot it manually. Under the normal circumstance in Ubuntu's Grub screen pressing the "c" key will drop the user into a Grub shell. If this is the case XP will fire up if it is any good by commands
Code:
root (hd0,0)
chainloader +1
boot
If Ubuntu's Grub screen has been replaced by a graphic screen then I would make a bootable Grub floppy or Grub CD to do the same job until I am satisfied my XP is no longer bootable. The bootable Grub floppy and CD can be made in accordance with Grub Manual Chapter 3.1 and 3.4, involving copying only 2 and 1 files respectively.

(2) I would mount the partition manually and check if I could access it by another Linux. This can be done in an installed Linux or just from a Live CD. In root terminal
Code:
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1
ls /mnt/sda1
 
Old 07-06-2007, 06:26 AM   #8
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
You need to run ntfsinfo as root so it has rights to read the device.

Skipping to /dev/hda4 is normal. That means it is the extended partition. "There can be only one."
 
Old 07-06-2007, 11:11 AM   #9
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Quote:
Originally Posted by jschiwal
Skipping to /dev/hda4 is normal. That means it is the extended partition. "There can be only one."
Not true.

There can be only one extended partition but it does not have to be the last one in the partition table. It can be any of them, and you can have one or more normal physical partitions after it if you wish.

And if you read the output of the fdisk, you will see that the cylinder boundaries clearly show a hole in the partition table, with a big gap between the end of sda2 and the beginning of sda4.

You need to be certain of your facts before pronouncing them.
 
Old 07-06-2007, 11:34 AM   #10
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Grub can't find ntfs

Quote:
Originally Posted by Enochs
Good news. The new Suse-Grub would not have altered your partions at all so your data is still there...safe and sound. You just have to find it. Is the new Suse-Grub working?...Can you boot into Linux? If so then please post your /boot/grub/menu.lst file? You may just need to identify your Windows OS in this file if it was over written when you installed the new Grub.
Yes, my new grub is working but only for Linux. This is my /boot/grub/menu.lst:
gfxmenu /boot/grub/message.cristal
# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=a6515639-89a1-4753-a488-94309cc1ec80 ro
# kopt_2_6=root=/dev/sda6 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,5)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##
# Splashimage
# foreground = 0000ff
# background = ffffff
# splashimage=(hd0,5)/boot/grub/splashimages/hpp.xpm.gz

title Ubuntu, kernel 2.6.17-10-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/sda6 ro quiet splash
initrd /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title Ubuntu, kernel 2.6.17-10-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/sda6 ro single
initrd /boot/initrd.img-2.6.17-10-generic
boot

title Ubuntu, memtest86+
root (hd0,5)
kernel /boot/memtest86+.bin
quiet
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
# title Ubuntu, kernel 2.6.15-27-386 (on /dev/sda3)
# root (hd0,2)
# kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/sda3 ro quiet splash
# initrd /boot/initrd.img-2.6.15-27-386
# savedefault
# boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
# title Ubuntu, kernel 2.6.15-27-386 (recovery mode) (on /dev/sda3)
# root (hd0,2)
# kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/sda3 ro single
# initrd /boot/initrd.img-2.6.15-27-386
# savedefault
# boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
# title Ubuntu, kernel 2.6.15-23-386 (on /dev/sda3)
# root (hd0,2)
# kernel /boot/vmlinuz-2.6.15-23-386 root=/dev/sda3 ro quiet splash
# initrd /boot/initrd.img-2.6.15-23-386
# savedefault
# boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
# title Ubuntu, kernel 2.6.15-23-386 (recovery mode) (on /dev/sda3)
# root (hd0,2)
# kernel /boot/vmlinuz-2.6.15-23-386 root=/dev/sda3 ro single
# initrd /boot/initrd.img-2.6.15-23-386
# savedefault
# boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda3.
# title Ubuntu, memtest86+ (on /dev/sda3)
# root (hd0,2)
# kernel /boot/memtest86+.bin
# savedefault
# boot

Thank you and bye soon

unconcrete
 
Old 07-06-2007, 11:53 AM   #11
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Enochs
Here is a link from someone with a similar problem. Near the bottom there are several good sugesstions.

https://bugs.launchpad.net/ubuntu/+s...rub/+bug/21175


When you install grub in the first sector of Windows partition, ex. /dev/sda1 or /dev/hda1, you will get an error 17, which means grub does not recognize the NTFS (Windows) file system. These are the errors I see above. Grub should be installed in /dev/sda and not sda1. please post your boot/grub/menu.lst file.

If your menu.lst file is correct and Grub wasn't loaded in /dev/sda1 by mistake then I would rebuild my master boot record by running the fixmbr command followed by the fixboot command. This will kill GRUB and boot you into Windows using the Windows default bootloader.

Jay
I think i've actually installed grub in sda1. This is my boot/grub/menu.lst:
---------------------------
gfxmenu /boot/grub/message.cristal
# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=a6515639-89a1-4753-a488-94309cc1ec80 ro
# kopt_2_6=root=/dev/sda6 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,5)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
---------------------------------------------------------

unconcrete
 
Old 07-06-2007, 12:05 PM   #12
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by saikee
I would do two things

(1) I would try to boot it manually. Under the normal circumstance in Ubuntu's Grub screen pressing the "c" key will drop the user into a Grub shell. If this is the case XP will fire up if it is any good by commands
Code:
root (hd0,0)
chainloader +1
boot
If Ubuntu's Grub screen has been replaced by a graphic screen then I would make a bootable Grub floppy or Grub CD to do the same job until I am satisfied my XP is no longer bootable. The bootable Grub floppy and CD can be made in accordance with Grub Manual Chapter 3.1 and 3.4, involving copying only 2 and 1 files respectively.

(2) I would mount the partition manually and check if I could access it by another Linux. This can be done in an installed Linux or just from a Live CD. In root terminal
Code:
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1
ls /mnt/sda1
I've tried the second way first, this is the output:
armonica@persik-desktop:~$ mount/dev/sda1 /media/pippo
bash: mount/dev/sda1: No such file or directory
armonica@persik-desktop:~$ mount/dev/sda1 /media/sda1
bash: mount/dev/sda1: No such file or directory
armonica@persik-desktop:~$ ls /media/sda1
At the moment it is no possible to mount normally sda1.
Now I'll get the grub manual to know how to build a grub recue cd.

Thanks,
unconcrete
 
Old 07-06-2007, 12:38 PM   #13
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jiml8
Not true.

There can be only one extended partition but it does not have to be the last one in the partition table. It can be any of them, and you can have one or more normal physical partitions after it if you wish.

And if you read the output of the fdisk, you will see that the cylinder boundaries clearly show a hole in the partition table, with a big gap between the end of sda2 and the beginning of sda4.

You need to be certain of your facts before pronouncing them.
In my system, the last partion is actually an extended one. Until now anyway all has been working well. The gap between the partition depends on the fact I've created a reiser partition to install Fedora or another distro, but since I've created more than 4 partitions, I've deleted it and left the space as unallocated for future use.
Have I to remove the unallocated space between VFAT and ext3 partitions?
This is the scheme:
/dev/sda1 --ntfs -- pippo -- 70GB -- boot
/dev/sda2 --fat32-- pluto -- 17,48GB --lba
/dev/sda3 --unallocated -- 35,34GB
/dev/sda4 --extended -- 62,64GB
/dev/sda5 --swap --1,13 GB
/dev/sda6 --ext3 --/,/dev/.static/dev --61,51 GB
 
Old 07-06-2007, 12:43 PM   #14
enrico_dvchp
Member
 
Registered: Aug 2005
Location: firenze
Distribution: ubuntu
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jiml8
Partition structure isn't showing sda3 and there is a hole in the partition structure evident from fdisk. However fstab is showing sda3. Also fstab has two entries for sda5. Not sure what happens here.

You might try commenting out the fstab entry for sda1 and replacing it with a line like this:
Code:
/dev/sda1 /media/pippo ntfs user,umask=0,noauto,exec,iocharset=is
o8859-1,owner 0 0
I don't know if that will help you, but it is the "classic" way to mount a drive and therefore might be more reliable than the UUID method which, after all, is claiming that the device doesn't exist.
This is my fstab now. Do you think it is right?
---------------------------------------------------
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda6
UUID=a6515639-89a1-4753-a488-94309cc1ec80 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
#UUID=E4C0300AC02FE212 /media/pippo ntfs defaults,nls=utf8,umask=0222,gid=46 0 0
#
/dev/sda1 /media/pippo ntfs user,umask=0,noauto,exec,iocharset=iso8859-1,owner 0 0
# /dev/sda2
UUID=1006-16B2 /media/pluto vfat defaults,utf8,umask=0000,gid=46 0 0
# /dev/sda3
# UUID=c0ec6d7e-f4b4-40d5-ab11-a04b99ec3392 /media/sda3 ext3 defaults 0 2
# /dev/sda5
UUID=9206b41a-6f52-477e-8394-bdfadc71329e none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdc /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/sda2 /media/pluto vfat defaults 0 0
# /dev/sda1 /media/pippo ntfs nls=iso8859-1,umask=0222 0 0
/dev/sda5
-------------------------------------------------

unconcrete
 
Old 07-06-2007, 01:24 PM   #15
Enochs
Member
 
Registered: Jun 2007
Location: Georgia
Distribution: Fedora
Posts: 50

Rep: Reputation: 17
Beats me?

Wow, that menu.list has the most commented lines I have ever seen! It makes for a long and confusing read. My menu.lst is no longer than this response. I have been informed that GRUB will give error 17 and not run at all if loaded in sda1 so this may not be the case, sorry. I didn't see anything obvious but before I close that file I would try two simple things, just for shits and giggles. Neither of these suggestions follows any logic so don't laugh when you read them but I am out of logical ideas. I wish I could have been of more help. I hope you find a solution.

1. Just above your Windows XP entry, GRUB placed these two lines:
title Other operating systems:
root

Comment them both out with #. reboot and select Windows XP.
I don't see a need for them and the keyword root...followed by no root??? Very odd. This entry should not affect the Windows XP entry below it but I would clean it up anyway. Reboot and try XP again before doing #2.

2. Change (hd0,0) to read (hd0,1)as shown below. hd0,0 should be correct so if it doesn't work then change it back. This shouldn't work but I googled another thread that stated this DID work for another person...then again I could find just about anything online if I looked long enough. I am curious to see if it works. Good luck.

title Microsoft Windows XP Professional
root (hd0,1)
savedefault
makeactive
chainloader +1

Last edited by Enochs; 07-06-2007 at 01:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost NTFS partition? Jongi SUSE / openSUSE 12 07-04-2005 09:21 AM
HELP PLEASE!!! Lost NTFS Partition frijj2k Linux - General 9 05-27-2005 10:44 AM
I lost my NTFS partition by mistake using GRUB yoonsangkyun Linux - Newbie 6 06-03-2004 07:53 PM
I lost my NTFS partition by reinstalling GRUB yoonsangkyun Linux - General 4 01-22-2004 02:25 PM
Lost XP HPFS/NTFS partition ajkhan Linux - General 3 09-19-2003 07:54 AM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration