LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2014, 07:08 PM   #1
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Rep: Reputation: Disabled
Noisy Keyboard makes mulltiple lettteers-what program fixes this?


Hi All:

10 years ago I had a small program that fixed the noisy keyboard issue and then I forgot about it. Now I need it again and can't find it. This is where I hit a key once and it will occasionally make two letters in what I type instead of just one. This is for my laptop and I don't want to use an external keyboard and channging the keyboard isn't that much fun. (double hit in the word channging, and it happened again a second time).

What is the name of the program that fixes this problem in linux?

Thanks to LQ for letting me ask the question! - Mike

p.s. not sure where to post this Question.

hp8730w running mint 17 cinnamon
 
Old 07-02-2014, 07:42 PM   #2
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 515

Rep: Reputation: 176Reputation: 176
From /etc/kbd/config:
Quote:
# rate and delay can get only specific values, consult kbdrate(1) for help
#KEYBOARD_RATE="30"
#KEYBOARD_DELAY="250"
Try adjusting the repeat rate.
 
Old 07-02-2014, 08:58 PM   #3
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Original Poster
Rep: Reputation: Disabled
The rate and delay don't come into play, I'm touch typing ppretty fast, if you want the measured speed, I used to type 50WPM coming out of high school on a manual typewriter.
 
Old 07-02-2014, 09:47 PM   #4
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 515

Rep: Reputation: 176Reputation: 176
In my previous post I should have said "try adjusting the delay".

Anyway, you can test to see if the delay is the problem by using xset to turn key repeat off:
Code:
$ xset r off  //turn auto repeat off
$ xset r on // turn repeat back on
I couldn't find what the default KEYBOARD_DELAY setting is (might depend on the keyboard), but if you find you need to adjust the delay you'll have to change /etc/kbd/config
 
Old 07-03-2014, 12:21 AM   #5
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Original Poster
Rep: Reputation: Disabled
Typing with the key repeat function on:
Thanks for telling me how to turn off the repeat. I did that and still got three repeats in the first two minutes I was tyyping. What I need is a program that changes the keyboard monitoring routine that requires the key to be pressed for at least a couple milliseconds before the buffer is stuffed with the key. And the number of milliseconds should be programmable so a reallly bad keyboard can have a higher bar to jump to make sure a key is pressed.

Now I'm going to type the same thing above with the key repeat off.
Thanks for telling me how to turn off the repeat. I did that and still got three repeats in the first two minutes I was typinng. What I need is a program that changes the keyboard monitoring routine that requires the key to be pressed for at least a couple milliseconds before the buffer is stuffed with the key. And the number of milliseconds should be programmable so a really bad keyboard can have a higher bar to jump to make sure a key is pressed.

Both paragraphs have a repeat, check out the word typing and a different key is repeated in the second paragraph in the same word.

Thanks! - Mike

By the way, cursoring around is a big pain with no key repeat.
 
Old 07-03-2014, 03:03 PM   #6
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 515

Rep: Reputation: 176Reputation: 176
One more thing to try.

From: man XkbSetBounceKeysDelay
Quote:
The BounceKeys control temporarily disables a key after it has been pressed, effectively "debouncing" the keyboard. The period of time the key is disabled after it is released is known as the BounceKeys delay.
I haven't used Cinnamon so I don't know the menus, but in Gnome it is under - System Settings->Universal Access->Typing. In KDE - System Settings->Accessibility->Keyboard Filters
 
Old 07-05-2014, 12:47 PM   #7
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Original Poster
Rep: Reputation: Disabled
Bouncekeys - This Q is almost solved (I'm looking for it)

Thanks norobro!

That sounds like it would work for what I need, THANKS (that's a big thanks).
I am going to start digging to try to find it and get it to work in cinnamon. I didn't find it in the cinnamon menus, maybe I just didn't look hard enough. I will re-check.
You could save me some digging trouble if you know the name of the package or executable, I can't seem to find bounce[anything keybboard] in synaptic or apt-get. Next comes a google search.

Code:
mint@mint ~ $ sudo apt-get install XkbSetBounceKeysDelay
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package XkbSetBounceKeysDelay
mint@mint ~ $ 
mint@mint ~ $ sudo apt-get install bouncekeys           
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package bouncekeys
mint@mint ~ $ 
mint@mint ~ $ man XkbSetBounceKeysDelay
No manual entry for XkbSetBounceKeysDelay
I'm now on the trail of getting "bouncekeys" to work in cinnamon. I'm now looking for the executable or package name.

THANKS norobro! - Mike
 
Old 07-06-2014, 02:44 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
And you have tried disassembling the keyboard and using soap and water or trichloroethane
 
Old 07-06-2014, 07:10 PM   #9
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Original Poster
Rep: Reputation: Disabled
John VV said: "And you have tried disassembling the keyboard and using soap and water or trichloroethane"

and normally I would think this a good idea, I've done that with Ataris and Nintendos(I used dish soap). But I don't know where to find Trico anymore.

This machine is a HP Laptop 8530W. Quite a nice machine, but I haven't ever heard of anyone taking the keyboard apart. Sounds like a good idea to me, I could put some dish soap in the sink, but that would require complete dissassembly of the keyboard and I'm a little afraid to do that. This is my main production machine. Could I really take it apart with no probllems, without destroying it? I like that solutionn if I could accompllish it.

- Mike
 
Old 07-06-2014, 07:34 PM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
seeing as 1-1-1 tri... is basically ether
look at the auto store for "starter fluid "
But look to see what ELSE is ALSO in it

it was all over the place years ago i used BIG bottles of the stuff in the photo industry

Last edited by John VV; 07-06-2014 at 07:37 PM.
 
Old 07-07-2014, 07:06 AM   #11
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,602

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
More likely you need to clean the keyboard.

Noisy keyboards are usually caused by conductive crap that got on the circuit board causing multiple key clicks when bouncing around under a key pad.

You can try tipping the keyboard on one end, then tapping the other on a table. This may dislodge the trash and drop it to the end next to the table.
 
Old 07-07-2014, 09:17 AM   #12
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 4,087
Blog Entries: 10

Rep: Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521Reputation: 1521
If you have access to compressed air, it might be helpful to blast away at it with that. We have nozzles around our work because the technicians use them to blow away the filings and stuff when they're assembling boards. A really helpful thing for laptops is to blast air down into the keyboard and any other place to try and force dust out of the machine or get crud blasted away. Maybe a brush at the same time if you can find one which will extend down to the base of the keyboard so you can help coerce any stubborn stuff out of there.
 
Old 07-09-2014, 01:47 AM   #13
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Original Poster
Rep: Reputation: Disabled
Here is what I'm going to do. I'm going to try to fix it in software first and when it gets too bad for software to fix it anymore, then I will try the hardware fix. I might consider a vacuum cleaner hose, I'm afraid of compressed air around my production laptop.

The software I'm looking for is XkbSetBounceKeysDelay or bounckeys (if I can find how to use) either of them, these names thank you to 'norobro'. I guess that is a plan so I will mark this solved even though I haven't fixed this yet.

Thank You all!
 
Old 07-09-2014, 01:59 AM   #14
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Original Poster
Rep: Reputation: Disabled
[SOLVED] Noisy Keyboard makes mulltiple lettteers-what program fixes this?

My original question was to find the name of the program thaat solved my noisy keyboard issue.

norobro gave the names as XkbSetBounceKeysDelay and BounceKeys.

I found a helpful webpage for these terms at http://linux.die.net/man/3/xkbsetbouncekeysdelay, so my question was answered. That's why I'm changing the subject for this as solved(I hope that marks this as solved).

Now I have to figure how to use this, I'm now looking for a how-to.

Thanks! - Mike
 
Old 07-10-2014, 10:37 AM   #15
mikecolley
LQ Newbie
 
Registered: Apr 2014
Location: All Over USA
Distribution: Mint16 Cinnamon
Posts: 27

Original Poster
Rep: Reputation: Disabled
WinterTroubles showed me where it is at:

Located in Linux Mint 17 Cinnamon at: MENU > Preferences > System Settings > Accessibility > Typing > Bounce Keys

Thank You All! - Mike Colley
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting program with sudo makes it GTK3 Mr. Alex Arch 3 11-02-2013 10:08 AM
Alsa on games makes the keyboard and mouse respond with a 15 sec. delay Ac1db0rN Linux - Hardware 4 03-24-2005 04:13 PM
WUSB11 v2.8 makes my keyboard hang?? Shadowslayer Linux - Hardware 0 02-26-2005 11:16 AM
Keyboard/Mouse Input Freezes - Slackware 10 - Powerbutton fixes it johnp05 Linux - Hardware 0 08-22-2004 11:13 PM
Mulltiple SSL Virtual Hosts w/Apache jrbush82 Linux - Software 3 04-12-2004 03:49 PM


All times are GMT -5. The time now is 10:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration