LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-17-2015, 05:17 AM   #1
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
No System sound setting on debian with xfce desktop


I have installed a new Debian OS to try out the xfce desktop.
My radeon hdmi sound card needs non-free drivers and so I have no sound.
On my previous debian install with gnome desktop, I found a number of changes I had to make to get the sound working.

I have done all this with this new install with xfce.
However, one thing I haven't done yet is to change the System settings-Sound settings to use the hdmi sound card.
The problem is the xfce desktop doesn't have an icon for sound settings under System settings.

This is a bit weird. So I'm wondering if xfce has installed correctly or if it's missing a package so the System sound settings will show up.
Does anyone know what's going on?
 
Old 01-17-2015, 11:44 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Right0click on menu bar, select panel & look for Volume control then add it.
 
1 members found this post helpful.
Old 01-18-2015, 01:20 PM   #3
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by EDDY1 View Post
Right0click on menu bar, select panel & look for Volume control then add it.
This has been helpful.
I've added a sound icon to the 'panel' on the desktop.
It looks like pavucontrol and it is set to the hdmi sound card.
But still no sound.
 
Old 01-18-2015, 02:29 PM   #4
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Rather than trawl through your post history, it would be helpful if you could list the changes you have attempted with this installation.

Are you using pure ALSA or do you have pulseaudio as well?

Also, why did you set up a new system just for XFCE?

If you installed XFCE on your GNOME system, the login screen (GDM) gives you the option to run that if you wish (click on the cog-wheel icon next to the "Sign In" button).

Last edited by Head_on_a_Stick; 01-18-2015 at 02:29 PM. Reason: clarification
 
Old 01-23-2015, 07:09 PM   #5
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
I have finally managed to get the sound working.

The radeon sound card has a particular problem which is solved by adding its name to grub.cfg in /boot/grub. I did that.
It's necessary to ensure the /etc/apt/sources.list has 'contrib' and 'non-free' and then install 'firmware-linux'. I did that.
Change system sound settings on the desktop to radeon hdmi. This is a little difficult on xfce because the sound icon isn't present on system settings. But I was eventually able to add a sound icon to the 'task bar' on the desktop and change the setting to hdmi sound card.
Make sure alsamixer is unmuted and set to hdmi sound card. Which I also did.

But it was only when I installed pavucontrol and set that to hdmi sound card as well that I finally got sound!
So many tweaks!
 
Old 01-24-2015, 04:07 PM   #6
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Debian
Posts: 812

Rep: Reputation: 216Reputation: 216Reputation: 216
Quote:
Originally Posted by Higgsboson View Post
The radeon sound card has a particular problem which is solved by adding its name to grub.cfg in /boot/grub
Congratulations on solving this.

Note that grub.cfg should not be edited by hand. It'll be overwritten by your system the next time you run update-grub. This in turn will be run automatically sometimes (when the system update includes a kernel update).
If it is a kernel parameter you added you can make the change permanent by editing the parameter GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and then running update-grub (as root).
 
1 members found this post helpful.
Old 01-24-2015, 04:36 PM   #7
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by joe_2000 View Post
Congratulations on solving this.
Note that grub.cfg should not be edited by hand. It'll be overwritten by your system the next time you run update-grub. This in turn will be run automatically sometimes (when the system update includes a kernel update).
Well that's good to know.
If the sound stops working at any time, I'll know to look in the grub.cfg file first!

Quote:
If it is a kernel parameter you added you can make the change permanent by editing the parameter GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and then running update-grub (as root).
Wow, that's cool! Thank you very much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XFCE desktop question - What and/or where is this setting called? youniqueg33k Linux - Desktop 4 01-08-2015 11:30 AM
xfce / Debian Remote Desktop salsalinux Linux - Desktop 2 01-18-2014 01:20 PM
how to setup remote desktop on Debian 6 XFCE? xiongnu Debian 3 06-29-2012 01:05 PM
[SOLVED] Help >Opensuse 11.4 with XFCE desktop sound problem. Marcus. Linux - Newbie 4 07-20-2011 05:00 AM
Debian 6 Desktop wont load - xfce Gam3r21 Debian 4 03-23-2011 09:50 PM


All times are GMT -5. The time now is 06:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration