LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-25-2007, 12:20 AM   #1
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Rep: Reputation: 30
no sound, what next?


The only thing I can think of that I did to break my sound was I activated the "Audio Settings Management(Alsa-utils)" in the administration->services configuration editor. The next time I turned on the computer the sound would not work. I deactivated the audio settings management service but after a reboot I still don't get sound.

As far as errors are concerned... I can't seem to get any. I open totem to play a movie in debug mode and it is silent despite the fact that there is no sound.

#lspci | grep audio
Code:
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
#lsmod | grep snd
Code:
snd_intel8x0           34332  2 
snd_ac97_codec         98464  1 snd_intel8x0
ac97_bus                3200  1 snd_ac97_codec
snd_pcm_oss            44544  0 
snd_mixer_oss          17408  1 snd_pcm_oss
snd_pcm                79876  4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy           4740  0 
snd_seq_oss            32896  0 
snd_seq_midi            9600  0 
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
snd_mpu401              9256  0 
snd_mpu401_uart         9472  1 snd_mpu401
snd_rawmidi            25472  2 snd_seq_midi,snd_mpu401_uart
snd_seq                52592  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23684  3 snd_pcm,snd_seq
snd_seq_device          9100  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54020  14 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8672  1 snd
snd_page_alloc         10888  2 snd_intel8x0,snd_pcm
What should I do next? Thanks.
 
Old 11-25-2007, 04:02 AM   #2
gbj
Member
 
Registered: Jul 2003
Posts: 142

Rep: Reputation: 15
Well first of all make sure that your sound chip is enabled in your BIOS. Next I would open up a console and fire up "alsaconf". When you are finished with alsaconf use "alsamixer" to unmute the sound card, with the "m" button. Then use "alsactl store" to store your alsa settings so that they are restored at reboot. Remember that you have to use all these commands as root. ALSA can be problematic, but I hope this helps.
 
Old 11-25-2007, 09:09 AM   #3
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Original Poster
Rep: Reputation: 30
hi, thanks for the reply. I dont have alsaconf and my sound used to work until i changed the setting I mentioned earlier. Also my sound works on my other box I dual boot with, so it isn't bios or hardware related.

I could install alsaconf if i knew how, although, since my sound worked before and I didn't have it, i'm not so sure I need it.
 
Old 11-26-2007, 01:33 AM   #4
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
Maybe this link will help

https://help.ubuntu.com/community/De...gSoundProblems
 
Old 01-02-2008, 02:25 PM   #5
abrindell
LQ Newbie
 
Registered: Dec 2007
Location: Middle, Georgia
Distribution: Ubuntu 9.04
Posts: 15
Blog Entries: 1

Rep: Reputation: 0
Angry What's the solution?

Im having the same exact problem. I activated the alsa-mixer service and KABLAM! - no sound. I went into the alsa gui and verified everything was turned ON. But... nothing! The sound card is working fine. What's the fix for this? ANYONE?
 
Old 01-02-2008, 02:29 PM   #6
abrindell
LQ Newbie
 
Registered: Dec 2007
Location: Middle, Georgia
Distribution: Ubuntu 9.04
Posts: 15
Blog Entries: 1

Rep: Reputation: 0
Cool Here's the solution!

Quote:
Originally Posted by abrindell View Post
Im having the same exact problem. I activated the alsa-mixer service and KABLAM! - no sound. I went into the alsa gui and verified everything was turned ON. But... nothing! The sound card is working fine. What's the fix for this? ANYONE?
This is what worked for me!
http://www.ibiblio.org/pub/Linux/doc...und.html#ss7.3
The graphic mixer doesn't show the unmute button. You have to do it with the terminal window via commands.

BEst!
alec
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
no sound from sound blaster PCI sound card using mandrake-linux 10.1 box nila56 Linux - Hardware 2 05-29-2006 02:48 PM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 01:02 PM
FC2: Sound Card (SiS SI7012) Detect But Donot Play Sound rajanaeem Linux - Hardware 0 10-22-2004 03:41 PM
No Sound : request_module: failed /sbin/modprobe -- sound-slot-0. error = 256 Mebuh Linux - General 0 01-26-2004 07:51 AM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration