LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2013, 02:32 AM   #1
Cabroncito
LQ Newbie
 
Registered: Sep 2013
Posts: 18

Rep: Reputation: Disabled
No sound coming from my Fedora 19 laptop


Today I went to YouTube for the first time since I installed Fedora 19, and saw that I needed to install a missing Flash plugin in order to watch videos. I installed the plugin. Youtube videos then played fine, except no sound. I checked my sound settings and made sure everything was turned up/on, and tested both the left and right speakers using the troubleshooting tool. No sound from either. I've tried both the 'microphone' and 'internal microphone' options. Point me in the right direction?
 
Old 09-23-2013, 02:37 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
If I understand you correctly the Youtube business is a red herring. Your problem has nothing to do with the flashplayer plugin. You don't have any sound at all, right? Have you tried running alsamixer from a terminal? You can make sure all the settings for your card are correct. What audio system are you using (alsa? pulse? other?)?
jdk
 
Old 09-23-2013, 02:48 AM   #3
Cabroncito
LQ Newbie
 
Registered: Sep 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
Right--no sound whatsoever. Now that I re-read my post, it wasn't necessary to include the bit about Flash and youtube at all.

I'll start googling alsamixer, and how to look up the type of audio system. I just needed someone to give me a lead. Thanks.

BTW, love your sig.
 
Old 09-23-2013, 03:20 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Glad to be of service and thanks for the kind comment. The alsamixer is found in a package called alsa-utils in Debian. Perhaps its package has a similar name in Fedora.
jdk
 
Old 09-24-2013, 04:44 AM   #5
Cabroncito
LQ Newbie
 
Registered: Sep 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
Looks like I'm stuck again. I've been using Google for a while, but I can't determine the source of the problem.

Here's the info for my sound card:

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. Device 1297
Flags: bus master, fast devsel, latency 0, IRQ 43
Memory at feb3c000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

I have Alsamixer. When I go into Alsamixer and hit F6 for 'select sound card,' my choices are default, HDA Intel, and 'enter device name.' I've tested the speakers with both default and HDA Intel selected, but I still have no sound. Again, I've made sure all volume controls are turned up.

Also, here's this if it helps:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
Old 09-24-2013, 09:43 AM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Can you try this on a terminal
Code:
aplay *some .wav file*
and put the path and name of any .wav file on your system. Maybe an interesting error message will appear. Here's what that looks like on my system--
Code:
:~$ aplay /usr/share/sounds/alsa/Side_Left.wav
Playing WAVE '/usr/share/sounds/alsa/Side_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
and I hear a woman's voice saying "side left".
jdk
 
Old 09-24-2013, 12:16 PM   #7
Cabroncito
LQ Newbie
 
Registered: Sep 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
I tried that. Here's what I got:

aplay /home/dan/Downloads/hornytoads.wav
Playing WAVE '/home/dan/Downloads/hornytoads.wav' : Unsigned 8 bit, Rate 11000 Hz, Mono

Still no sound. It looks like Linux thinks it's playing the file without problems.
 
Old 09-24-2013, 12:52 PM   #8
Kuranes
LQ Newbie
 
Registered: Aug 2003
Location: Paris XII
Distribution: Xubuntu, Raspbian, Debian, Freebox OS
Posts: 13

Rep: Reputation: Disabled
Make sure alsamixer levels are not muted, since alsa mutes them by default after installation.
Look for "MM" at the bottom of output channels and press m to toggle it (OO means it's unmuted).

Last edited by Kuranes; 09-24-2013 at 12:53 PM.
 
Old 09-24-2013, 01:03 PM   #9
Cabroncito
LQ Newbie
 
Registered: Sep 2013
Posts: 18

Original Poster
Rep: Reputation: Disabled
It's working! It turned out that I just needed to go into the sound settings and switch from Analog Output/Amplifier to Analog Output/No Amplifier.
 
Old 09-25-2013, 12:58 AM   #10
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Well done! Persistence pays off, eh?
jdk
 
Old 09-25-2013, 11:15 AM   #11
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Slackware; Crunchbang.
Posts: 409
Blog Entries: 2

Rep: Reputation: 98
Quote:
Originally Posted by Cabroncito View Post
It's working! It turned out that I just needed to go into the sound settings and switch from Analog Output/Amplifier to Analog Output/No Amplifier.
How does one access those settings? I'm having a similar problem, after having installed a new sound card.....
 
Old 09-25-2013, 02:33 PM   #12
Kuranes
LQ Newbie
 
Registered: Aug 2003
Location: Paris XII
Distribution: Xubuntu, Raspbian, Debian, Freebox OS
Posts: 13

Rep: Reputation: Disabled
Quote:
Originally Posted by Sumguy View Post
How does one access those settings? I'm having a similar problem, after having installed a new sound card.....
If you use pulseaudio, pavucontrol is the "control panel" you might be looking for, where you can select the output (cf. Profiles in the Configuration tab).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 06:10 AM
No sound Coming out of my Laptop tamer79 SUSE / openSUSE 6 10-18-2008 03:50 PM
Sound Not Coming On Fedora 5 64 MY_INSATIBLE_THIRST Linux - Newbie 1 10-06-2006 09:34 AM
sound on my pc coming on one side of the speaker on fedora 5 64 MY_INSATIBLE_THIRST Linux - Hardware 0 10-02-2006 09:24 AM
fedora on laptop and sound firedude Linux - Laptop and Netbook 16 06-15-2004 12:53 PM


All times are GMT -5. The time now is 11:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration