LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2015, 08:14 AM   #1
peter576
Member
 
Registered: Nov 2009
Distribution: Debian 8 (64bit)
Posts: 32

Rep: Reputation: 0
Lightbulb NetworkManager applet won't connect to Internet


hi,
i have a 'Intel Corporation WiFi Link 5100' netcard, formly at start up the system wrote iwlwifi-5000-1, iwlwifi-5000-2, iwlwifi-5000-3, iwlwifi-5000-4, iwlwifi-5000-5 is missing. I downloaded them and put them in /lib/firmware, no the error message disappeared and i'm connected to my router, but i only have internet with ethernet, although signal strenght is 97%. What can be wrong? How can I solve this?
thank you!
 
Old 05-10-2015, 09:18 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,429

Rep: Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348
You give your distribution as Slackware, without a statement of the version in use.

You should not have needed to download the firmware for your wifi device, as it would have been included in the default full install of Slackware. Did you do some sort of minimal install?

Were you formerly using the internet only via the ethernet interface using a configuration in /etc/rc.d/rc.inet1.conf?
If so, then revert to a clean /etc/rc.d/rc.inet1.conf. http://www.linuxquestions.org/questi...9/#post5236776
 
Old 05-10-2015, 02:32 PM   #3
peter576
Member
 
Registered: Nov 2009
Distribution: Debian 8 (64bit)
Posts: 32

Original Poster
Rep: Reputation: 0
sorry, i have Debian version 8, i forget to set the distribution after reinstallation.
 
Old 05-10-2015, 02:42 PM   #4
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by peter576 View Post
i have Debian version 8
Rather than copying the firmware files manually, add the "contrib" & "non-free" components to your repository lines in /etc/apt/sources.list and then run:
Code:
# apt-get update
# apt-get install firmware-iwlwifi
https://wiki.debian.org/SourcesList#Component

If it still doesn't work, post the output of:
Code:
ip r
dmesg|grep -i iwl
lspci -knn|grep -iA2 net
 
Old 05-10-2015, 03:30 PM   #5
peter576
Member
 
Registered: Nov 2009
Distribution: Debian 8 (64bit)
Posts: 32

Original Poster
Rep: Reputation: 0
thank you. I added theese 2 blocks to sources.list
#added
deb http://ftp.de.debian.org/debian/ dists/Debian8.0 non-free
deb-src http://ftp.de.debian.org/debian/ dists/Debian8.0 non-free

#added
deb http://ftp.de.debian.org/debian/ dists/Debian8.0 contrib
deb-src http://ftp.de.debian.org/debian/ dists/Debian8.0 contrib

can this be correct?


# ip r
169.254.0.0/16 dev wlan0 scope link metric 1000
192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.2
192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.2

# dmesg|grep -i iwl
[ 2.018089] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[ 2.018152] iwlwifi 0000:03:00.0: irq 48 for MSI/MSI-X
[ 2.037590] iwlwifi 0000:03:00.0: firmware: direct-loading firmware iwlwifi-5000-5.ucode
[ 2.037749] iwlwifi 0000:03:00.0: loaded firmware version 8.83.5.1 build 33692 op_mode iwldvm
[ 2.082179] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[ 2.082184] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[ 2.082186] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[ 2.082189] iwlwifi 0000:03:00.0: Detected Intel(R) WiFi Link 5100 AGN, REV=0x54
[ 2.083614] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 2.168694] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[ 3.749243] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3.752274] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[ 3.851181] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[ 3.854263] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0

# lspci -knn|grep -iA2 net
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8057 PCI-E Gigabit Ethernet Controller [11ab:4380] (rev 10)
Subsystem: Sony Corporation Device [104d:906b]
Kernel driver in use: sky2
03:00.0 Network controller [0280]: Intel Corporation WiFi Link 5100 [8086:4232]
Subsystem: Intel Corporation WiFi Link 5100 AGN [8086:1301]
Kernel driver in use: iwlwifi
 
Old 05-10-2015, 03:39 PM   #6
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by peter576 View Post
thank you. I added theese 2 blocks to sources.list
#added
deb http://ftp.de.debian.org/debian/ dists/Debian8.0 non-free
deb-src http://ftp.de.debian.org/debian/ dists/Debian8.0 non-free

#added
deb http://ftp.de.debian.org/debian/ dists/Debian8.0 contrib
deb-src http://ftp.de.debian.org/debian/ dists/Debian8.0 contrib

can this be correct?
Not at all -- see this example:
https://wiki.debian.org/SourcesList#...8_.22Jessie.22

You should add "contrib" & "non-free" (without the quotation marks) immediately after the word "main" (on the same line).

Also, I don't think "Debian8.0" is a release version understood by APT -- replace that with "jessie" so that it looks like the example given above, ie:
Code:
deb http://ftp.de.debian.org/debian jessie main contrib non-free
deb-src http://ftp.de.debian.org/debian jessie main contrib non-free

deb http://ftp.de.debian.org/debian jessie-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main
Then use:
Code:
# apt-get update
# apt-get install firmware-iwlwifi
At any rate, your interface is already up & running (you should still install the firmware from the repositories so that is can be updated); I think the problem is that NetworkManager will always use the ethernet connection if the cable is connected.

Try either unplugging the cable or explicitly disabling the wired connection from the control panel.
 
Old 05-11-2015, 03:14 AM   #7
peter576
Member
 
Registered: Nov 2009
Distribution: Debian 8 (64bit)
Posts: 32

Original Poster
Rep: Reputation: 0
thank you,
now it works better but only for some seconds, and if i ping for example linux.org or google.com, it will know the IP address of the server, but it says 'destination host unreachable'
 
Old 05-11-2015, 02:34 PM   #8
lsalab
LQ Newbie
 
Registered: Jan 2009
Posts: 16

Rep: Reputation: 1
Quote:
Originally Posted by peter576 View Post
# ip r
169.254.0.0/16 dev wlan0 scope link metric 1000
192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.2
192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.2
From what I see here, you don't have a default gateway configured.

Also, I see that both the wireless and the ethernet have the same IP address '192.168.0.2'. This can cause you some issues if you are not using something like link aggregation or similar solutions. You should check that.

Try to set up the default gateway. For a temporary solution you could try this:

Code:
ip route add default via 192.168.0.1 dev wlan0
I assume that you gateway has '192.168.0.1' as the LAN IP address, change it if you need to.

If this works, you should change your networking configuration and add the default gateway.
 
  


Reply

Tags
firmware, intel wireless, internet, networkmanager, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add NetworkManager Applet 0.8.1 pauljanygodwin Linux - Desktop 0 12-14-2012 05:44 PM
Windowmaker and nm-applet (NetworkManager) simopal6 Linux - Software 1 11-20-2012 03:22 PM
NetworkManager applet janniz Slackware 3 07-26-2012 02:37 AM
NetworkManager Applet 0.7.0? Linuxkundi Slackware 1 09-13-2008 05:03 AM
NetworkManager won't connect wirelessly... jonrpick Linux - Newbie 3 05-20-2008 12:14 AM


All times are GMT -5. The time now is 02:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration