LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-11-2012, 06:35 PM   #1
timebirds
Member
 
Registered: Mar 2012
Posts: 33

Rep: Reputation: Disabled
My pure-ftpd server is giving me an error when I try to connect (SOLVED)


I followed this tutorial, and whenever I try to connect I get this error message.

Status: Connecting to ---------:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 17:27. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER timebirds
Response: 331 User timebirds OK. Password required
Command: PASS ********
Response: 421 Home directory not available - aborting
Error: Could not connect to server

I'm using filezilla to connect.

Last edited by timebirds; 03-13-2012 at 09:05 PM.
 
Old 03-11-2012, 06:49 PM   #2
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
I don't use pureftp. So I can't offer any help from a personal experience standpoint. But I did find this page. The English is a little troublesome to puzzle out, but maybe it will help with your problem.
 
1 members found this post helpful.
Old 03-11-2012, 06:49 PM   #3
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Did you check user info in the server, with
Code:
pure-pw show timebirds
 
Old 03-11-2012, 06:57 PM   #4
timebirds
Member
 
Registered: Mar 2012
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Cedrik View Post
Did you check user info in the server, with
Code:
pure-pw show timebirds
Gives me this:

Login : timebirds
Password : $1$Kn1gMMn0$X4FPfDewSsaG.EIgkrVlg0
UID : 1000 (ftpuser)
GID : 1000 (ftpgroup)
Directory : /home/pubftp/timebirds/./
Full name :
Download bandwidth : 0 Kb (unlimited)
Upload bandwidth : 0 Kb (unlimited)
Max files : 0 (unlimited)
Max size : 10 Mb (enabled)
Ratio : 0:0 (unlimited:unlimited)
Allowed local IPs :
Denied local IPs :
Allowed client IPs :
Denied client IPs :
Time restrictions : 0000-0000 (unlimited)
Max sim sessions : 0 (unlimited)

Last edited by timebirds; 03-11-2012 at 07:00 PM.
 
Old 03-11-2012, 07:07 PM   #5
timebirds
Member
 
Registered: Mar 2012
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Dark_Helmet View Post
I don't use pureftp. So I can't offer any help from a personal experience standpoint. But I did find this page. The English is a little troublesome to puzzle out, but maybe it will help with your problem.
Ok, i can connect now, but i see nothing. how do i edit this:

Directory : /home/pubftp/timebirds/./

Last edited by timebirds; 03-11-2012 at 07:18 PM.
 
Old 03-11-2012, 07:41 PM   #6
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Quote:
Originally Posted by timebirds
Ok, i can connect now, but i see nothing.
The tutorial you linked to earlier creates a top-level directory that contains "home" directories for all ftp users (i.e. "/home/pubftp" is the top-level in your setup). The first time an ftp user logs in, a separate directory is created for that user under the top-level. That directory will be empty of course. Further, no ftp user will be able to navigate to any path outside the top-level directory.

If you wanted access to, for instance, /home/timebirds, then you'll need to read up on the pureftp documentation for config settings. The users in pureftp are separate/distinct from the users created in linux--even if they share the same text name.

Unfortunately, I can't point you to any specific sections of the documentation because I don't use pureftp.

Last edited by Dark_Helmet; 03-11-2012 at 07:42 PM.
 
Old 03-11-2012, 07:50 PM   #7
timebirds
Member
 
Registered: Mar 2012
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Dark_Helmet View Post
The tutorial you linked to earlier creates a top-level directory that contains "home" directories for all ftp users (i.e. "/home/pubftp" is the top-level in your setup). The first time an ftp user logs in, a separate directory is created for that user under the top-level. That directory will be empty of course. Further, no ftp user will be able to navigate to any path outside the top-level directory.

If you wanted access to, for instance, /home/timebirds, then you'll need to read up on the pureftp documentation for config settings. The users in pureftp are separate/distinct from the users created in linux--even if they share the same text name.

Unfortunately, I can't point you to any specific sections of the documentation because I don't use pureftp.
ok thanks for your help with that webpage link. i had to specify a directory for it to show.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pure-FTPd cannot connect to server from outside of network imagineaxion Ubuntu 2 03-06-2009 01:46 PM
pure-ftpd-mysql activates pure-ftpd zvikamer Linux - Software 2 03-01-2008 01:11 PM
Pure-FtpD Can't connect from outsize router! Shioni Linux - Software 3 06-26-2006 05:41 PM
Pure-ftpd - error 553 rimmern Linux - Newbie 1 12-15-2005 08:00 PM
Pure-FTPD( Unable to connect) fritz001 Slackware 5 01-27-2005 07:36 PM


All times are GMT -5. The time now is 08:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration