LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-14-2003, 01:27 PM   #1
Fred Affe
LQ Newbie
 
Registered: Aug 2003
Distribution: SuSE 9.0
Posts: 22

Rep: Reputation: 15
Question Mounting NTFS in SuSE 8.0


Hi folks!


I'm trying to mount my NTFS-Drives (Win2K).

Well, I got so far: Root mounts the NTFS-Drives and can read them. But when the user tries to open the folder (e.g. /Windows/E), Linux says he doesn't have the necessary rights to open the folder.

I tried to use chmod 777 before mounting the drive, but it didn't work.

fstab looks like this:
/dev/hdb7 /windows/E ntfs auto,user 0 0

Thanks for your answers, and please forgive my English, I'm from Germany.

Greets
Fred Affe
 
Old 08-14-2003, 01:38 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Use these options in your /etc/fstab entry - just substitute your user id number ( uid ) in place of my example one

auto,ro,umask=222,uid=501

You can get your User ID Number by opening a command line and typing:

id username (substitute username with Aaron or Sofie or whatever your username is)

Look for the

uid=xxx

thats your user id number

Last edited by Skyline; 08-14-2003 at 01:43 PM.
 
Old 08-14-2003, 02:04 PM   #3
Fred Affe
LQ Newbie
 
Registered: Aug 2003
Distribution: SuSE 9.0
Posts: 22

Original Poster
Rep: Reputation: 15
Well.... at least the user can open the folder now


When the drives get mounted on startup, they appear as /windows/E and /windows/F, before I changed fstab the user wasn't able to open the folder at all (it had a lock as icon) and root could read the files in it, and now the user can open the folder, but it's empty. Root can read the folders nevertheless.

What does "umask" do?

Last edited by Fred Affe; 08-14-2003 at 02:08 PM.
 
Old 08-14-2003, 04:06 PM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Umask just sets a filter of permissions for all new files created

As a matter of interest - can you post your /etc/fstab contents

You can get them by opening a Konsole and typing

su
then type your root password

then type

kedit /etc/fstab


.
 
Old 08-14-2003, 07:24 PM   #5
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Quote:
Originally posted by Fred Affe
Well.... at least the user can open the folder now


When the drives get mounted on startup, they appear as /windows/E and /windows/F, before I changed fstab the user wasn't able to open the folder at all (it had a lock as icon) and root could read the files in it, and now the user can open the folder, but it's empty. Root can read the folders nevertheless.

What does "umask" do?
This is what I have, edit it to fit yours:
/dev/hda1 /mnt/windows ntfs ro,umask=0222 0 0

Works fine, all users with read only permission

Quote:
umask is a filter of permissions, so it works in the opposite way to chmod. Full permissions are equivalent to 777 (rwxrwxrwx). A umask of 0222 (-w--w--w-) leaves 555 (r-xr-xr-x).
 
Old 08-14-2003, 07:49 PM   #6
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
This is what I have, edit it to fit yours:
/dev/hda1 /mnt/windows ntfs ro,umask=0222 0 0
Awatto - you've forgot

auto

He's not going to have his partition automatically mounted on boot up without this.
 
Old 08-14-2003, 08:04 PM   #7
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Quote:
Originally posted by Skyline
Awatto - you've forgot

auto

He's not going to have his partition automatically mounted on boot up without this.
Hmm, strange, mine does, lol. Must be because of different distro, but thanks for pointing that out.
 
Old 08-14-2003, 08:11 PM   #8
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
Hmm, strange, mine does, lol. Must be because of different distro, but thanks for pointing that out
Awatto - just to clarify - are you suggesting that your partition automatically mounts on boot up without an auto option?
 
Old 08-14-2003, 08:14 PM   #9
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Yep. Tha's exactly what I have in my fstab and it is mounted every time I boot up ever since I added it...
 
Old 08-14-2003, 08:25 PM   #10
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
You havent answered my question - I pointed out that Fred would need an auto option in his fstab entry to have his Windows partition automatically mounted on boot up.

To that you replied

Quote:
Hmm, strange, mine does, lol.
implying that you have your Windows partition automatically mounted on boot up without an auto option

So I'll ask you again - is it possible to have your Windows partition automatically mounted on boot up without an auto option?
 
Old 08-14-2003, 08:31 PM   #11
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Sorry for being unclear.

Yes - Mine is automatically mounted, and does not have an auto option.
 
Old 08-15-2003, 01:59 AM   #12
Fred Affe
LQ Newbie
 
Registered: Aug 2003
Distribution: SuSE 9.0
Posts: 22

Original Poster
Rep: Reputation: 15
Talking

This is what my fstab looks like now:
Code:
/dev/hda4	/	reiserfs	defaults 1 2
/dev/cdrom	/media/cdrom	auto	ro,noauto,user,exec 0 0
devpts	/dev/pts	devpts	defaults 0 0
/dev/fd0	/media/floppy	auto	noauto,user,sync 0 0
proc	/proc	proc	defaults 0 0
usbdevfs	/proc/bus/usb	usbdevfs	noauto 0 0
/dev/hdb7	/windows/E	ntfs	auto,user,ro,umask=0222 0 0
/dev/hdb6	/windows/F	ntfs	auto,user,ro,umask=0222 0 0
/dev/hdb5	/windows/G	vfat	auto,user,fat=32 0 0
/dev/hda3	swap	swap	pri=42 0 0
And I have to say: It works!!!

Thank you very much for your help!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting NTFS drives in SuSE Dunkalis Linux - General 3 08-03-2005 06:16 PM
Trouble mounting FAT32 and NTFS under SuSE 9.2 nitroid SUSE / openSUSE 2 12-07-2004 09:55 AM
suse 9.0, trouble mounting ntfs mdemers883 Linux - Distributions 7 01-25-2004 07:59 PM
Mounting NTFS teyesahr Linux - Newbie 15 08-01-2003 02:51 PM
SuSe 8 makes NTFS mount point, but doesn't create directories, error when mounting... BlackDogg Linux - Distributions 5 08-01-2002 06:08 AM


All times are GMT -5. The time now is 06:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration