LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-31-2003, 06:57 PM   #1
teyesahr
Member
 
Registered: Jul 2003
Location: Lancaster, Pa
Distribution: Red Hat 9.0
Posts: 46

Rep: Reputation: 15
Mounting NTFS


I've been told by a number of sources that NTFS is supported by Linux, at least for read purposes. Yet, I got this error when I tried to mount it to my /mnt/win2k directory:

Quote:
[root@localhost mnt]# mount -t ntfs /dev/hda1 /mnt/win2k
mount: fs type ntfs not supported by kernel
Can anyone help me?

PS: How do I change the name of my computer from "localhost" to something else? Thanks.

Last edited by teyesahr; 07-31-2003 at 06:59 PM.
 
Old 07-31-2003, 07:15 PM   #2
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
To add NTFS support to RedHat, you need to install a RPM.
http://linux-ntfs.sourceforge.net/
Or you can recompile your Kernel and add NTFS support directly into the kernel.


To change the hostname, edit the /etc/sysconfig/network file.
 
Old 07-31-2003, 08:17 PM   #3
teyesahr
Member
 
Registered: Jul 2003
Location: Lancaster, Pa
Distribution: Red Hat 9.0
Posts: 46

Original Poster
Rep: Reputation: 15
YES! It's all coming together, now....
 
Old 07-31-2003, 08:27 PM   #4
teyesahr
Member
 
Registered: Jul 2003
Location: Lancaster, Pa
Distribution: Red Hat 9.0
Posts: 46

Original Poster
Rep: Reputation: 15
Hey, I changed the network file, but my terminal window still echoes "localhost"
 
Old 08-01-2003, 05:40 AM   #5
levian
LQ Newbie
 
Registered: Aug 2003
Location: kadin, jkt
Distribution: Dolphin,Shrike,98
Posts: 20

Rep: Reputation: 0
try to change your /etc/hosts also
 
Old 08-01-2003, 07:58 AM   #6
teyesahr
Member
 
Registered: Jul 2003
Location: Lancaster, Pa
Distribution: Red Hat 9.0
Posts: 46

Original Poster
Rep: Reputation: 15
Yes, I already figured that out :-), but thanks.
 
Old 08-01-2003, 09:16 AM   #7
Hoops66
Member
 
Registered: Jun 2003
Distribution: Red Hat/ Win 2k Pro/Fedora Core2/Suse 9.1 Pro
Posts: 44

Rep: Reputation: 15
what's the fstab for auto mounting the NTFS, i had a wicked kernel panic and i had to re-install my RH9, and i didn't write down what i did. I can only see NTFS part as root in the command line... here's what i have so far... this time i am writing this down

Code:
LABEL=/               /                      ext3    defaults        1 1
LABEL=/boot         /boot                ext3    defaults        1 2
none                    /dev/pts            devpts  gid=5,mode=620  0 0
none                    /proc                 proc    defaults        0 0
none                    /dev/shm           tmpfs   defaults        0 0
/dev/hda6             swap                swap    defaults        0 0
/dev/cdrom           /mnt/cdrom         udf,iso9660 noauto,kudzu,ro 0 0
/dev/fd0               /mnt/floppy         auto    noauto,owner,kudzu 0 0
/dev/hda2            /mnt/windows      auto    ?????????????????
 
Old 08-01-2003, 09:35 AM   #8
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Hoops66

Try

/dev/hda2 /mnt/windows ntfs auto,ro,umask=002 0 0

or

/dev/hda2 /mnt/windows ntfs defaults,umask=002 0 0

remember the correct spacing - there's 6 fields here all with a space between them - Field 4 is Mount options - it just uses commas between its entries.

Last edited by Skyline; 08-01-2003 at 09:39 AM.
 
Old 08-01-2003, 09:54 AM   #9
Kasperisa
LQ Newbie
 
Registered: Jul 2003
Posts: 26

Rep: Reputation: 15
Quote:
Originally posted by Skyline
Hi Hoops66

Try

/dev/hda2 /mnt/windows ntfs auto,ro,umask=002 0 0

or

/dev/hda2 /mnt/windows ntfs defaults,umask=002 0 0

I tried those two commands after installing the correct RPM for NTFS support for souceforge for the correct kernel that i have. I get the message:
bash: /dev/hda2: Permission denied

ive tried using hda, hda1, and various others. The NTFS partition im looking for is the primary master harddrive, with it being only one partition. with RH9.0 being on the primary slave in its standard 3 partitions. and yes i was under root when trying it. Does anyone know what happened? what went wrong?

k, i know what when wrong, i just found out (explaining the editing of this post). i downloaded and installed the i386 rpm and i just learned that my processor is a i686... can someone please tell me how to uninstall the package i just installed please?

Last edited by Kasperisa; 08-01-2003 at 10:03 AM.
 
Old 08-01-2003, 10:03 AM   #10
teyesahr
Member
 
Registered: Jul 2003
Location: Lancaster, Pa
Distribution: Red Hat 9.0
Posts: 46

Original Poster
Rep: Reputation: 15
Doing this worked for me:

Quote:
/dev/hda1 /mnt/win2k ntfs auto,ro,umask=002 0 0
I also had to install NTFS support, as per an earlier reply in this thread.

Also, like you, my windows NTFS partition is a monolith, consuming all of my primary harddrive, with all the Linux partitions occupying the slave drive. If you have RH9 like you say, this ought to work.

PS: Not to offend you (I did this, myself, so I assume others might be as stupid), but did you remember to create the 'windows' directory in /mnt?

Last edited by teyesahr; 08-01-2003 at 10:06 AM.
 
Old 08-01-2003, 10:16 AM   #11
Kasperisa
LQ Newbie
 
Registered: Jul 2003
Posts: 26

Rep: Reputation: 15
Quote:
Originally posted by teyesahr
PS: Not to offend you (I did this, myself, so I assume others might be as stupid), but did you remember to create the 'windows' directory in /mnt?
I couldn't remember to create the windows directory, as I didn't have that knowledge to forget in the first place

my problem now is actually that i installed the wrong rpm. I installed kernel-ntfs-2.4.20-8.i386.rpm

when i should have installed kernel-ntfs-2.4.20-8.i686.rpm

So i try and install the correct one and says that it is already installed.
and then i try and uninstall the other package kernel-ntfs-2.4.20-8.i386.rpm but it says it doesn't exist. I have tried using
rpm -e kernel-ntfs-2.4.20-8.i386
but still a no go. does anyone know how to find and remove this stupid nuisance?
 
Old 08-01-2003, 12:09 PM   #12
Hoops66
Member
 
Registered: Jun 2003
Distribution: Red Hat/ Win 2k Pro/Fedora Core2/Suse 9.1 Pro
Posts: 44

Rep: Reputation: 15
here is the help that i followed the 1st time i did this, it worked like a charm for me.

the umask worked... i have one question though, what is the purpose of the 0 0 switch, at the end of the line??
 
Old 08-01-2003, 12:11 PM   #13
Hoops66
Member
 
Registered: Jun 2003
Distribution: Red Hat/ Win 2k Pro/Fedora Core2/Suse 9.1 Pro
Posts: 44

Rep: Reputation: 15
http://linux-ntfs.sourceforge.net/info/redhat.html

sorry 'bout that
 
Old 08-01-2003, 12:41 PM   #14
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Hoops66

About the last 2 fileds in a typical /etc/fstab entry:


The 5th field indicates whether the filesystem should be included in a back-up.

The 6th Field indicates how the filesystem should be checked on boot up.
 
Old 08-01-2003, 12:59 PM   #15
Hoops66
Member
 
Registered: Jun 2003
Distribution: Red Hat/ Win 2k Pro/Fedora Core2/Suse 9.1 Pro
Posts: 44

Rep: Reputation: 15
...thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ntfs Mounting sri_hassan Fedora - Installation 2 11-24-2005 02:16 AM
mounting NTFS gnu4world Linux - General 2 05-21-2003 01:50 AM
Mounting NTFS tspauld98 Linux - General 3 08-04-2002 02:46 AM
Mounting NTFS sami Linux - Newbie 4 06-25-2002 12:24 PM
mounting ntfs starbreaker Slackware 3 06-02-2002 10:43 PM


All times are GMT -5. The time now is 04:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration