LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2005, 09:41 AM   #1
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Rep: Reputation: 15
Mounting a "special device", Read Only


I have Linux running on a machine on which eComStation is also installed. I wish to designate one partition of the eComStation installation for data transfer between the two OSes. At the moment I want the transfer to be in one direction only, so I want to mount the transfer partition witout write permission for anyone, including the superuser.

Mounting the partition in Linux is no problem:
<mount -t hpfs /dev/sda12 /home/stan/importdata>.

But the default is to mount with write permission, which I don't want. As I read the man page for mount, I should be able to alter this by adding the r option behind the -t:
<mount -tr hpfs /dev/sda12 /home/stan/importdata>.

But this gets me a referral back to the man page, so clearly I am misunderstanding, although it seems simple enough. What is it that I am misunderstanding?
 
Old 09-11-2005, 09:45 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
You should be able to mount it with the ro (read only) option - just add "-o ro" to your mount command or "ro" to the options column of /etc/fstab
 
Old 09-11-2005, 09:51 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you would need to specify the -r seperately from the -t as the -t needs to know that hpfs parameter. personally i would say use "-o ro" with is passing a standard "read only" flag as an option. as far as your syntax
 
Old 09-11-2005, 09:55 AM   #4
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by david_ross
You should be able to mount it with the ro (read only) option - just add "-o ro" to your mount command or "ro" to the options column of /etc/fstab

Interesting. The man page says merely that "-o ro" is a synonym for "-r", implying that the latter is at least as valid as the other. I'll try your suggestion, for which many thanks.
 
Old 09-11-2005, 10:03 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
i think david missed what i originally missed, in that you can't combine the two options togheter as in is parameterised
 
Old 09-11-2005, 10:06 AM   #6
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by acid_kewpie
you would need to specify the -r seperately from the -t as the -t needs to know that hpfs parameter. personally i would say use "-o ro" with is passing a standard "read only" flag as an option. as far as your syntax
Ach!! Very clear. I should have seen that the way I had it broke the association between the "t" and its argument.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
always "device is busy" when mounting Mathsniper Linux - Hardware 2 04-14-2005 08:28 PM
cdrom not recogonized/no hda/"special device" not found etc. thechao Debian 1 01-23-2005 05:42 PM
External USB HDD"Mounting local filesystems: /dev/sdb1 is not a valid block device" manudath Linux - Hardware 3 12-13-2004 10:59 PM
USB drive keeps mounting as "read only" I need to write to it. Lossenelin Linux - Hardware 1 02-12-2004 07:49 PM
need help, on how to access quickly to special characters like "" or ""? Motaro Linux - Newbie 1 12-31-2003 12:53 PM


All times are GMT -5. The time now is 05:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration