LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-12-2004, 06:23 PM   #1
manudath
Member
 
Registered: Oct 2004
Posts: 42

Rep: Reputation: 15
External USB HDD"Mounting local filesystems: /dev/sdb1 is not a valid block device"


Hi,

I was trying to mount my new external HDD (Maxtor, 120GB) on the Redhat Enterprise Linux (installed on a SATA hard drive)

The entry for the external drive in /etc/fstab is:

/dev/sdb1 /mnt/external1 ext3 exec,auto,nouser,async 0 0

My problem is: Whenever the system boots up, after performing the fsck, it gives an error: "Mounting local filesystems: /dev/sdb1 is not a valid block device" [FAILED]

But on booting up completely, the drive is actually mounted. If I make the option in /etc/fstab as noauto, I see a clean boot up, but I have to manually mount the drive, and I dont want to do that everytime.

Can anyone please help me with this?

Thanks,
Manudath
 
Old 12-12-2004, 09:30 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,801

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
AFAIK the kernel mounts the filesystems via fstab prior to loading modules. So there are several options:

You can compile sata support into the kernel.

Change the boot sequence to load the modules prior to mounting the filesystems. I do not know how to accomplish this or if it is possible but wonder why this isn't done anyway.

You can add the sata module to the initrd image.

You can add a command to mount the drive into the /etc/rc.local file. The /etc/rc.local is the last thing to run and the module would be already loaded.

Obviously, the last two choices are the easiest.
 
Old 12-13-2004, 05:11 PM   #3
manudath
Member
 
Registered: Oct 2004
Posts: 42

Original Poster
Rep: Reputation: 15
Thanks michael,

I had put the command in rc.local... But I was thinking if there were better choices...

Thanks for ur reply...
 
Old 12-13-2004, 09:59 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,801

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Adding the sata module to the initrd image should also work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: /dev/sdb1 is not a valid block device zaltar Linux - General 8 07-13-2005 02:07 AM
External HD "Not a valid block device" Slackware 10.0 ZiggyJustice Linux - Hardware 2 03-02-2005 03:18 PM
USB HD - "not a valid block device" fryem720 Linux - Hardware 10 02-10-2005 06:34 PM
"/dev/cdrom is not a valid block device" error kungfuhokie Fedora 4 06-11-2004 06:55 AM
Kernel 2.6.1 /dev/cdrom "not a valid block device" jwjensen Linux - General 8 01-27-2004 12:50 PM


All times are GMT -5. The time now is 06:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration