LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2004, 01:44 AM   #1
MindTheGap76
LQ Newbie
 
Registered: Mar 2004
Posts: 4

Rep: Reputation: 0
Mandrake 10.0 Community - rpmlib(CompressedFileNames)??


I have just installed a fresh copy of Mandrake 10.0 Community Evaluation, and am having a recurring problem installing a few RPMS.

The first RPM I tried to install was kernel-source-2.6.3-4mdk.i586.rpm (so that I could get my nVidia graphics card working). I received the following error messages:
Some package requested cannot be installed:
kernel-source-2.6.3-4mdk.i586 (due to missing libncurses5-devel-5.3-1.20040125.4mdk.i586)
libncurses5-devel-5.3-1.20040125.4mdk.i586 (due to unsatisfied rpmlib(CompressedFileNames) <= 3.0.4-1)

I gave up on that and tried to install mplayer-1.0-0.pre3.13mdk.i586 and received this message:
Some package requested cannot be installed:
libggi2-2.0.4-1mdk.i586 (due to missing libgii0-0.8.4-1mdk.i586)
libgii0-0.8.4-1mdk.i586 (due to unsatisfied rpmlib(CompressedFileNames) <= 3.0.4-1)

In both of these cases (and a few others that I tried) I am getting this same "rpmlib(CompressedFileNames) <= 3.0.4-1" error. What is this error and how can I fix it?

I apologize if this is a dense question; I am fairly skilled in Windows, but a total n00b when it comes to Linx. Please let me know if there is any other info I can provide that would help clarify the situation. I've looked around here and on google and have been unable to find any answers.

Last edited by MindTheGap76; 03-16-2004 at 01:47 AM.
 
Old 03-19-2004, 01:56 PM   #2
guest
Member
 
Registered: May 2003
Distribution: CentOS 5 64 bit
Posts: 255

Rep: Reputation: 30
I just installed Manddrake 10 and had the same problem. Some files urpmi uses to check for updates got corrupted. I deleted these two files:

hdlist.Updates for Mandrakelinux 10.0 (ftp1u).cz
synthesis.hdlist.Updates for Mandrakelinux 10.0 (ftp1u).cz

in the directory /var/lib/urpmi/

Now I get a warning when I use urpmi (unable to access hdlist file of "Updates for Mandrakelinux 10.0 (ftp1u)", medium ignored) but it works anyway.

Hope this works for you.
 
Old 05-03-2004, 09:30 PM   #3
derbaff
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Rep: Reputation: 0
I had the same problem. I fixed it by going to the Mandrake control panel and then going into Media Manager and then removing the online update source. Now it works fine. I just had to setup the online update stuff again, but no big deal.

This probably does the same thing the other guy did. But in a more officail fasion and with no resulting errors.
 
Old 06-06-2004, 04:40 PM   #4
clutjespelberg
LQ Newbie
 
Registered: Jun 2004
Location: Groningen, The Netherlands
Distribution: Mandrake 10
Posts: 1

Rep: Reputation: 0
For me it was enough to disable the medium, after the installation you can enable it again if you wish. Thanks for the info!
 
Old 08-18-2004, 09:38 PM   #5
Dinabandhu
LQ Newbie
 
Registered: Aug 2004
Location: Australia
Distribution: Mandrake 10 at moment
Posts: 11

Rep: Reputation: 0
Talking

[QUOTE]Originally posted by derbaff

I am having a similar problem, but my file does not have the ones you mentioned:
hdlist.Updates for Mandrakelinux 10.0 (ftp1u).cz
synthesis.hdlist.Updates for Mandrakelinux 10.0 (ftp1u).cz

My printout:

[root@localhost urpmi]# ls
compssUsers.flat
hdlist.Installation CD 1 (x86) (cdrom1).cz
hdlist.Installation CD 2 (x86) (cdrom2).cz
hdlist.Installation CD 3 (x86) (cdrom3).cz
hdlist.Installation CD 4 (x86) (cdrom4).cz
MD5SUM
synthesis.hdlist.Installation CD 1 (x86) (cdrom1).cz
synthesis.hdlist.Installation CD 2 (x86) (cdrom2).cz
synthesis.hdlist.Installation CD 3 (x86) (cdrom3).cz
synthesis.hdlist.Installation CD 4 (x86) (cdrom4).cz

Sorry to be brainless, but does this mean that i have to put the CDs in the drive and update from the Media Manager.

Der


 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rpmlib(CompressedFileNames) <= 3.0.4-1 ?? netmanw00t Linux - Software 1 07-31-2004 11:45 PM
KDevelop and rpmlib eqxro Programming 1 07-27-2004 05:57 AM
Should i upgrade from mandrake 10 community to mandrake 10 official? Braveheart1980 Mandriva 7 06-21-2004 02:49 PM
rpmlib ras123 Linux - Newbie 1 05-13-2004 03:27 PM
mandrake 10 community santasballz Linux - Newbie 5 03-13-2004 09:39 PM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration