LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2004, 05:06 PM   #1
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Rep: Reputation: 15
lilo linux options don't load --error 0x07


I have 2 linux kernels, a current and an old, plus a Windows boot. I have options for all 3 under LILO. However, the linuces won't boot. Even when I copied the bootdisk kernel to hd and made that a fourth option, it wouldn't boot. The only way I can boot is from floppy or into WinXP (or into Knoppix).

EDIT: let me clarify.....
LILO menu comes up fine, with all 4 options. The 3 linuces give error 0x07 and return instantly to LILO menu. WinXP boots fine. It boots fine from a bootdisk, which is strange because one of the linuces is the exact same kernel as on the bootdisk!

LILO was working fine previously, all this trouble started when I rebuilt kernel and /vmlinuz became /vmlinuz.old.
/EDIT

I can only guess that something is wrong with my lilo.conf, so here it is:

Code:
# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# ---------------       `install-mbr(8)', `/usr/share/doc/lilo/',
#                       and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt', or install a new kernel.  The |
# | computer will most likely fail to boot if a kernel-image      |
# | post-install script or you don't remember to run `lilo'.      |
# |                                                               |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.
#
lba32

# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.
#disk=/dev/hde
#    bios=0x81

#disk=/dev/sda
#    bios=0x80

# Specifies the boot device.  This is where Lilo installs its boot
# block.  It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.
#
boot=/dev/hda

# Specifies the device that should be mounted as root. (`/')
#
root=/dev/hdb1

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller.  Using `compact' is especially recommended when
# booting from a floppy disk.  It is disabled here by default
# because it doesn't always work.
#
# compact

# Installs the specified file as the new boot sector
# You have the choice between: bmp, compat, menu and text
# Look in /boot/ and in lilo.conf(5) manpage for details
#
install=/boot/boot-menu.b

# Specifies the location of the map file
#
map=/boot/map

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration.  If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
#
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
#
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well.  Please RTFM `install-mbr(8)'.
#
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.
#
# delay=200

# You can put a customized boot message up if you like.  If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress.  `single-key' goes with the `alias' lines in the
# `image' configurations below.  eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
#
message=/boot/bootmess.txt
	prompt
#	single-key
#	delay=100
	timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
#
# vga=ask
# vga=9
#
# vga=normal
vga=773

# Kernel command line options that apply to all installed images go
# here.  See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
#
# append=""

# Boot up Linux by default.
#
default=Linux--NewKern

image=/vmlinuz
	label=Linux--NewKern
	read-only
#	restricted
#	alias=1

image=/vmlinuz.old
	label=Linux--PrevKern
	read-only
	optional
#	restricted
#	alias=2

image=/linux.bin
	label=Linux--Bootdisk
	read-only
	optional

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
#
other=/dev/hda3
	label=Windows-XP
#	restricted
#	alias=3

Last edited by Sinope; 08-09-2004 at 05:23 PM.
 
Old 08-09-2004, 05:13 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
You have no;
root=
initrd=
I don't use lilo so I don't know for sure if you need initrd but have to have root=,that much I do know.also need to run /sbin/lilo after a change.

Last edited by comprookie2000; 08-09-2004 at 05:14 PM.
 
Old 08-09-2004, 05:19 PM   #3
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
Look around line 30-ish:

Code:
# Specifies the device that should be mounted as root. (`/')
#
root=/dev/hdb1
 
Old 08-09-2004, 05:54 PM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
hdb1 is that the /boot partition of the slave or the /root check it out in /etc/fstab
 
Old 08-09-2004, 06:03 PM   #5
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
ah, let me explain the hd partitions:

hda1 /boot 64m
hda2 swap 512m
hda3 windows 8g

hdb1 / 60g


hda is the master, obviously. You'll notice that i'm booting from the MBR on hda, so the separate /boot partition is sort of pointless, but i didn't know i was doing that until after hda1 was mounted as /boot. no real reason to change it, i figured. ....is there?
 
Old 08-09-2004, 06:20 PM   #6
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Most have hda1 as windows then linux next,over my head may have something to do with /boot on ond hd and / on another?
 
Old 08-09-2004, 07:07 PM   #7
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
I doubt it, since I had the same setup under Slackware and that booted fine....
 
Old 08-09-2004, 08:49 PM   #8
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
default=Linux--NewKern

image=/boot/vmlinuz
label=Linux--NewKern
read-only
root=/dev/hdb1
You could try this.

Last edited by comprookie2000; 08-09-2004 at 08:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo hangs on XP load : XP & Linux on diff. disks Lagg Linux - Software 6 08-29-2005 04:25 AM
when trying to boot win 2000 i get error 0x07 mms_master Linux - General 1 03-13-2004 04:22 PM
LILO.conf won't load Linux JulianS Slackware 5 03-06-2004 05:45 PM
Lilo with several kernel options tungsten Slackware 2 01-11-2004 09:43 AM
Hmm my Lilo won't umm Load linux...help please! shadowpuff Linux - Newbie 5 02-05-2003 03:08 PM


All times are GMT -5. The time now is 10:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration