LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-07-2009, 12:25 PM   #1
kenneho
Member
 
Registered: May 2003
Location: Oslo, Norway
Distribution: Ubuntu, Red Hat Enterprise Linux
Posts: 655

Rep: Reputation: 40
KVM keyboard layout problem


Hi.


I've just installed my first couple of virtual machines (VM's) in Ubuntu using virt-manager running on KVM. I've installed both Fedora 10 and Ubuntu 9.10, and in both I'm having problems setting up the keyboard.

While in Gnome, I click System > Preferences > Keyboard, and choose the same keyboard as my Ubuntu host is set up with, i.e. "Generic 105-key (Intl) PC". But when I type in stuff in the "Type to test settings" box, many of the keys are completely off. For example, in norwegian we have letters such as "", "" and "", and typing these keys results in nothing.

So how come the setting is working on my host, but not in my guests (i.e. VMs)? Any ideas where to start debugging this?

Edit: I should add that when I choose english layout in the VMs, the key mappings are different from when I choose the same on the host. So there is obviously something wrong somewhere....

Regards,
kenneho

Last edited by kenneho; 11-07-2009 at 12:30 PM.
 
Old 11-08-2009, 06:59 AM   #2
opaltoad
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Rep: Reputation: 1
you need to change your language settings, not the amount of keys your keyboard has.
Look for something along the lines of regional settings in your system preferences.
 
Old 11-14-2009, 08:17 AM   #3
kenneho
Member
 
Registered: May 2003
Location: Oslo, Norway
Distribution: Ubuntu, Red Hat Enterprise Linux
Posts: 655

Original Poster
Rep: Reputation: 40
Quote:
Originally Posted by opaltoad View Post
you need to change your language settings, not the amount of keys your keyboard has.
Look for something along the lines of regional settings in your system preferences.
Thanks for your reply.

I don't believe it's my language settings that are causing the symptom, cause I've found that if I boot my virtual machine (VM) from the "virt-manager" application, it get keyboard problems, but booting it like this everything is just perfect:
Code:
sudo kvm -hda virtualdisk.img -cdrom cdrom.iso -m 256 -net nic -net user -soundhw all
So for some reason, booting the VM from "virt-manager" is different from booting via the command line issuing "kvm ...". Do you happen to know what the big difference is?
 
Old 11-14-2009, 08:42 AM   #4
kenneho
Member
 
Registered: May 2003
Location: Oslo, Norway
Distribution: Ubuntu, Red Hat Enterprise Linux
Posts: 655

Original Poster
Rep: Reputation: 40
I've moved this discussion to the virtualization forum:

http://www.linuxquestions.org/questi...-works-769091/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with scandinavian keyboard layout Sordo Linux - Software 1 04-26-2009 06:17 AM
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 07:43 PM
Keyboard layout problem with different languages Linuxapprentice Fedora 1 02-08-2006 10:47 PM
Keyboard layout problem theonebeyond Linux - General 22 12-13-2004 02:38 AM
X.org keyboard layout problem drigz Linux - Software 4 08-20-2004 08:27 AM


All times are GMT -5. The time now is 12:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration