LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-20-2011, 09:32 AM   #1
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Rep: Reputation: 19
Kubuntu 11.04, Fat32 access denied.


Hi, friends,

I am using a Toshiba P7500 series laptop, i3 dual core, 6GB ram,

This is a brand new machine. I was trying to recreate the conditions specified in a previous thread of mine, located here:
http://www.linuxquestions.org/questi...itions-881489/

I have followed the steps as good as I could. The main difference that I think is causing me problems is the fact that I am now trying to do this (explained in that thread) with a Fat32 instead of the ext3.

I THINK I know where my mistake is, but not sure how to fix. In the fstab, and in the mkdir, I am not sure how to address the fat filesystem.

To recap my intentions:
I want my FAT32 partition to mount automatically, and have a presence in my /home. In my other machine, where this is working flawlessly, my "file storage" partition (named "DATA" in the other thread, and was an ext3), this partition looks and behaves just like any other subdirectory under /home.

Right now, with my attempt at a setup, and with my error, the partition is not accessible anymore.

I hope all this makes sense. Sorry if it is confusing.
Please take me step-by-step so i can understand the process much better.

Thank you
Neal

Last edited by Bhakta Neal; 08-20-2011 at 09:58 AM.
 
Old 08-21-2011, 02:36 AM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi Neal,

How are you doing buddy? Let's see if we can fix this thing that's giving you headaches. First of all, sorry for the late reply, I was out whole day yesterday.

Can you post output of :
Code:
cat /etc/fstab
and
Code:
mount
Kind regards,

Eric
 
1 members found this post helpful.
Old 08-21-2011, 07:24 AM   #3
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
Quote:
bhakta@Krishna-PC:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=fe1ab25d-1c6c-4297-a18b-8f9571d8dbdc / ext4 errors=remount-ro 0 1
# swap was on /dev/sda7 during installation
UUID=fe43f7fe-9944-4085-b515-4747e3d92195 none swap sw 0 0

/dev/sda8 /mnt/data fat32 auto,user,rw 1 2
and

Quote:
bhakta@Krishna-PC:~$ mount
/dev/sda6 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
/dev/sr0 on /media/Within Temptatio type iso9660 (ro,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500)
 
Old 08-21-2011, 07:28 AM   #4
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
Im doing great bud, just so anxious to get things done before the trip, so this mistake I made is not helping!
Eventually you will see that I tried to follow your instructions in that old thread, but I hit the wall because Im working with FAT32 on this one, and I remember vaguely that fat32 has a little bit different process?
 
Old 08-21-2011, 07:36 AM   #5
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
In post #3, the last line
Quote:
/dev/sda8 /mnt/data fat32 auto,user,rw 1 2
was entered to fstab by me, attempting to follow instructions!
 
Old 08-21-2011, 02:29 PM   #6
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi buddy,

Sorry for the late response, I spend a day at the beach with 96 degrees F. Change fat32 to vfat and try again.

Kind regards,

Eric
 
1 members found this post helpful.
Old 08-21-2011, 02:59 PM   #7
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
THANKS!
Workin on that now
 
Old 08-21-2011, 03:16 PM   #8
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
Great that allows me access now.

However, there is a slight bug:

In my Dolphin, in the "Places" margin, there is the drive "Fatass32" (which I named with gparted during initial setup), which is my FAT32 prtition. This is correct behavior.

Also, under my /home directory, there is a "FatAss32" directory.

When I click to open .......
Wait, I just noticed something important.

My partition is named Fatass32, and my file manager directory is FatAss32. They have different names, which is probably why when I try to open FatAss32, I get a new, blank empty folder, instead of seeing the files already in place on Fatass32.

I am sure I made the mistake during the mkdir instruction. How can I fix it?
 
Old 08-22-2011, 12:30 AM   #9
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi Neal,

Most likely you created two directories. Delete the one you don't use/which doesn't contain data, check that your mountpoint in /etc/fstab refers to the correct one and run:
Code:
sudo mount -a
if you changed something in /etc/fstab.

Kind regards,

Eric
 
1 members found this post helpful.
Old 08-22-2011, 12:56 AM   #10
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
Hi Eric, hope you had a nice weekend! Sounds like it!

Hope this part looks right:
Quote:
bhakta@Krishna-PC:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=fe1ab25d-1c6c-4297-a18b-8f9571d8dbdc / ext4 errors=remount-ro 0 1
# swap was on /dev/sda7 during installation
UUID=fe43f7fe-9944-4085-b515-4747e3d92195 none swap sw 0 0

/dev/sda8 /mnt/data vfat auto,user,rw 1 2
 
Old 08-22-2011, 01:06 AM   #11
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi buddy,

Yeah, I had a very nice weekend. Hope you did too. Your /etc/fstab looks OK to me. But you mount your vfat to /mnt/data. Does that mean you created a symbolic link in your home directory? I'm a bit confused with your explanation of the two directories Fat... Did you create two directories and a symbolic link as I suspect or did you mount your partition under one of those directories?

Kind regards,

Eric
 
1 members found this post helpful.
Old 08-22-2011, 01:21 AM   #12
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
Well, my intention was to make the Fatass32 (FAT32 file sys) drive behave like the ext3 that you helped me set up in the old thread:
http://www.linuxquestions.org/questi...itions-881489/

The behavior:
To access the partition, I simply navigated via gui to /home/DATA. /DATA was a folder under /home, as if it were simply just a subdirectory. Therefore, my intuition tells me this is a symbolic link. Is that correct? I did not need to navigate to /mnt or /media.

You know, I can still turn on that machine, and view the settings, then replicate...

In my GUI I have 2 different folders: Fatass32 and FatAss32.
Fatass32 currently opens the FAT32 partition, while FatAss32 opens a blank folder (and should be erased, it is not needed.)

The other machine is running now, so let me know if an fstab or other would help
 
Old 08-22-2011, 01:24 AM   #13
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

According to your fstab you're mounting /dev/sda8 on /mnt/data. So I assume you made a symbolic link. You can confirm that with the output of
Code:
ls -l
in your home directory. Better practice would be to mount the disk directly on /home/Fatass32 if that's the directory you want to use in combination with your FAT32 partition.

Kind regards,

Eric
 
1 members found this post helpful.
Old 08-22-2011, 01:31 AM   #14
Bhakta Neal
Member
 
Registered: Jul 2010
Location: Big Island, Hawaii
Distribution: Kubuntu10.04
Posts: 248

Original Poster
Rep: Reputation: 19
ls -l

Quote:
bhakta@Krishna-PC:~$ ls -l
total 36
drwxr-xr-x 2 bhakta bhakta 4096 2011-08-15 11:12 Desktop
drwxr-xr-x 2 bhakta bhakta 4096 2011-08-18 21:26 Documents
drwxr-xr-x 4 bhakta bhakta 4096 2011-08-20 10:18 Downloads
drwxr-xr-x 2 bhakta bhakta 4096 2011-08-21 16:28 Fatass32
drwxr-xr-x 3 bhakta bhakta 4096 2011-08-20 14:24 Music
drwxr-xr-x 3 bhakta bhakta 4096 2011-08-20 11:08 Pictures
drwxr-xr-x 2 bhakta bhakta 4096 2011-08-15 11:12 Public
drwxr-xr-x 2 bhakta bhakta 4096 2011-08-15 11:12 Templates
drwxr-xr-x 2 bhakta bhakta 4096 2011-08-20 14:28 Videos
 
Old 08-22-2011, 01:36 AM   #15
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

And the output of
Code:
mount
Kind regards,

Eric
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed slackware-try to access FAT32 file partition-permission denied-? linus72 Slackware 10 03-23-2009 08:23 AM
How do I manually mount a FAT32 external drive in Kubuntu 7.0.0? higleyg Linux - Newbie 1 05-26-2008 05:37 PM
Access denied when attempting access samba share warlockvix Linux - Software 1 05-11-2007 02:36 PM
getting access denied , when trying to access camera as normal user bennythepitbull Linux - Hardware 2 11-04-2003 02:30 AM
2 fat32 partitions on fbsd5/w2k dual. Can only access one fat32 so far.. mipia *BSD 1 10-06-2003 02:10 AM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration