LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-22-2009, 09:47 PM   #1
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
Installed slackware-try to access FAT32 file partition-permission denied-?


After a clean install of 12.2 I could access the FAT32 partition containing my files. But, after updating 12.2 I could no longer access the partition-"permission denied".
How can I fix this?
Thanks.
 
Old 03-22-2009, 10:18 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,442
Blog Entries: 4

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
Hi,

What do you mean by updating? What and how?
 
Old 03-22-2009, 10:31 PM   #3
arfon
Member
 
Registered: Apr 2004
Location: Texas - Dang, it's hot!
Distribution: Slackware, Slackware64, Slax, CentOS (when I have to)
Posts: 132

Rep: Reputation: Disabled
How are you mounting the partition?


Is it in your fstab? If it is in your fstab, did you set it with the 'users' parameter?

EXAMPLE:
/dev/sda1 /mnt/memstick auto noauto,users, 0 0
 
Old 03-23-2009, 07:24 AM   #4
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Original Poster
Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
OK-after installing 12.2 I added my firefox backup bookmarks to firefox from the FAT32 partition, got all my stuff working-3-button mouse, etc, then uncommented one of the slack mirrors, "slackpkg update", then "slackpkg upgrade-all". After upgrading-rebooted.
Got to KDE desktop, and after installing src2pkg and sbopkg, I again clicked on the "system" icon, clicked on "storage media", then clicked on the icon for the FAT32 partition-sda5-"permissions denied".
This did not happen the first time.
Here is my fstab-
Code:
/dev/hda9        swap             swap        defaults         0   0
/dev/hda1        /                ext3        defaults         1   1
/dev/hda5        /dev/hda5        vfat        defaults         1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
None of my other partitions are in the fstab-sda-2,3,6,7,8. Yet they can all be accessed easily. sda4 is extended.
Code:
bash-3.1# blkid
/dev/hda1: UUID="bf570f19-bade-4d0c-b93c-2e9b1c84e94c" TYPE="ext3" 
/dev/hda2: UUID="ce6d5374-9f45-41e4-9113-e72653b4a7ee" SEC_TYPE="ext2" TYPE="ext3" 
/dev/hda3: UUID="b31c0d39-40e4-4263-9be5-9c1158dff74b" TYPE="ext3" 
/dev/hda5: UUID="49BA-FC97" TYPE="vfat" 
/dev/hda6: UUID="3ebaeaf9-03e9-4dcf-a82f-e1ec1a907a73" SEC_TYPE="ext2" TYPE="ext3" 
/dev/hda7: UUID="f66a08c2-4555-44d8-a3d2-c33db50a7c6d" SEC_TYPE="ext2" TYPE="ext3" 
/dev/hda8: UUID="1e4d3cf6-57d2-4e0a-b73a-a5851a70197c" TYPE="ext3" 
/dev/hda9: TYPE="swap" 
bash-3.1#
So, what gives here??
Thanks.
 
Old 03-23-2009, 08:06 AM   #5
vbisis
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 250

Rep: Reputation: 34
Since the latest update, I have almost the same problem: Everytime I try to access a fat-formatted partition like an usb-stick the root password is asked to gain access.

Did I miss some change with udev or something?
 
Old 03-23-2009, 08:21 AM   #6
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Original Poster
Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
I think I see my problem-I told it /dev/hda5 as my mount point when installing-do I have to edit my fstab so it says "dev/hda5 /mnt/hda5" instead of "dev/hda5 /dev/hda5"??
Or do I have to create a mountpoint for it??
Help!
 
Old 03-23-2009, 08:42 AM   #7
arfon
Member
 
Registered: Apr 2004
Location: Texas - Dang, it's hot!
Distribution: Slackware, Slackware64, Slax, CentOS (when I have to)
Posts: 132

Rep: Reputation: Disabled
Yep, THAT'S your problem...

/dev/hda5 /dev/hda5 is SOOOO wrong!

You can't mount it to itself.

/dev/hda5 /mnt/hda5 is ok
/dev/hda5 /mnt/someotherdirectory is ok
/dev/hda5 /somedirectory/somedirectory/somedirectory is ok

The fix is EASY...

1) make sure your mount point exists and if it doesn't, create it: mkdir /mnt/hda5
2) edit your fstab so the "/dev/hda5 /dev/hda5..." says "/dev/hda5 /mnt/hda5..."

It should then mount ok.

Last edited by arfon; 03-23-2009 at 08:47 AM.
 
Old 03-23-2009, 08:45 AM   #8
GazL
Senior Member
 
Registered: May 2008
Posts: 3,502

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Yep, that's your problem.

I'd recommend creating your mountpoint somewhere else other than under /mnt (Have a read of /mnt/README and you'll see why), but how you name your mountpoints is all down to personal preference.
 
Old 03-23-2009, 08:47 AM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 3,502

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Quote:
Originally Posted by arfon View Post
Yep, THAT'S your problem...
lol... now you've gone and made me sound like an echo.
 
Old 03-23-2009, 08:49 AM   #10
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Original Poster
Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
YEP-and it was as simple as-
Code:
bash-3.1# mkdir /mnt/hda5
bash-3.1# mount /dev/hda5 /mnt/hda5
bash-3.1#
Der?!
Dolt!
Thanks guys.
 
Old 03-23-2009, 09:23 AM   #11
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,944

Rep: Reputation: Disabled
For future reference, http://slackwiki.org/Windows_Partitions might be helpful.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Access permission denied wegadnie Linux - Newbie 7 11-03-2008 10:18 PM
bashrc file access permission denied swift_a2002 Linux - Software 12 02-27-2008 07:51 PM
Permission denied to a partition jaen Linux - Newbie 12 05-20-2007 08:33 PM
permission for FAT32 partition academik Linux - Software 6 01-16-2006 10:20 AM
file permissions on VFAT partition - access denied cevjr Linux - Security 3 09-04-2003 05:50 PM


All times are GMT -5. The time now is 03:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration