LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-05-2004, 09:17 AM   #1
Fred Greg
LQ Newbie
 
Registered: Oct 2004
Location: NSW, Australia
Distribution: Debian GNU/Linux - testing (sarge)
Posts: 2

Rep: Reputation: 0
Keys swapped while not in X, mouse wheel not working.


While not logged into X, ie. while logged into tt2, tt3, etc., some of my keys swap:

# becomes
@ becomes "
" becomes @

As far as I've seen, that's all - but entering the code for (Alt+0163) gives the correct symbol, so I can't type # at all, which is annoying for config files - no comments.

This doesn't occur in X; that's just fine. So I can configure everything from X, but that's a pain - what if I don't want to run X?

I have no idea how to configure the keyboard except for X, which is fine.

Also, my mouse wheel isn't working in X - I found this site while searching Google, but the help previously given there didn't help - X's config file used a different format, & it looked like it was set up anyway:
Code:
/etc/X11/FX86Config-4
Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "PS/2"
        Option          "Emulate3Buttons"       "true"
# I don't need this emulation, I've got 3 buttons; should I turn it off?
Code:
        Option          "ZAxisMapping"          "4 5"
# This ZAxisMapping is what was suggested to include in the other thread I found in this site, but it's already on... help!?!
Code:
EndSection
Section "InputDevice"
        Identifier      "Generic Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection
I'm using a PS/2 Logitech Navigator Duo (Mouse & Keyboard), both of which are fine bar one problem each. These are the only config problems I've encountered yet. I run Debian sarge (testing), with 512MB DDR, P4 2.6 GHz, only 10 GB to Linux, the rest is for Windows XP, where the stuff works perfectly. I've got an nVidia GeForce4 MX 440 (don't see how that could affect it, but I dunno), AC '97 Sound. Those are fine.
 
Old 10-05-2004, 09:26 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Here is the relevant section of my XF86Config-4 file (Mandrake 10)
Code:
Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection
Note the Option "ZAxisMapping" "6 7" BTW, it's only an el-cheapo Belkin USB optical scroll mouse, not an MS one.

Baldrick
 
Old 10-05-2004, 09:29 AM   #3
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
And as far as the keyboard goes, it sounds like the system is configured to use a UK keyboard, but a US one in X ... strange. Not too sure how to fix that

Baldrick
 
Old 10-05-2004, 10:52 AM   #4
Fred Greg
LQ Newbie
 
Registered: Oct 2004
Location: NSW, Australia
Distribution: Debian GNU/Linux - testing (sarge)
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks Baldrick65 - It didn't work, but could it be the numbers? I have no idea where to get specs on the Logitech mouse though...

Any ideas as to where I might be able to configure the system keyset or whatever it's called, anyone?
 
Old 10-06-2004, 07:41 AM   #5
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Try deleting the "Emulate 3 Buttons" option and muck around with the "ZAxisMapping" number settings. Try "6 7" and "4 5" to see if it helps. I'm not sure about the keyboard mapping though

Baldrick

Last edited by Baldrick65; 10-06-2004 at 07:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PS2 wheel mouse/wheel not working jayhel Linux - Hardware 2 06-18-2006 07:54 PM
mouse wheel not working mike_savoie Debian 2 07-28-2005 11:34 AM
mouse wheel not working kmichal2 Mandriva 2 11-29-2004 08:29 AM
mouse wheel not working oldi Slackware 7 04-19-2004 05:39 PM
how to get Mouse wheel working fwee Slackware 13 07-06-2003 03:09 PM


All times are GMT -5. The time now is 05:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration