LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2008, 04:08 PM   #1
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Rep: Reputation: 31
keyboard: I can't get this sign ^ correctly!


Hi!
I have opensuse 10 on a laptop. I can't manage to get this sign ^ to work correctly. It should be placed under the letter, not on its side. All other signs like or work fine. I've try to change languages in french or german, I tried all the keyboards but nothing work.
I would be very thankful for any help. I need to use this sign properly.
 
Old 05-17-2008, 04:52 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
On my keyboard I would hit CTRL+6 to get it, where is it on your keyboard?
 
Old 05-17-2008, 04:54 PM   #3
vadkutya
Member
 
Registered: Apr 2008
Distribution: slackware 10.2
Posts: 117

Rep: Reputation: 16
hey xpucto,

maybe the font you use does not support this? if ` and works correctly then it has nothing to do with the nodeadkeys option. you can specify this in /etc/xorg.conf. if nodeadkeys is switched on you have no dead keys which means every key pressed prints it output right away and is not waiting for additional keystrokes. if you press the key and it prints the right away you have nodeadkeys. if it prints nothing but gives you if you press 'e' afterwards then you have dead keys.

since and ` works correctly it might be a problem with the font you are using. check it out. with what editor do you work. does the problem occure with any editor?

vadkutya

p.s. try ALT+j this should do the trick if ^+e does not work. but it does only work for in console, i think. try ALT+b for and ALT+n for . ALT+t is . i couldn't find the hatted u because my keyboard commands are redefined by wmii.

Last edited by vadkutya; 05-17-2008 at 05:00 PM.
 
Old 05-18-2008, 03:08 AM   #4
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by XavierP View Post
On my keyboard I would hit CTRL+6 to get it, where is it on your keyboard?
On my keyboard ^ is the first key on the left just near the 1. CTRL+^ doesn't work.

Quote:
Originally Posted by vadkutya View Post
hey xpucto,

maybe the font you use does not support this? if ` and works correctly then it has nothing to do with the nodeadkeys option. you can specify this in /etc/xorg.conf. if nodeadkeys is switched on you have no dead keys which means every key pressed prints it output right away and is not waiting for additional keystrokes. if you press the key and it prints the right away you have nodeadkeys. if it prints nothing but gives you if you press 'e' afterwards then you have dead keys.

since and ` works correctly it might be a problem with the font you are using. check it out. with what editor do you work. does the problem occure with any editor?

vadkutya

p.s. try ALT+j this should do the trick if ^+e does not work. but it does only work for in console, i think. try ALT+b for and ALT+n for . ALT+t is . i couldn't find the hatted u because my keyboard commands are redefined by wmii.
Hi Vadkutya!
I've looked under /etc/X11/xorg.conf, the nodeadkey is not switched on:
Quote:
Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de,de,fr"
Option "XkbModel" "acer_tm_800"
Option "XkbOptions" "grp:alt_shift_toggle"
Option "XkbRules" "xfree86"
Option "XkbVariant" "deadgraveacute,,"
maybe ist Keyboard[0] the problem?

^ doesn't work on any editor: vim (terminal), kate, openoffice, firefox...

thanks guys for your support.
 
Old 05-18-2008, 06:36 AM   #5
vadkutya
Member
 
Registered: Apr 2008
Distribution: slackware 10.2
Posts: 117

Rep: Reputation: 16
hey xpucto,

you're right. xorg.conf is in /etc/X11/. sry. but i think i found the culprit. you have
Code:
Option "XkbVariant" "deadgraveacute,,"
in your xorg.conf. this option means that only grave and acute are nodeadkeys. hence '~' and '^' still are. try:
Code:
Option "XkbVariant" "Standard"
should fix it. hope it helps.

good luck, vadkutya
 
Old 05-18-2008, 08:00 AM   #6
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by vadkutya View Post
hey xpucto,

you're right. xorg.conf is in /etc/X11/. sry. but i think i found the culprit. you have
Code:
Option "XkbVariant" "deadgraveacute,,"
in your xorg.conf. this option means that only grave and acute are nodeadkeys. hence '~' and '^' still are. try:
Code:
Option "XkbVariant" "Standard"
should fix it. hope it helps.

good luck, vadkutya
Thanks vadkutya, it works! Many thanks for your time and help! Now I'm able to deal again with and !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB errors durring boot. have to unplug keyboard, plug back in to use it to sign on agentc0re Slackware 5 03-17-2008 08:02 PM
Apple USB Keyboard not working correctly vladuz976 Linux - Hardware 1 08-12-2006 12:25 PM
'' sign on us keyboard mayasedai Linux - General 7 07-23-2006 01:31 PM
Keyboard not working correctly Zakos Ubuntu 0 06-11-2006 02:24 PM
Keyboard doesn't work correctly in kde or gnome dokterneo Slackware 2 08-15-2003 08:09 AM


All times are GMT -5. The time now is 08:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration