LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-29-2002, 09:40 AM   #1
abinash_y
LQ Newbie
 
Registered: Apr 2002
Location: NJ, USA
Distribution: redhat 7.2
Posts: 11

Rep: Reputation: 0
Kernel panic : VFS : Unable to Mount root FS


Hi,
I have redhat 7.2 , Kernel 2.4.7.10 successfully installed on my Laptop, and i am trying to update kernel to 2.4.19 , so ...

i download complete source from kernel.org, then used following steps .

1. make xconfig
2. make dep
3. make bzImage
4. make modules
5. make modules_install
6. cp .../linux2.4.19/arch/i386/boot/bzImage /boot/bzImage-2.4.19
7. edited grub.conf
default=1
timeout=10
splashimage=(hd0,2)/grub/splash.xpm.gz
title Red Hat Linux (2.4.7-10)
root (hd0,2)
kernel /vmlinuz-2.4.7-10 ro root=/dev/hda5
initrd /initrd-2.4.7-10.img
title Windows XP
rootnoverify (hd0,1)
chainloader +1
title Red Hat Linux (2.4.19)
root (hd0,2)
kernel /bzImage-2.4.19 root=/dev/hda5
# initrd /initrd-2.4.7-10.img

and i thought, i did everything right , but when i rebooted m/c to load new kernel

i got following error lines
kmod: failed to exec /sbin/modprobe -s -k block-major-3, errno=2
VFA: cannot open root device "/hda5" or 03:05
please append a correct "root=" boot option
kernel panic: VFS: Unable to mount root fs on 03:05

my old kernel still working fine, without any problems.
i couldn't find any fix to this

thanks for any help
 
Old 08-29-2002, 01:54 PM   #2
dwd
Member
 
Registered: Aug 2002
Distribution: RedHat / Debian / Ubuntu
Posts: 35

Rep: Reputation: 15
Try taking out the "root=..." option, and use rdev on the kernel image to get, and if needed set, the kernel's internal knowledge of the root partition.

You *may* well find that it's set rght anyway.

Of course, real men don't use a boot loader, they just insert a formatted floppy, and:

cat /boot/bzImage-2.4.19 >/dev/fd0

And therefore that *needs* rdev. It's a handy tool, found in util-linux, which you almost certainly have installed already, since initscpits depends on it, amongst other things.
 
Old 08-31-2002, 03:32 AM   #3
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
what kind of hardrive do you have?, IDE or Scsi?, if it's scsi then the problem is that you probably forgot to enable the Scsi adapter which is what accesses your hardrive, and so your kernel cannot mount an invisible hardrive. Also check to see you didn't forget to enable the support for the correct file system, that's crucial,
let us know how it goes.
 
Old 08-31-2002, 09:33 AM   #4
kald
LQ Newbie
 
Registered: Aug 2002
Posts: 4

Rep: Reputation: 0
You probably put the support for ext2 (or whatever your root filesystem is ) as module. You need to put it into the kernel.
So, make again a 'make xconfig' , and check it out.
 
Old 09-01-2002, 06:07 AM   #5
dwd
Member
 
Registered: Aug 2002
Distribution: RedHat / Debian / Ubuntu
Posts: 35

Rep: Reputation: 15
Right, his hard drive is IDE - hence the "hda5", and it's not a filesystem problem, since the modprobe is failing on major 3, which is indeed hda*.

Thinking about it, it seems likely that IDE is compiled in as a module, or not at all. If as a module, it's not present in the initrd, assuming there is one at all.
 
Old 09-04-2002, 02:06 PM   #6
abinash_y
LQ Newbie
 
Registered: Apr 2002
Location: NJ, USA
Distribution: redhat 7.2
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks.
i didn include support for IDE during kernel compilation (smart me ).

i recompiled and incuded code for IDE(in kernel) and it worked .

-Abinash
 
Old 09-05-2002, 03:58 AM   #7
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
congrats then, , good it wasn't anything serious,

Last edited by zLinuxz; 09-05-2002 at 04:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic: VFS: Unable to mount root fs in 08:02 sebas_turu Debian 10 01-21-2008 02:04 AM
Kernel Panic: VFS: Unable to mount root fs on 09:02 verbali Linux - Hardware 8 02-24-2004 07:11 PM
Kernel panic: VFS: Unable to mount root cmlo Linux - Software 4 05-20-2003 03:25 AM
Kernel panic: VFS: Unable to mount root cmlo Linux - Newbie 3 05-17-2003 08:55 PM
Kernel Panic: VFS: Unable to mount root fs on 09:02 verbali Linux - General 6 05-26-2002 03:30 PM


All times are GMT -5. The time now is 04:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration