LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Closed Thread
 
Search this Thread
Old 05-06-2002, 01:22 PM   #1
verbali
LQ Newbie
 
Registered: May 2002
Location: dxb
Distribution: Redhat GNU/Linux 7.2
Posts: 16

Rep: Reputation: 0
Unhappy Kernel Panic: VFS: Unable to mount root fs on 09:02



Hi guys,

I am new to GNU/Linux. I get a Kernel Panic on booting up from CD (while installing rh GNU/Linux 7.2 on a notebook):

EXT2-fs: unable to read superblock (does it mean: could not read the installation-system-root-fs from CD?)

cramfs: wrong magic (does it mean: installation-system-root-fs have to load into ramdisk - compressed ram fs, but failure?)

isofs_read_super: bread failed, dev=09:02, iso_blknum=16, block=32 (are these the block #s which are not readable on the CD?)

Kernel Panic: VFS: Unable to mount root fs on 09:02 (the result: Kernel could not load root-fs, gives up...)

I got the same result while attempting to boot from a floopy which was created from a previous installation (on a Compaq Deskpro - which went smooth from the same set of CDs). I tried it again on the Compaq, works just fine...

-I passed Linux mem=256M at boot: prompt, didn't help.
-no "crc: errorFreeing initrd memory: xxxK"
-The same set of CDs work fine on other systems - media: ok
-The CD ROM drive is ok, as rh GNU/Llinux 7.1 works just fine on this notebook.
-tried disabling power saving feature in BIOS, didn't help.

There's a Win2k (on /dev/hda1). Not that it should make any difference. And the partition I wish to install rh 7.2 is currently FAT32 - but I'm going to be formatting it. So that shouldn't matter, if I understand it right...

In distress, any help will be greatly appreciated. Thanks a ton in advance.
-Verb-
 
Old 05-06-2002, 01:56 PM   #2
kill-hup
Member
 
Registered: Aug 2000
Location: NY - USA
Distribution: Slackware
Posts: 109

Rep: Reputation: 15
Are you running into this error when attempting to install, or has Linux already been installed on your system and you are trying to boot via CD?
I only ask to clarify the problem

If you are installing Linux from the RH7.2 CD, you really needn't pass any parameters at the "boot:" prompt. It sounds to me like the CD is attempting to boot an existing Linux system with either isn't there yet or is referencing the wrong HD partition.
 
Old 05-06-2002, 02:08 PM   #3
verbali
LQ Newbie
 
Registered: May 2002
Location: dxb
Distribution: Redhat GNU/Linux 7.2
Posts: 16

Original Poster
Rep: Reputation: 0
Hi kh,

I'm running into this kernel panic while trying a fresh install (!). I passed the mem param just to ensure that it sees all the memory there is. Just tried. Do you have any ideae what dev=09:02 means? I've seen various numbers in various situations. I think that may give us a good pointer...

Thank you for caring to reply...

-Verb-
 
Old 05-06-2002, 02:29 PM   #4
kill-hup
Member
 
Registered: Aug 2000
Location: NY - USA
Distribution: Slackware
Posts: 109

Rep: Reputation: 15
Sounds to me like the CDROM drive is having difficulty reading the CD. Since you said the same disc works well in other machines, I would have to fault the hardware on this laptop.

You might want to try cleaning the drive or even adjusting the speed settings in the bios, if it allows it. I had a Thinkpad once that would refuse to read my install CD until I boosted the speed of the drive in the bios from "quiet" to "normal"

Silly question, but did you recently install W2K from CD? Just looking to see if it could be confirmed as a CDROM problem or not
 
Old 05-06-2002, 02:38 PM   #5
verbali
LQ Newbie
 
Registered: May 2002
Location: dxb
Distribution: Redhat GNU/Linux 7.2
Posts: 16

Original Poster
Rep: Reputation: 0
Hi kh,

The CD ROM works fine, or so it looks. I tried installing rh GNU/Linux 7.1, and it works fine. Yes, I did install Win2k recently on it.

The BIOS (SystemSoft MobilePRO BIOS version 1.01) does not have options to set CD ROM speeds.

I posted here after trying all that I could before asking for help. I really appreciate your help. Thank you.

I'm still trying to figure out what dev=09:02 means... any clues?

-Verb-
 
Old 05-26-2002, 02:26 PM   #6
verbali
LQ Newbie
 
Registered: May 2002
Location: dxb
Distribution: Redhat GNU/Linux 7.2
Posts: 16

Original Poster
Rep: Reputation: 0
Thumbs up Kernel no more panic-ing!

I got the notebook up and running with Redhat GNU/Linux 7.3

Made a FAT32 partition, copied the ISOs (3), pointed there by root=/dev/hda3 at boot prompt and got on with installing from there...

I haven't been able to trace the reason for the panic, though! As it was so badly needed to get this notebook up 'n running...

Thanks everyone, for the time and help extended, I really appreciate it. Thank you.
 
Old 05-26-2002, 02:30 PM   #7
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
This thread is a reason why we don't double post. Same question in different forums getting answers. Please refrain from double posting in the future please.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic: VFS: Unable to mount root fs in 08:02 sebas_turu Debian 10 01-21-2008 01:04 AM
Kernel Panic: VFS: Unable to mount root fs on 09:02 verbali Linux - Hardware 8 02-24-2004 06:11 PM
Kernel panic: VFS: Unable to mount root cmlo Linux - Software 4 05-20-2003 02:25 AM
Kernel panic: VFS: Unable to mount root cmlo Linux - Newbie 3 05-17-2003 07:55 PM
Kernel panic : VFS : Unable to Mount root FS abinash_y Linux - Newbie 6 09-05-2002 02:58 AM


All times are GMT -5. The time now is 08:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration