LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2004, 02:22 AM   #1
ihsus
LQ Newbie
 
Registered: Mar 2004
Posts: 13

Rep: Reputation: 0
KDE upgrade from 3.1.4 to 3.2.1 went wrong?


I followed some instructions posted here and upgraded KDE.
I ignored some messages regarding dependency issues because all of them said "installed".
Now KDE 3.2.1 is up and running, I don't really think it's slow, or has some issues, but when I booted up YaST and clicked "Install and Remove Software" I got massive amount of conflict list which scared me.
Also, when I tried to ./configure some things, an error saying "qt -mt" not found" came up.
Did I manage to destroy KDE?
What should I do with those conflicts?!

Quote:
#### YaST2 conflicts list - generated 2004-03-16 00:46:05 ####

arts 1.1.4-23 conflict
Required by:
arts-devel requires arts = 1.1.4-
Conflict Resolution:
( ) Remove All 9 Conflicting Packages
Delete kdesdk3-devel
Delete kdemultimedia3-devel
Delete kconfigure
Delete kdegraphics3-devel
Delete kdevelop3
Delete arts-devel
Delete kdenetwork3-devel
Delete kdebase3-devel
Delete kdelibs3-devel
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.1.4-36 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Unresolved Requirements:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 4 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.2.1-10 conflict
Required by:
kdeaddons3-kate requires libkateinterfaces.so
kdeaddons3-kate requires libkmultitabbar.so.0
kdeaddons3-konqueror requires libkonq.so.4
kdeaddons3-konqueror requires libkonqsidebarplugin.so.0
kdebase3-devel requires kdebase3 = 3.1.4-
kdebase3 requires appletproxy.so
kdebase3 requires extensionproxy.so
kdebase3 requires kaccess.so
31 more...
Conflicts with:
kdebase3 conflicts with kdebase3-SuSE <= 9.0-
Conflict Resolution:
( ) Remove All 8 Conflicting Packages
Delete susehelp_en
Delete kdevelop3
Delete susehelp
Delete kdeaddons3-konqueror
Delete kdebase3-SuSE
Delete kdebase3-devel
Delete kdeaddons3-kate
Delete kdebase3
( ) Ignore Conflict and Risk System Inconsistencies
kdelibs3 3.1.4-24 conflict
Required by:
kdelibs3-devel requires kdelibs3 = 3.1.4-
Conflict Resolution:
( ) Remove All 8 Conflicting Packages
Delete kdesdk3-devel
Delete kdemultimedia3-devel
Delete kconfigure
Delete kdegraphics3-devel
Delete kdevelop3
Delete kdenetwork3-devel
Delete kdebase3-devel
Delete kdelibs3-devel
( ) Ignore Conflict and Risk System Inconsistencies
libkateinterfaces.so not available
Required by:
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkateinterfaces.so
kdebase3 requires libkateinterfaces.so
Conflict Resolution:
( ) Remove All 5 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
Delete kdebase3
( ) Ignore Conflict and Risk System Inconsistencies
libkmultitabbar.so.0 not available
Required by:
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkmultitabbar.so.0
kdebase3 requires libkmultitabbar.so.0
Conflict Resolution:
( ) Remove All 5 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
Delete kdebase3
( ) Ignore Conflict and Risk System Inconsistencies
libkonqsidebarplugin.so.0 not available
Required by:
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libkonqsidebarplugin.so.0
kdebase3 requires libkonqsidebarplugin.so.0
Conflict Resolution:
( ) Remove All 5 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
Delete kdebase3
( ) Ignore Conflict and Risk System Inconsistencies
libksgrd.so.0 not available
Required by:
kdebase3 requires libksgrd.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libksgrd.so.0
kdebase3 requires libksgrd.so.0
Conflict Resolution:
( ) Remove All 5 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
Delete kdebase3
( ) Ignore Conflict and Risk System Inconsistencies
libsensordisplays.so.0 not available
Required by:
kdebase3 requires libsensordisplays.so.0
kdebase3 requires libsensordisplays.so.0
kdebase3 requires libsensordisplays.so.0
kdebase3 requires libsensordisplays.so.0
kdebase3 requires libsensordisplays.so.0
kdebase3 requires libsensordisplays.so.0
kdebase3 requires libsensordisplays.so.0
kdebase3 requires libsensordisplays.so.0
Conflict Resolution:
( ) Remove All 5 Conflicting Packages
Delete kdevelop3
Delete kdeaddons3-konqueror
Delete kdebase3-devel
Delete kdeaddons3-kate
Delete kdebase3
( ) Ignore Conflict and Risk System Inconsistencies
libxml2 2.5.10-25 conflict
Required by:
libxml2-devel requires libxml2 = 2.5.10-
Conflict Resolution:
( ) Remove All 12 Conflicting Packages
Delete kdesdk3-devel
Delete kdemultimedia3-devel
Delete kconfigure
Delete libxslt-devel
Delete libxml2-devel
Delete kdegraphics3-devel
Delete libbonoboui-devel
Delete kdevelop3
4 more...
( ) Ignore Conflict and Risk System Inconsistencies
libxslt 1.0.32-25 conflict
Required by:
libxslt-devel requires libxslt = 1.0.32-
Conflict Resolution:
( ) Remove All 9 Conflicting Packages
Delete kdesdk3-devel
Delete kdemultimedia3-devel
Delete kconfigure
Delete libxslt-devel
Delete kdegraphics3-devel
Delete kdevelop3
Delete kdenetwork3-devel
Delete kdebase3-devel
Delete kdelibs3-devel
( ) Ignore Conflict and Risk System Inconsistencies
qt3 3.2.1-34 conflict
Required by:
qt3-devel requires qt3 = 3.2.1-
qt3-non-mt requires qt3 = 3.2.1-
Conflict Resolution:
( ) Remove All 16 Conflicting Packages
Delete qt3-devel-doc
Delete kdesdk3-devel
Delete kdemultimedia3-devel
Delete kconfigure
Delete kdegraphics3-devel
Delete kdevelop3
Delete kdelibs3-devel-doc
Delete qt3-devel-tools
8 more...
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###
 
Old 03-16-2004, 02:26 AM   #2
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
where you using kde when u upgraded?
 
Old 03-16-2004, 02:30 AM   #3
ihsus
LQ Newbie
 
Registered: Mar 2004
Posts: 13

Original Poster
Rep: Reputation: 0
No, I was in text mode.
I did "rpm -Uvh --nodeps --replacefiles *.rpm" and did not get any error during the installation...
 
Old 03-16-2004, 02:34 AM   #4
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
what distro are u using?
 
Old 03-16-2004, 02:49 AM   #5
ihsus
LQ Newbie
 
Registered: Mar 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I forgot to say I use SuSE 9 Pro, sorry.
I did an upgrade on a fresh install of SuSE (didn't even do online updates), KDE is working perfectly so far (except for that qt -mt problem).
Since this is just a fresh install of SuSE, I might just go ahead and ignore these, and play with things, but it'd be still great if anybody could tell me what those conflicts mean.
 
Old 03-16-2004, 02:56 AM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
do "rpm -qa | grep kde" and see if 3.1.4 packages are still there
also try doing a "rpm --rebuilddb"
 
Old 03-16-2004, 10:59 AM   #7
ihsus
LQ Newbie
 
Registered: Mar 2004
Posts: 13

Original Poster
Rep: Reputation: 0
"rpm -qa | grep kde" showed that basic files I installed are 3.2.1 but a lot of others are still 3.1.4. (Such as kde-games, but I don't think they all need to be 3.2.1?)
I'm going to re-install SuSE and will try to solve issues before upgrading KDE. I'll post the exact dependency errors later.
Thanks for your helps so far!
 
Old 03-17-2004, 05:23 PM   #8
ihsus
LQ Newbie
 
Registered: Mar 2004
Posts: 13

Original Poster
Rep: Reputation: 0
After reinstalling SuSE, I tried again and upgrading went well!
Here's what I did.

After downloading all kde base packages rpms to a folder, I switched to text mode, and did "rpm -Uvh *.rpm" and it gave me
Code:
error: Failed dependencies:
kdebase3-SuSE <= 9.0 conflicts with kdebase3-3.2.1-10
libkateinterfaces.so.0 is needed by (installed) kdeaddons3-kate-3.1.4-35
libkmultiabbar.so.0 is needed by (installed) kdeaddons3-kate-3.1.4-35
libkonqsidebarplugin.so.0 is needed by (installed) kdeaddons3-konqueror-3.1.4-35
After doing some googling, I learned that I had to delete some files in order to upgrade KDE if you're using SuSE 9.0.
As for those 3 files needed, I just had to download 3.2.1 versions of kdeaddons3 and put them in the folder I put other rpms.

So I switched to text mode again, typed "rpm -e kdebase3-SuSE kdenetwork3-mail" to delete conflicting rpms, then did "rpm -Uvh *.rpm" again.
I got some error about files of k3b conflicting, so I deleted k3b, tried "rpm -Uvh *.rpm" and the insallation worked!

Then I did "rpm -qa | grep kde" to check version #s, and upgraded my other installed rpms one by one. Now "rpm -qa | grep kde" shows that all my kde rpms are version 3.2.1!
Thanks for help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrade to XORG went wrong - now what? ravenslay3r Debian 8 07-13-2005 11:24 AM
Something went wrong in upgrade to 2.6.10 Mirari Slackware 1 06-09-2005 11:48 PM
X config wrong following upgrade quinnk Red Hat 1 04-26-2005 05:44 PM
Fluxbox upgrade, something's wrong. littlemidget Debian 5 01-25-2005 12:53 AM
XFree upgrade gone wrong... salinger Linux - Software 5 04-16-2003 08:13 PM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration