LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-17-2003, 12:59 AM   #1
tokyoprogressiv
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Rep: Reputation: 0
Japanese-English issues in Suse (and/or other Linuxes)


Hi


Lots of questions....if EVEN ONE of them can be answered, I would be grateful.

I started on APPLE II, then Mac, then Windows. I was persuaded that Suse Linux would not be that hard unless I wanted to master Linux. I just want to use it for now. I learn slowly, but eventually do learn. But since I opted to get rid of Windows, I need to at least be able to use it rather than want to learn all there is to learn about things.

The problem: Japanese

I have had Suse a week, but internet is up at new place since this morning. I see you can choose KDE (default) or Gnome. I first chose Kde by default. Played with language setting. First disappointment is, unlike Windows 2000 English version, which gives me Eng menus in most program but allows Japanese input, I cannot input in Japanese unless in Japanese. I prefer Eng menus.

(1) Is there a way to have Eng menus and yet inut in Japanese? My ability in Japanese is such that I prefer my own langaiuge for the menus.

(2) I next chose Gnome because it looked easier. I think I switched to English. Went back to KDE, menus are now in English. Some programs come up in Japanese and some in Eng. It seems it can't decide what mode it is in. Is this normal? is there a soliution.? (Seems to be English mode because the programs do not allow Japanese input).

Other little things:

(3) Hardware

When I bought this made-to-order computer, it came with a 3.0 AMD processor and an ATA -serial drive (didn't even know there was such a beast). It seemed to cause some Windows probelms in not recognizing the disk, and there was an Asus driver disk for the motherboard that I was told I HAD to install. Now that i have tossed Windows entirely, I assume that I will be able at some point to go online and get something for the motherboard, if necessary, just like for the Nvidea 3D drivers, since I cannot access all the goodies on those disks. any comments here would be welcome. Happily, HP Scanner-printer-fax Scanner tested out ok, and I could select a compatible printer driver. Also, Creative video cam is ok.

(4) I used to use Cakewalk to record audio programs or do Midi on my old 350 Pentium. When i tried with my Windows 2000 on the new machine, I was getting a one second delay after striking a key. I have yet to set up for Suse. Any recommendations.?

(5) Email: I used to use Becky for its reliabilty and simplicity. Don't need bells and whistles. Just reliability. Which is the most similar mail program? Something called Simian or something came up in Japanese, while something called KDe mail or something was in English. That was wierd.

(6) Some messenger type program came up. I could even see myself. But it doesn' t seem to accept MS messenger addresses (hotmail).

Another claimed to be compatible but didn't seem to have a webcam function.

That one, or another, told me I had logged off or something.


Well, since my friend and I regularly used MS messenger, and I would like to first see if she can stick with it, I wonder if there is another way? I tried to download MS Messenger, but that Linux did not know how to open it (and I guess it won't work anyway since MS messenger is likely anti-Linux, right?

I suppose I will have to migrate to another program....but if there is one that allows her to keep messenger, or use Yahoo or some other that includes Webcam, that would be nice.



That's about it. I think I need to take things one at a time rather than read up on everything, but would appreciate advice from people experienced in the above. Do not know how much is Suse specific either. Assume almost any linux progra will work on any linux setup---you call them disfos?????


Paul Arenson

paul@tokyoprogressive.org
 
Old 12-17-2003, 03:29 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Believe me, linux is much more flexible when it comes to internationalisation (until unicode is widely adapted by win32 developers), if you know what you're doing.
To input Japanese there's several IME's to choose from, but I recommend canna + kinput2, they should be included in your Suse cdrom, you can install them with YaST2.
Then add these lines in your ~/.profile

exec /usr/X11R6/bin/kinput2 -canna &
export LC_CTYPE=ja_JP
export XMODIFIERS="@im=kinput2"

logoff and login again you should now be able to input japanese by pressing "CTRL + O"
Make sure you use a font in your applications that is able to display Japanese, otherwise sometimes it'll still work but fall back using an ugly default unicode font.

As for the applications, take notice of your locale environment variables, open up a terminal and type "locale", $LANG and $LC_CTYPE are the most influencial, only LC_CTYPE should be set to ja_JP, others should be en_US (or watever). I think YaST2 sets this automatically depending on what you chose but you can override it using the ~/.profile file, basically export LC_CTYPE to ja_JP and the rest to en_US or watever you prefer. As far as I know most applications looks at the $LANG variable to determine their output.
For email kmail is pretty simple to use IMO, try Gaim for IM.
 
Old 12-17-2003, 10:10 AM   #3
tokyoprogressiv
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks, Demonbane. I will have to figureout how to do some of what you write when I come back from a trip to the States....leaving day after tomorrow. I am not sure what to make of the stuff about opening up in a terminal...local, lang\, etc. All unfamilair stuff for the moment.....

Menawhile, you wrote try Gaim.....well, I did but get this:
TOKYOPROGRESSIVE@hotmail.com has been disconnected...I wonder if my internet settings need to be tweaked. It is fiber optic, and I did not have to enter any of the intyernet numbers in connection......it worked automatically.


I ask because my dreamhost email also does not open in Kmail.....

Better wait to hear what dreamhost has to say about it..


But I will try your Japanese suggestions as soon as I get back.

Thanks agian.
 
Old 12-17-2003, 04:32 PM   #4
tokyoprogressiv
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Unhappy response from dreamhost on kmail

Well, so far, not so good....

I got a response from dreammail that shows they do not understand my problem, or I did not explian it well....

This is what they said I my response.....



DreamHost Customer Support Team said:
> ------------------------------------------------------------------------
>
> Hello,
>
>
>
> You should be using mai.imcjapanstream.org for your mail server. That
> seems like the problem you are having.


Thanks, but I am sorry, I am not sure I understand.

You wrote mai.imcjapanstream.org...I entered and got NO SUCH HOST (this is in RECEIVE)

I went back and put mail.imcjapanstream.org
and the error disappeared.....

But no mail

So let me summarize...please let me know specifically for this email program, Kmail, the most common in Linux I hear,

RECEIVE

name
login
password
host
port
prefix to folders


I have
imcjapan
paul
****** (same as webmail)
imcjapanstream.org
143
----




For SEND

I have
NAME imcjapan
HOST imcjapanstream.org
PORT 25
RECOMMEND ----

Server requires authentication
login paul
password ******


So where is the mistake?

--------------->

Do you think there is something wrong with my internet setup, am I misunderstanding the configuration or????

(Webmail works fine)

Thanks!
 
Old 12-18-2003, 10:28 AM   #5
tokyoprogressiv
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Original Poster
Rep: Reputation: 0
japanese

----> is widely adapted by win32 developers), if you know what you're doing.
To input Japanese there's several IME's to choose from, but I recommend canna + kinput2, they should be included in your Suse cdrom, you can install them with YaST2.


I did this as part of installation (adding things)


Then add these lines in your ~/.profile]

WHERE DO I DO THIS???

exec /usr/X11R6/bin/kinput2 -canna &
export LC_CTYPE=ja_JP
export XMODIFIERS="@im=kinput2"

logoff and login again you should now be able to input japanese by pressing "CTRL + O"
Make sure you use a font in your applications that is able to display Japanese, otherwise sometimes it'll still work but fall back using an ugly default unicode font.


WELL--> I tried in an editor but CONTROL O brings up a menu......




As for the applicatio



ns, take notice of your locale environment variables,

WHERE DO I FIND THAT?



open up a terminal

AND THIS???

and type "locale", $LANG and $LC_CTYPE are the most influencial, only LC_CTYPE should be set to ja_JP, others should be en_US (or watever). I think YaST2 sets this automatically depending on what you chose but you can override it using the ~/.profile file, basically export LC_CTYPE to ja_JP and the rest to en_US or watever you prefer. As far as I know most applications looks at the $LANG variable to determine their output.
For email kmail is pretty simple to use IMO, try Gaim for IM.


THANKS


Something in Gnome says it cannot log onto the Internet with some settings refelcting my fiber optic provider......yet it does actually connect.

Wierd. I think I had better reasd the manual and contact Suse....

But anyway, I definitely installed Cana and most things Japanese....


Thanks,

paul




__________________
"If something can go wrong, it will"
 
Old 12-18-2003, 06:12 PM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
With the pop3 account as long as you dont get authentication errors then it should be working..
Quote:
Then add these lines in your ~/.profile]

WHERE DO I DO THIS???

exec /usr/X11R6/bin/kinput2 -canna &
export LC_CTYPE=ja_JP
export XMODIFIERS="@im=kinput2"
There's a file called ".profile" in your home folder (its hidden by default) which you have to edit.
Try to work in a terminal(or a terminal emulator to be exact), by default you should see an icon that looks like a computer monitor somewhere on the bottom panel(for gnome its called gnome terminal, for kde its konsole).
For a console based text editor I recommend pico, which should come with Suse. So basically you fire up the terminal and type "pico ~/.profile" the tilde indicates your home directory so its equivalent to /home/username.
Quote:
WELL--> I tried in an editor but CONTROL O brings up a menu......
Yes I know some applications overrides the ctrl+o shortcut. from memory I think abiword or gedit does this, I suppose you can get around it by disabling the shortcut for that particular application or change the kinput2 shortcut, can't remember on top of my head on how to do it but read the man page. Test kinput2 in a terminal, if ctrl+o does nothing then you haven't set it up properly.
Quote:
Something in Gnome says it cannot log onto the Internet with some settings refelcting my fiber optic provider......yet it does actually connect
What's the exact error message?
 
Old 12-19-2003, 04:33 PM   #7
tokyoprogressiv
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Original Poster
Rep: Reputation: 0
thanks.......

Hi

very helpful, thanks.

Email is working fine now, though in kde when I try to add another account, it only sees the first one....well, I can figure that ouit later.

same for all the things you suggested.....I will be in Boston for the next 3 weeks, so will check this out when i come back...and i can now send email with ((prewritten) japanese text, so I know that is working. Once I get the ime input all will be fine.

Thanks again and will be in touch when I get back. Have to get to the airport now.

Best regards,

paul
 
Old 12-20-2003, 06:42 PM   #8
Jiawen
Member
 
Registered: Aug 2003
Location: Twin Cities, MN, US
Distribution: Mandriva -> Ubuntu
Posts: 106

Rep: Reputation: 15
I've had similar problems with Chinese input in Mandrake 9.1, so maybe my experience might help...

I've heard several people say that the only way to have both English and Japanese on your system is to create two user profiles for yourself -- one with Japanese locale settings and one with English. At least for Chinese, there doesn't seem to be a way to get Chinese input from within an English locale setting. Linux seems to store language settings on a per-user basis.

You may find that you don't need the English as much as you think, though. I use Mandrake in Traditional Chinese, and have had almost no problems with it. Error messages are occasionally confusing, but for the most part, they're just as confusing as they were in English. Plus, many applications (Firebird, some parts of Quanta, many games, etc.) are in English anyway.

Finally, it sounded like you were possibly not familiar with what a terminal is. Terminals are where you do commandline actions, kind of like using the old C:/ prompt in DOS. Depending on what distribution you're using, these could be in many different places. In Mandrake, for example, you just go into the main menu (with a Gnome footprint or KDE gear-thingy) and there should be a section labeled "Terminals". I assume that SuSE should have a somewhat similar setup. I have nine different ones on my system -- for Japanese, Korean, Chinese and a few varieties of vanilla English-only ones. Until you actually get Japanese set up on your system, though, you could just use whichever one you want. They all work pretty much the same.

If that sounded patronizing, please don't take it that way. When I first started, I had no idea what a terminal was, so it seems plausible that other people might not know, either.
 
Old 12-23-2003, 12:19 PM   #9
Jiawen
Member
 
Registered: Aug 2003
Location: Twin Cities, MN, US
Distribution: Mandriva -> Ubuntu
Posts: 106

Rep: Reputation: 15
An update: I've since found a very interesting page that describes how to do Chinese input without a Chinese-locale user; it's worth a try with Japanese.
 
Old 03-13-2004, 06:22 PM   #10
sylvain_gnu
Member
 
Registered: Mar 2004
Posts: 91

Rep: Reputation: Disabled
Question How's it going for you with Japanese and GNU/Linux?

Hello Tokyoprogressiv,

I hope you finally found a good solution for using Japanese with GNU/Linux.

My wife speaks Japanese, so last year, I installed Emacs with Japanese support (using the emacs Mule package) for her and she could enter Japanese in Romaji and then by pressing backspace she could select kanjis and kanas).

I suppose the support for Japanese is easier now, so I'd like to know what you found out before trying again...

Can you give us some news?
For instance:
- Which software are you using finally? KMail? Something else?
- Which desktop? KDE? (last time I tried with KDE3 I was disappointed, maybe it's better now) Gnome? How did you configure it?

Thanks in advance,
Sylvain.
 
Old 03-14-2004, 10:07 AM   #11
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
This is kind of a lame hack but you could make aliases for all of your commands that are something like this:

alias command='LANG=en_US command'

put them in your .bashrc file in your home directory. In this way the menus will be in English BUT you will still be able to use the kinput and canna servers.

You might want to read this:

http://lfs.oregonstate.edu/hints/dow...iles/jlenv.txt

Just read about setting stuff up. You dont need to compile I would imagine
 
Old 03-15-2004, 02:17 PM   #12
sylvain_gnu
Member
 
Registered: Mar 2004
Posts: 91

Rep: Reputation: Disabled
Smile Interesting, thanks

Arigato gozaimas, Kroenecker-san! for this good doc.

I'll begin trying it a soon as I have 1 or 2 hours.
Hope you're having good time in Japan.

Cheers,
Sylvain.
 
Old 03-17-2004, 02:23 PM   #13
tokyoprogressiv
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Re: How's it going for you with Japanese and GNU/Linux?

Sorry...am travelling now and did not see before. I will be back in about 3 weeks.....

But the answer was i visisted a Tokyo users group...they were helpful, but they don't really like newbies.....so they expected me to somehow learn Linux beyond what I wanted to do...but anyway, that is not a problem. I eventually found that other users had probelms...one guy coulod do Japanese if he installed japanese system, but couldnot add japanese to an ewnglish system. i still do not know why there is a difference between users......but anyway, Dr. Fabian of Suse updated some canna files...i do not have the list right now...it is in my old email files... I found these advertosed on another list, instaleld them, and now Kanji works in applications...haven't checked which ones yet...but Kmail is ok.


Hope this helps. I can let you know more later/


paul


Quote:
Originally posted by sylvain_gnu
Hello Tokyoprogressiv,

I hope you finally found a good solution for using Japanese with GNU/Linux.

My wife speaks Japanese, so last year, I installed Emacs with Japanese support (using the emacs Mule package) for her and she could enter Japanese in Romaji and then by pressing backspace she could select kanjis and kanas).

I suppose the support for Japanese is easier now, so I'd like to know what you found out before trying again...

Can you give us some news?
For instance:
- Which software are you using finally? KMail? Something else?
- Which desktop? KDE? (last time I tried with KDE3 I was disappointed, maybe it's better now) Gnome? How did you configure it?

Thanks in advance,
Sylvain.
 
Old 03-20-2004, 02:27 PM   #14
sylvain_gnu
Member
 
Registered: Mar 2004
Posts: 91

Rep: Reputation: Disabled
Thanks for now, Paul.
Have a good time!
Cheers,
Sylvain.
 
Old 04-20-2004, 01:33 PM   #15
sylvain_gnu
Member
 
Registered: Mar 2004
Posts: 91

Rep: Reputation: Disabled
Lightbulb Some news

Some news.
During this week-end I configured my Debian GNU/Linux system to support japanese for my girlfriend. She uses mozilla-thunderbird as e-mail client and OpenOffice.org for documents. She's very enthusiastic about it. It's great.

We had to install some ' kinput2 ' packages to do that.
We're using 2 aliases to switch from fr_FR environment to ja_JP... environment. These aliases are set in the ' .rc ' files of the shell we are using (zsh but no matter).
The alisases are available below.

% alias
fr='LANG=fr_FR && export LC_MESSAGES=fr_FR && export LC_CTYPE=fr_FR '
jp='LANG=ja_JP.eucJP && export LC_MESSAGES=ja_JP.eucJP && export LC_CTYPE=ja_JP.eucJP && export XMODIFIERS=@im=kinput2 && kinput2 -xim -kinput -canna &'

So, from a console:
% jp
to swith to the japanese env.
% fr
to go back to the french env.

Cheers,
Sylvain.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Way to use a good free English to English Dictionary linbose Linux - Software 6 06-03-2009 10:25 PM
Japanese & Chinese input methods on English Gnome / Fedora Core 2 + Gimlet shortcuts sunwukong Linux - General 0 09-02-2004 04:55 AM
Java Virtual Machine Language: Japanese Issues kzarog Linux - Software 0 05-17-2004 03:26 PM
Can I input in Japanese, but keep English menus? whplanet Linux - Newbie 3 05-06-2004 03:32 AM
Can I have english menu with chinese/english/spanish input? codec Linux - General 9 10-04-2003 07:18 PM


All times are GMT -5. The time now is 12:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration