LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2004, 07:38 AM   #16
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52

I thought your problem may be just alsa volumes, but obviously not.
Sorry then, I really don't know what is going on with your hardware detection... anyone else have any ideas?
 
Old 06-30-2004, 03:58 AM   #17
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
Guys - I think we're nearly there!

With alsamixer set I do get sound without having first to run the soudcard detection utility or another sound app.

Thanks!

The problem is however that the stored settings of alsamixer are not loaded at boot-up.
"aslactl store" (or in my case "/usr/bin/alsactl store") seems to work but when I reboot and run alsamixer again everything is back to zero...
Running "/usr/bin/alsactl restore" does bring back the saved settings.

How do I make sure that the mixer settings are loaded at boot-up?

It seems that essentially I have the same problem - in order to get sound I have first to run either the soundcard detection utility or the alsamixer.

It's not exactly mission critical but it would be nice to have it fixed.... Any ideas?

Thanks for all your help so far...

Mark
 
Old 06-30-2004, 04:25 AM   #18
NonSumPisces
Member
 
Registered: May 2004
Location: Västerås, Sweden
Distribution: Slackware Current
Posts: 228

Rep: Reputation: 30
You'll have to add a script that runs alsactl restore on boot or when you log in, but that's not really my area.
This is probably not the smothest way, but you could PROBABLY do it something like this:

1. Create a file in /etc named .alsareload

2. Add the following in it:

Code:
#!/bin/bash
function alsarestore {
echo "Restoring ALSA-settings"
alsactl restore
echo "ALSA-settings restored, hopefully :)"
}

3: Then add the following line in your ~/.bash_profile

Code:
if [ -f /etc/.alsareload ]; then
   . /etc/.alsareload
fi
Done. Reboot. This should run alsactl restore every time you log on as the user who has the .bash_profile. Just copy it to other users homedirs if you need too. There are other ways of doing it, but as I said, it's not what I'm good at
If the alsarestore file won't do the trick, replace "the alsactl restore"-line with something like:

Code:
. /usr/bin/alsactl restore
Good luck.

/Marcus

Last edited by NonSumPisces; 06-30-2004 at 04:31 AM.
 
Old 06-30-2004, 06:09 AM   #19
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
We've done it!!!!

Thank you so much guys... Sound now works straight from boot-up!

I really appreciate all your help.
I know it was only a trivial matter but it is so much better to have it working...

Thanks again

Mark

p.s.
I'm no bash script programmer, but when I found that Marcus' script wasn't working I tired a number of (dumb) things before I guessed that what the script was doing was creating a function called "alsarestore" but nowhere was that function called. I added the line "alsarestore" on the bottom of the script and it worked. I presume I did the right thing?

Last edited by ArthurDent; 06-30-2004 at 06:33 AM.
 
Old 06-30-2004, 06:29 AM   #20
NonSumPisces
Member
 
Registered: May 2004
Location: Västerås, Sweden
Distribution: Slackware Current
Posts: 228

Rep: Reputation: 30
Good work

You've solved it brilliantly If it works, you probably did it right
That's the beauty of Linux: Do something right, or even remotly right, and it works. Do something right in w1nblow$ and it _might_ work, if it wants too

Cheers

/Marcus

Last edited by NonSumPisces; 06-30-2004 at 06:39 AM.
 
Old 06-30-2004, 09:39 PM   #21
penguin4
Senior Member
 
Registered: May 2004
Location: california
Distribution: mdklinux8.1
Posts: 1,209

Rep: Reputation: 45
nonsumpisces; amen to that, linux hands down , thumbs down on W.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
irritating automount issue czarherr Linux - Software 0 10-03-2005 01:31 PM
Irritating Mouse Feature Wildhog Linux - Newbie 7 08-31-2005 03:00 PM
Irritating problem with suse 2k. Linux - Distributions 2 09-21-2003 02:55 PM
yahoo messenger irritating !! zaman Linux - Hardware 5 07-07-2003 01:13 AM
irritating, repetitive HD sound (only in Linux) aethereal Linux - General 5 11-20-2001 05:34 AM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration