LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2004, 12:57 PM   #1
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Rep: Reputation: 30
Irritating Sound Problem


Hello All

This is more of an irritation than a real problem - the sound for my system does actually work...

The problem is that before any sound application will work I need to run the "soundcard detection" utility. If I try to run - for example - the CD Player application it will identify the CD in the drive and start playing it as normal - just no sound - no errors.

If, on the other hand I first run the "Soundcard Detection" utility the utility gives me the message:

The following audio device was detected.
Vendor: Intel Corp
Model: 82801AA AC'97 Audio
Module: snd-intel8x0

(Yes I know - It's not exactly at state of the art system...)

But the thing is - from then on sound will work.

I don't know if it's relevant, but I have the following entry in my /var/log/messages log for every boot-up:

Jun 26 15:27:41 localhost modprobe: FATAL: Error running install command for sound_slot_0
Jun 26 15:27:41 localhost modprobe: FATAL: Error running install command for sound_slot_0
Jun 26 15:27:41 localhost modprobe: FATAL: Error running install command for sound_slot_1

I know it's only a trivial problem but I do find it irritating. Can anyone help me to get it working from the start?

Many thanks

Mark
 
Old 06-26-2004, 02:52 PM   #2
NonSumPisces
Member
 
Registered: May 2004
Location: Västerås, Sweden
Distribution: Slackware Current
Posts: 228

Rep: Reputation: 30
Have you tried using the latest alsapackage to install the sound devices in /dev?
Might not be relevant, but give it a try, ight solve it.

http://www.alsa-project.org/
 
Old 06-26-2004, 05:01 PM   #3
penguin4
Senior Member
 
Registered: May 2004
Location: california
Distribution: mdklinux8.1
Posts: 1,209

Rep: Reputation: 45
A.D; if nonsumpisces,s advice doesn,t do it try http://tldp.org/HOWTO/HOWTO-INDEX/howtos.html page 45 of 56,Sound-
HOWTO and Sound-playing-HOWTO
 
Old 06-26-2004, 05:46 PM   #4
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
Thanks chaps...

NonSumPisces, I installed the ASLA driver and followed exactly the instructions on this page - the compile and install seemed to work OK and I modified the /etc/modules.conf file as per the instuctions (and also the /etc/modprobe.conf file because it seemed from the modules.conf file that it was necessary).

I rebooted - but still the same problem. In fact things have got a bit weirder... Playing an audio CD using CD Player - once I had activated the sound using the soundcard detection utility - was working fine but then... the CD kept playing even when I closed the the CD Player application!

I now get these lines in my /var/log/messages file:

Jun 26 22:13:47 localhost modprobe: FATAL: Error running install command for sound_slot_1
Jun 26 22:14:20 localhost system-config-soundcard(pam_unix)[2788]: authentication failure; logname= uid=500 euid=0 tty= ruser=mark rhost= user=root
Jun 26 22:14:33 localhost userhelper[2791]: running '/usr/share/system-config-soundcard/system-config-soundcard' with root privileges on behalf of 'mark'

As a complete newbie I have no idea what it means (if anything).

The point about all this is this: - I am able to play sound quite well - OGGs, MP3s, MIDIs, WAVs - you name it I can play it ... just not without going through a little keyboard dancing first.

I would just like to be able to reliably play sounds without first having to check whether or not the soundcard is active.

All the best

Mark
 
Old 06-26-2004, 06:22 PM   #5
NonSumPisces
Member
 
Registered: May 2004
Location: Västerås, Sweden
Distribution: Slackware Current
Posts: 228

Rep: Reputation: 30
try generating a new modprobe.conf

Code:
/sbin/generate-modprobe.conf /etc/modprobe.conf
Might work. Do any changes to it alsa said.
 
Old 06-27-2004, 06:58 AM   #6
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
When I run /sbin/generate-modprobe.conf /etc/modprobe.conf it simply generates a modprobe.conf file with the single line:
"Cannot find old version of modprobe. Giving up."

If it helps you, this is what my modprobe.conf file looks like. Note: I had already added the lines proposed from the ALSA website...

<MODPROBE.CONF>
# Note: for use under 2.4, changes must also be made to modules.conf!
alias snd-card-0 snd-intel8x0
alias usb-controller uhci-hcd
install sound-slot-0 /sbin/modprobe --first-time --ignore-install sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-0

# ALSA portion

alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# end of ALSA portion
</MODPROBE.CONF>

I'm not sure why the generate-modprobe.conf fails.

What should I do now?
 
Old 06-27-2004, 01:23 PM   #7
NonSumPisces
Member
 
Registered: May 2004
Location: Västerås, Sweden
Distribution: Slackware Current
Posts: 228

Rep: Reputation: 30
modprobe is part of a package called module-init-tools, and it's difficult to get an install of it right.
Try to download a new copy of it and try installing it.

http://wuarchive.wustl.edu/mirrors/k...le-init-tools/

When you install it, you need to do make moveold if my memory isn't failing me. Read the manual on how to do it, you might need to install into both sbin and usr/sbin.
When it's properly installed and you've gotten no errors, generate a new modprobe.conf and make the needed changes to it. I don't know if this will help you anything but it fixed my soundproblems.

Last edited by NonSumPisces; 06-27-2004 at 01:24 PM.
 
Old 06-27-2004, 02:04 PM   #8
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
Well this is starting to get a bit scary...

I have downloaded the tarball for module-init-tools-3.0.tar.bz2 from http://www.kernel.org/pub/linux/util...le-init-tools/ but I am loathe to risk totally messing up my system. If someone is prepared to hold my hand I might give it go...

Incidentally I also looked for an RPM and found modutils-2.4.26-16_1.rhfc.at.i386.rpm from rpm.pbone.net but when I checked with rpm -qa | grep modutils I found that I already had modutils-2.4.26-16 installed.

I had a peek inside the module-init-tools-3.0. tarball and I found a file called FAQ. Inside that I found this snippet:
"Q) Sound doesn't load automatically.
A) You need to set up an alias (or install command) for "sound-slot-0" in
/etc/modprobe.conf: the ALSA sound system seems to want this."

Before I start a whole install can we just explore this a little bit further...
What does it mean "You need to set up an alias..."?
My whole modprobe.conf file is posted above - does it have such an alias? If not can I just amend the file with some appropriate line(s)?

Thanks for your help so far...

Best Regards

Mark
 
Old 06-27-2004, 02:18 PM   #9
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Q. do you also have a /etc/modules.conf? if so, try transfering:

# ALSA portion

alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# end of ALSA portion

into it.
 
Old 06-27-2004, 02:36 PM   #10
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
Hi Tuttle,

Thanks for your reply - I do indeed have a /etc/modules.conf file and I did copy that text into that too (I did it at the same time as I put the text into /etc/modrpobe.conf).

Should the text be in both - or just one of the two .conf files?

Mark
 
Old 06-27-2004, 04:20 PM   #11
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Probably both. On my system, modprobe.conf only contains info for my nvidia card whereas modules.conf contains all of it, including my video card, alsa stuff (same info as in your modprobe.conf - except "snd-intel8x0" is "snd-ens1371" (soundblaster)) and phillips webcam.
I'm sure it won't hurt, although I can't claim to be an expert on the subject.
 
Old 06-27-2004, 05:13 PM   #12
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
Well it is in both modprobe.conf and modules.conf and still my sound doesn't come up without a struggle...

What are my otions now? Do you think I should go for the install of module-init-tools-3.0? (gulp!)
 
Old 06-27-2004, 05:27 PM   #13
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Sorry, didn't notice your earlier post involving modules.conf!

Have you tried "alsamixer" - then do:

Code:
user@box:~$ su
[password]
root@box:~# alsactl store
"alsactl restore" will restore your volumes at boot.
 
Old 06-28-2004, 03:27 AM   #14
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 179

Original Poster
Rep: Reputation: 30
Thanks Tuttle,

I ran alsamixer - I'm not entirely sure what the correct settings should be so I just set everything to the limit before the line went red.

I saved it using alsactl store (which had to be /usr/bin/alsactl store on my system). This, of itself, made no difference to my problem - still no sound until I have run the soundcard detection utility - so I tried rebooting.

On reboot the alsamixer levels are all back to zero (except the first column - Master). Running /usr/bin/alsactl restore brought back the saved settings but again - still no sound until I run the detection utility.

I'm not sure I understand what's going on here. Do I need to have a "/usr/bin/alsactl restore" command run somewhere during the boot process? If so where do I put it? Is it likely that that will cure my problem?

Sorry to be so lame...

Thanks again

Mark

Last edited by ArthurDent; 06-28-2004 at 03:29 AM.
 
Old 06-28-2004, 01:52 PM   #15
NonSumPisces
Member
 
Registered: May 2004
Location: Västerås, Sweden
Distribution: Slackware Current
Posts: 228

Rep: Reputation: 30
When you run alsamixer, you can probably see that most of the options are turned off. You activate them by pressing . (dot) att every bar and then you raise their volumes. Raise all the fields you can. The you press esc to exit alsamixer and then you do "alsactl store". That will save your settings and automagically restore them when you boot Neat, huh? Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
irritating automount issue czarherr Linux - Software 0 10-03-2005 01:31 PM
Irritating Mouse Feature Wildhog Linux - Newbie 7 08-31-2005 03:00 PM
Irritating problem with suse 2k. Linux - Distributions 2 09-21-2003 02:55 PM
yahoo messenger irritating !! zaman Linux - Hardware 5 07-07-2003 01:13 AM
irritating, repetitive HD sound (only in Linux) aethereal Linux - General 5 11-20-2001 05:34 AM


All times are GMT -5. The time now is 08:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration