LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-09-2006, 05:18 PM   #1
tstuart
LQ Newbie
 
Registered: Sep 2006
Posts: 16

Rep: Reputation: 0
IPSEC starting automatically...


IPSEC is starting automatically when I boot. I need to stop it from loading because when it does it makes my internet connection work only intermittently. If I run /etc/init.d/ipsec --stop then my internet connection starts working fine.
I'm running kubuntu and in System settings I have made sure the IPSEC option in system services is set not to load. Also in the ipsec.conf I have auto=start...

Any help you can give me is greatly appreciated. I need to know how to either stop ipsec from loading at startup, or fix it so having ipsec loaded does not interfer with my internet connection.

During bootup I see something that says loading /etc/init.d/ipsec-tools.conf.
Any way to stop this from loading?

Regards,

Trevor

Last edited by tstuart; 09-10-2006 at 03:19 PM.
 
Old 09-12-2006, 06:51 AM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Assuming you are in runlevel 5 (graphical interface), what is the output of
ls /etc/rc5.d ?
 
Old 09-12-2006, 07:25 AM   #3
tstuart
LQ Newbie
 
Registered: Sep 2006
Posts: 16

Original Poster
Rep: Reputation: 0
Here is the output you requested:
$ ls /etc/rc5.d
K08vmware S18hplip S20laptop-mode S20rsync S90vmware
S05vbesave S19cupsys S20makedev S25bluez-utils S98usplash
S10acpid S20apmd S20nvidia-kernel S25mdadm S99acpi-support
S10sysklogd S20dbus S20postfix S89anacron S99kdm
S11klogd S20dictd S20powernowd S89atd S99rc.local
S14ppp S20hotkey-setup S20racoon S89cron S99rmnologin

I see Racoon still loading, but I don't know how to stop it... I appreciate any help you can provide!
 
Old 09-12-2006, 11:21 PM   #4
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by tstuart
I see Racoon still loading, but I don't know how to stop it
There is almost certainly a way to do this with a GUI tool, but even if I knew the distro/desktop you are using I wouldn't know how. From the command line, you can stop racoon from starting in runlevel 5 by (as root):

Code:
cd /etc/rc5.d
mv S20racoon K80racoon
This will only affect runlevel 5, but if you want to keep things clean, you can do something similar for all the other runlevel directories that start up racoon. Note that this will not affect anything until a runlevel change or until the next boot. You appear to already know how to stop services in the moment.

Brief explanation: All of the entries in these directories are (should be) symlinks to scripts, most of which are in /etc/init.d. All the symlinks that start with "K" get "killed" when that runlevel start up, and all of the symlinks that start with "S" get started. Within each group, the order is determined by the 2 digit number following the initial letter. I.e. S34service1 will get started before S35service2.
 
Old 09-15-2006, 12:16 PM   #5
bostondriver
LQ Newbie
 
Registered: Jul 2006
Location: Boston
Posts: 10

Rep: Reputation: 0
Quote:
Originally Posted by tstuart
IPSEC is starting automatically when I boot. I need to stop it from loading because when it does it makes my internet connection work only intermittently. If I run /etc/init.d/ipsec --stop then my internet connection starts working fine.
What do you mean by "work only intermittenly"?

Your IPsec/IKE policies may not be setup correctly. Did you configured IPsec or IKE or just enable IPsec with no configuration? For IPsec to work, you also need to configure the other endpoint.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mozilla now starting automatically zadox Linux - Newbie 4 09-04-2006 11:18 PM
not starting automatically ??? JNaas Linux - Networking 0 09-30-2004 08:25 PM
Starting KDE automatically Sinope Linux - Newbie 2 08-13-2004 10:56 AM
[freeswan] no traffic to internet after starting ipsec service tyl Linux - Networking 3 08-03-2003 02:05 PM
Starting X Automatically shari Linux - Software 2 08-08-2001 02:11 AM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration