LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-09-2006, 11:23 PM   #1
zadox
LQ Newbie
 
Registered: Jan 2004
Location: Templeton, CA
Distribution: RH8 FC3, DSL
Posts: 24

Rep: Reputation: 15
Mozilla now starting automatically


Hi and thanks for your help. I'm running an older P3 with RH 8.0. Its been very stable for years but has recently developed an odd behavior on start-up. The Mozilla browser is now automatically starting each time I log in and start my session- This doesn't cause any major problems but it is unusual behavior for Mozilla. I figure I can edit a file either in Mozilla or in the X11R6 folder for my user profile to fix the problem. Any suggestions?
Thanks again,
zadox
 
Old 05-09-2006, 11:35 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
hmm, my guess would be to check these files (whatever ones exist): ~/.bashrc, ~/.bash_profile, ~/.profile, and /etc/profile
 
Old 09-03-2006, 12:07 PM   #3
zadox
LQ Newbie
 
Registered: Jan 2004
Location: Templeton, CA
Distribution: RH8 FC3, DSL
Posts: 24

Original Poster
Rep: Reputation: 15
stopping Mozilla autostart

Mozilla is closed when I log out- have even checked it with "ps ax", Below is the content of the .xinitrc file: I don't see any reference to mozilla but maybe its picking up the netscape... should I edit there and if so how?

##################################################################################

#!/bin/sh
# (c) 1999-2002 Red Hat, Inc.

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
userxkbmap=$HOME/.Xkbmap

sysresources=/etc/X11/Xresources
sysmodmap=/etc/X11/Xmodmap
sysxkbmap=/etc/X11/Xkbmap

# merge in defaults
if [ -f "$sysresources" ]; then
xrdb -merge "$sysresources"
fi

if [ -f "$userresources" ]; then
xrdb -merge "$userresources"
fi

# merge in keymaps
if [ -f "$sysxkbmap" ]; then
setxkbmap `cat "$sysxkbmap"`
XKB_IN_USE=yes
fi

if [ -f "$userxkbmap" ]; then
setxkbmap `cat "$userxkbmap"`
XKB_IN_USE=yes
fi

if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config`
if [ -n "$xkbsymbols" ]; then
setxkbmap -symbols "$xkbsymbols"
XKB_IN_USE=yes
fi
fi
fi

# xkb and xmodmap don't play nice together
if [ -z "$XKB_IN_USE" ]; then
if [ -f "$sysmodmap" ]; then
xmodmap "$sysmodmap"
fi

if [ -f "$usermodmap" ]; then
xmodmap "$usermodmap"
fi
fi

unset XKB_IN_USE

# run all system xinitrc shell scripts.
for i in /etc/X11/xinit/xinitrc.d/* ; do
if [ -x "$i" ]; then
. "$i"
fi
done

# The user may have their own clients they want to run. If they don't,
# fall back to system defaults.
# set up ssh agent environment if available.

if [ -f $HOME/.Xclients ]; then
[ -x /usr/bin/ssh-agent -a -z "$SSH_AGENT_PID" ] && \
exec ssh-agent $HOME/.Xclients || \
exec $HOME/.Xclients
elif [ -f /etc/X11/xinit/Xclients ]; then
[ -x /usr/bin/ssh-agent -a -z "$SSH_AGENT_PID" ] && \
exec ssh-agent /etc/X11/xinit/Xclients || \
exec /etc/X11/xinit/Xclients
else
# failsafe settings. Although we should never get here
# (we provide fallbacks in Xclients as well) it can't hurt.
xclock -geometry 100x100-5+5 &
xterm -geometry 80x50-50+150 &
if [ -x /usr/bin/netscape -a -f /usr/share/doc/HTML/index.html ]; then
netscape /usr/share/doc/HTML/index.html &
fi
if [ -x /usr/X11R6/bin/fvwm2 ]; then
exec fvwm2
else
exec twm
fi
fi
 
Old 09-04-2006, 08:50 AM   #4
shorun
Member
 
Registered: Mar 2006
Location: belguim
Distribution: fedora, mandriva, suse
Posts: 148

Rep: Reputation: 15
well. did it happen the first time?
KDE has an option to "remember" your using applications. if you log off, it willl remember what you are running. could verry well be one of this. you could check the file's above or try to just run x (close all unneeded apps) and then log off. log back on and see if there is any change.

but most likely it's written in one of the files above to start FF whenever X starts.
 
Old 09-04-2006, 10:18 PM   #5
nilleso
Member
 
Registered: Nov 2004
Location: ON, CANADA
Distribution: ubuntu, RHAS, and other unmentionables
Posts: 372

Rep: Reputation: 31
check your sessions/autostart in you wm (gnome or kde). You probably did a save session another time when you had moz open and haven't performed a 'save session' since

cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
not starting automatically ??? JNaas Linux - Networking 0 09-30-2004 07:25 PM
Starting KDE automatically Sinope Linux - Newbie 2 08-13-2004 09:56 AM
Automatically starting Kppp Gomi Linux - Newbie 1 05-18-2004 08:33 PM
Prevent X from starting automatically Yocal Linux - Newbie 6 08-27-2003 05:31 PM
Starting X Automatically shari Linux - Software 2 08-08-2001 01:11 AM


All times are GMT -5. The time now is 02:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration