LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2009, 01:43 PM   #1
deibertine
Member
 
Registered: Mar 2009
Posts: 222

Rep: Reputation: 30
Unhappy Installing Vmware Workstation in Fedora 11


Hi all,

I'm trying to install vmware workstation (VMware-Workstation-6.5.1-126130.i386.bundle) in my new Fedora 11:
Linux fedora11.devbox 2.6.29.4-167.fc11.i586 #1 SMP Wed May 27 17:14:37 EDT 2009 i686 i686 i386 GNU/Linux
Kernel 2.6.29.4-167.fc11.i586

I installed kernel-headers gcc gcc-c++ kernel-devel

Searching around the net, bring me to a conclusion that my kernel may not be the right one so need to update and apply a patch (any-any patch 113) in which also did.

However launching the bundle install after it finishes successfully then tried to launch the application from the gui, it gives me this error:

"Before you can run vmware workstation, several modules must be compiled and loaded into the running kernel..."
Cancel or Install?

When I click install, it gives me this error:
"Unable to build kernel module.See log file /tmp/vmware-root/setup-7243.log for details...."

Error Log:
Jun 16 22:26:29.790: app| Log for VMware Workstation pid=4767 version=6.5.1 build=build-126130 option=Release
Jun 16 22:26:29.790: app| Host codepage=UTF-8 encoding=UTF-8
Jun 16 22:26:29.790: app| Logging to /tmp/vmware-root/setup-4767.log
Jun 16 22:26:31.337: app| Extracting the sources of the vmmon module.
Jun 16 22:26:31.353: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.29.4-167.fc11.i586/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.0
Jun 16 22:26:41.585: app| Extracting the sources of the vmmon module.
Jun 16 22:26:41.622: app| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.29.4-167.fc11.i586/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.4.0

Anyone has seen this error?

Need advise please.

Thanks!
DB
 
Old 06-17-2009, 01:58 PM   #2
alinas
Member
 
Registered: Apr 2002
Location: UK, Sywell, EGBK
Distribution: RHEL, SuSE, CentOS, Debian, Ubuntu
Posts: 60

Rep: Reputation: 20
Hi,
No, I'm not familiar with this problem, however, just wanted to turn your attention to the fact that what you quoted is not strictly speaking an error log, just *a* log file entry. The lines with "IS_GCC_3=no" might indicate where the problem is (the application may be looking for the gcc version 3), but I can't find in the message anything that would confirm this as your definite error...
 
Old 06-17-2009, 02:27 PM   #3
deibertine
Member
 
Registered: Mar 2009
Posts: 222

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by alinas View Post
Hi,
No, I'm not familiar with this problem, however, just wanted to turn your attention to the fact that what you quoted is not strictly speaking an error log, just *a* log file entry. The lines with "IS_GCC_3=no" might indicate where the problem is (the application may be looking for the gcc version 3), but I can't find in the message anything that would confirm this as your definite error...
Thanks for the response.
Ok, saw that line.

Im not sure which gcc to install now.

I guess I can try this:
ftp://mirrors.laffeycomputer.com/pub...-3.4.2.tar.bz2

So I did install the above gcc version but getting this error:
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
make: *** [configure-gcc] Error 1

This is after I did a ./configure

Any idea?
 
Old 06-18-2009, 12:34 AM   #4
deibertine
Member
 
Registered: Mar 2009
Posts: 222

Original Poster
Rep: Reputation: 30
It turned out that VMware WS is not fully supported yet under the new release of Fedora 11.

I ended up downgrading to Fedora 10 and this worked just fine!

Thanks.
 
Old 06-18-2009, 02:59 AM   #5
alinas
Member
 
Registered: Apr 2002
Location: UK, Sywell, EGBK
Distribution: RHEL, SuSE, CentOS, Debian, Ubuntu
Posts: 60

Rep: Reputation: 20
Interesting - I was going to suggest a swap to Ubuntu 9.04, where I am using WS 6.5 - it installed without a problem...
 
Old 09-04-2009, 02:06 PM   #6
Bladez711
LQ Newbie
 
Registered: Sep 2009
Posts: 13

Rep: Reputation: 0
similar problem

i install vmware server 1.09 with package installer, but now i cant find how to launch it, can someone direct me please?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VMware Workstation 6.02 with Fedora 8 Dummy-in-Linux Fedora 4 12-11-2007 05:54 PM
Errors while installing VMWare workstation bigjig SUSE / openSUSE 5 11-17-2007 09:16 AM
Fedora 7 and Vmware Workstation Dummy-in-Linux Fedora 4 07-25-2007 06:16 AM
VMware workstation on fedora 5: not working! 144419855310001 Fedora 8 04-28-2006 07:50 AM
Vmware workstation 4+0 + Fedora and Win2K MongeK Linux - Software 5 02-15-2004 04:52 PM


All times are GMT -5. The time now is 10:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration