LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2004, 09:42 PM   #1
scc28y
LQ Newbie
 
Registered: Feb 2004
Posts: 13

Rep: Reputation: 0
Angry installing ethernet card problem


Hi, I am one of those unfortunate souls with an ISA ethernet card.

My card uses AMD PCnet-ISA 79c960 chip. It is supposed to use the lance.o driver.

I modified my /etc/modules.conf and added the following lines:

alias eth0 lance
options lance io=0x340

Then, I saved the new modules.conf and did a modprobe eth0

The error message tells me that insmod /lib/modules/2.2.16/net/lance.o failed

I also tried io=0x320, io=0x300, and io=0x360


None worked.

Could someone please be kind enough to help me!

Stanley
 
Old 02-09-2004, 09:51 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
looking around i am noticing the ne2100 working more so than lance ...
so, try the ne2100.o module rather than lance.o one ....
and see if you have any sucess ...
i am not sure if you have it or not, so you may have to recompile your kernel and add support for it...
 
Old 02-09-2004, 10:17 PM   #3
scc28y
LQ Newbie
 
Registered: Feb 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Hi, does anyone have the ne2100.o module? Could you please tell me where I can get it? I only have the slackware distribution which only has the lance.o module

thx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing an ethernet card w/o rebooting? devfreak Linux - Hardware 3 08-10-2005 12:47 PM
Boot problem: "GRUB Loading stage2read Error" after installing PCI Ethernet card nsyng Fedora - Installation 1 06-06-2005 06:53 AM
problem installing 2nd ethernet card on nforce board mjrpes Linux - Hardware 3 11-09-2003 07:33 PM
installing an ethernet card driver cmack Slackware 1 08-24-2003 06:09 PM
installing lan card(ethernet) uninterrupted Linux - Networking 3 07-01-2003 01:54 PM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration