LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2004, 12:27 PM   #1
chipix
LQ Newbie
 
Registered: Dec 2002
Location: Athens, HELLAS
Distribution: Fedora Core 4
Posts: 22

Rep: Reputation: 15
Unhappy Installed Fedore core 2 T3 in a machine with RedHat 8 and Win 2000


Hi,

I wanted to install Fedore Core 2 T3 in a separate hard disk. My master HD contains a WIN 2000 installation (first partition) and a RedHat 8 installation (other partitions).

I installed Fedora at the second HDD and used the grub configuration suggested by the installer, thatis booting with 2 options: 1. Windows, 2. Fedora.

I continued with the installation and when i rebooted no GRUB menu was visible. There was only a blank screen with the word GRUB at the upper left part of the screen.


Have I done something wrong?

How can I go back to my previous grub configuration in order to boot to Win or to RedHat 8?

Thanks,
chipix
 
Old 05-13-2004, 02:04 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Nothing wrong, just owerwriten the grub stage 2 or MBR

Nothing to worry about.
Do the following(type this in line by line).

find /grub/grub.conf
or
find /boot/grub/grub.conf (whichever gets you results.)

You should get a result in form of "(hdx,x) where x is a number"

Next:

root (hdx,x)
(type in the correct x you got from find command)

cat /grub/grub.conf
or
cat /boot/grub/grub.conf
(again, whichever gets you some results)

(this should print the content of your grub.conf file)

You will see some lines

title=Win 2000
rootnoverify(hdx,x)
chainloader +1

title=Red hat 8
kernel bla bla bla
initrd bla bla bla

You have to type in the lines kernel and initrd under redhat 8
one by one
and after that type in

boot

That should get you into the Red Hat 8.

Once in there su to root and type in your root password. And finally run

/sbin/grub-install /dev/hdx (where x is the drive you have rh8 on)

reboot

Now you should see a grub menu

However (you should write commands into grub, to get you familiar with grub) you can just put in your Fedora CD 1 or Red hat 8 CD 1 and boot from that and only continue from su-ing and running /sbin/grub-install

Hope you get it right. And happy Linux use.

Peace!

Last edited by marghorp; 05-13-2004 at 02:57 PM.
 
Old 05-13-2004, 02:15 PM   #3
Grymme
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
How does your /boot/grub/menu.lst look like? (the one from the system you installed grub)

Getting that grub> thing when you boot isn't the worst thing actually.. it means your grub works somewhat but it lacks a menu (which is what the menu.lst is for).

To start windows from that prompt you can type:
Code:
rootnoverify    (hd0,0)
makeactive
chainloader = (hd0,0)+1
Do you know what your kernel is named?

then you could do something like for the redhat
Code:
root (hd0,1)
kernel  /boot/nameofyourkernel root=/dev/hda2 ro vga=791
And for your fedora on the second HD (first partition)
Code:
root (hd1,0)
kernel  /boot/nameofyourkernel root=/dev/hdb1 ro vga=791
if you don't want 1024x768 graphics then skip the vga thing

In your menu.lst these commands should go after a
Code:
title Whateveryouwant
For a 2.4 kernel the cdwriters might work bad if you don't emulate scsi. This is done by putting this in the kernel commandline (like after vga=791)
Code:
hdc=ide-scsi
Try to mess around but be sure NOT to do something like grub-install /dev/hda1 (or where your windows partition is) because that will kill your windows boot and you will have to work some to fix it.

edit: ** took me too much time to write so someone else made it before. Perhaps it can be usefull anyway **

Last edited by Grymme; 05-13-2004 at 02:17 PM.
 
Old 05-14-2004, 04:03 AM   #4
chipix
LQ Newbie
 
Registered: Dec 2002
Location: Athens, HELLAS
Distribution: Fedora Core 4
Posts: 22

Original Poster
Rep: Reputation: 15
Grymme,

The screen is not displaying "grub>" prompt but "GRUB " and I cannot write anything.

marghorp,

where to execute the find commands? I have used booted wth Linux rescue mode and I have mounted the fedora installation.

How should I continue? My grub.conf in the fedora core installation is the following:

timeout=20
splashimage=(hd1,0)/grub/splash.xpm.gz

title Fedora Core 2 T3 (2.6.5-1.327)
root (hd1,0)
kernel /vmlinuz-2.6.5-1.327 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.327.img

title Windows 2000
rootnoverify (hd0,0)
chainloader +1

Thanks
 
Old 05-14-2004, 05:18 AM   #5
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
How do you know what your grub.conf looks like if you cant write anything to GRUB? How did you get into Linux then?

If you're in there once, just do a

grub-install /dev/hda

as root of course
 
Old 05-14-2004, 05:22 AM   #6
chipix
LQ Newbie
 
Registered: Dec 2002
Location: Athens, HELLAS
Distribution: Fedora Core 4
Posts: 22

Original Poster
Rep: Reputation: 15
I updated the grub installation with the Red Hat 8 installation CD. Now I can boot to windows and Red Hat 8. Now my grub.conf is the following:

default 1
timeout 15
splashimage=(hd0,5)/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-14)
root (hd0,5)
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/
initrd /initrd-2.4.18-14.img
title Windows
rootnoverify (hd0,0)
chainloader +1
title Fedora Core 2 T3 (2.6.5-1.327)
root (hd1,0)
kernel /vmlinuz-2.6.5-1.327 ro root=/dev/hdb1=/1 rhgb quiet
initrd /initrd-2.6.5-1.327.img

When I select the Fedora option in grub boot menu it displays the following error:

root (hd1,0)

System error: Cannot find hard disk.

Any suggestions?
 
Old 05-14-2004, 05:29 AM   #7
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Check if it is connected correctly. There is some problem. MAybe it is hardware related.
 
Old 05-18-2004, 08:13 AM   #8
chipix
LQ Newbie
 
Registered: Dec 2002
Location: Athens, HELLAS
Distribution: Fedora Core 4
Posts: 22

Original Poster
Rep: Reputation: 15
Yes, it ws h/w related. In BIOS the second disk was not properly declared. Due to the fact that GRUB uses bios information to read the disk configuration, the problem was solved
 
Old 05-18-2004, 12:25 PM   #9
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Nice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Fedora Core 3, Samba, gnome & win 2000/XP edesmarais Linux - Networking 21 12-15-2005 02:36 PM
Fedora Core 4 in Win 2000/03 Domain vrooom305 Fedora 3 08-18-2005 04:54 PM
Win XP + Win 2000 + Fedora Core 2 koyi Linux - Newbie 6 09-30-2004 05:09 AM
Share Redhat 9 Printer with Win 2000 Machine Paul Mon Linux - Hardware 2 10-31-2003 12:31 PM
Dual Boot Win 2000 and RedHat 9... beanlover Linux - Newbie 13 09-30-2003 11:36 AM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration