LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-28-2003, 09:10 AM   #1
beanlover
LQ Newbie
 
Registered: Sep 2003
Posts: 6

Rep: Reputation: 0
Dual Boot Win 2000 and RedHat 9...


Ok...I am a professed n00b when it comes to Linux. Wanted to give it a try.

Went out and got the latest redhat .iso files and made the cd's. The install went kinda bumpy but I was able to get through.

My setup is I have two harddrives. a DVD drive and a CD-RW drive. My "C:" drive is where Windows 2000 lives. my second hard drive is where I installed Redhat. I installed Grub as the boot loader and had it write to the first boot sector of /dev/hda2 (I think...it was the second drive). I manually made an entry for

So now when I boot Win2k comes up and I don't see anything for Redhat. Not too surprising really since I doubt the bios looks at the second hard drive for boot info and that is where I wrote the info. I was afraid I wouldn't be able to boot win2k if I wrote it to the first drive.

Anyway, I have seen several places where you can use ntldr to start Redhat but all solutions I have found involve using a floppy drive which I don't have. In addition to that all the solutions were for installations that were on the same hard drive.

Anyone know how I can set up win2k's bootloader to start Redhat in this scenario?

Any help would be appreciated.

Thanks,

B
 
Old 09-28-2003, 09:54 AM   #2
austindad
LQ Newbie
 
Registered: Sep 2003
Location: Austin, TX, USA
Distribution: Slackware, Knoppix, RH
Posts: 11

Rep: Reputation: 0
Hey, what do you know, a question I can answer.

You need to create 512k boot sector image of where your linux boot sector is. You do this using the linux 'dd' command. Assuming the linux boot sector is at /dev/hda2, the syntax is: 'dd if=/dev/hda2 of=bootsect.lnx bs=512 count=1'. You should now have a file called bootsect.lnx (which, if you're using Windows2000, needs to be in DOS 8.3 filename format)

The bootsect.lnx file is your linux boot sector. Put it in the root of your C: drive on the Win2000 partition. To add this to your NTLDR menu, you only need to edit the boot.ini file located in your Windows root directory (usually C:\.) Here's a sample boot.ini:

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000"

To add the bootsect.lnx file, simply add a line that looks like this:

C:\bootsect.lnx="Red Hat Linux 9"

Once you've edited the boot.ini and saved it, you should be good to go. When you reboot the machine, the NTLDR menu has a new option at the bottom, "Red Hat Linux 9", in this case. Select it, hit enter, and linux boots.

Good luck!
 
Old 09-28-2003, 01:09 PM   #3
beanlover
LQ Newbie
 
Registered: Sep 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I figured it wouldn't be too difficult.

Now for my next newb question...how do I boot to linux now? Can I just use the install cd to boot normally?

I will try to boot up but any answer will be appreciated.

Thanks,

B
 
Old 09-28-2003, 06:49 PM   #4
beanlover
LQ Newbie
 
Registered: Sep 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I can't get Redhat to boot effectively for me to do the instructions above. All I have that will boot it is the install cds. The only way I found to get to a command prompt is to go through rescue. I can't mount hda1 (windows hard drive) while in this mode for some reason (I am very inexperienced). I was able to make the file mentioned above but can't copy it.

Is there anywhere on the 'net I can get a boot image and burn it to a bootable cd so I can follow the instructions on this thread? I don't want to just go buy/borrow a floppy drive so I can do this...there has to be another way.

signed,

frustrated n00b
 
Old 09-29-2003, 11:28 AM   #5
beanlover
LQ Newbie
 
Registered: Sep 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Ok...I "discovered" that I could set which hard drive to boot first in BIOS. Never needed to change it before but it finally dawned on me that I could do it.

So I set it to boot from the second drive and it comes up and says "GRUB" and then nothing for a long time. I set my windows 2000 entry as the default boot target so my wife won't have to try to figure out what the heck this GNOME stuff is! :P I expected to see a menu with my os choices but it never showed one.

I reboot and decide to go through the entire install again. This time I set LILO as my boot manager. I added Windows_2000 entry and pointed it to HDA1 during install. (Installed in boot sector of HDB1 and NOT MBR of HDA1).

Everything seemed to go smoothly with the install (As it did last time) and I reboot. Now it gets to the drive and it says LILO but immediately there are about 10-15 colored blocks on the screen like ansi art. They are scattered around the screen and the computer is frozen. *sigh* No os choice menu either. Windows_2000 entry set as default boot target.

So...has anyone had this happen to them? Solutions? I think I am going to do the entire install for a 3rd time and use Grub again to see if there are different results (I messed around with the boot loader settings before I set the BIOS to boot from the second harddrive so I may have messed something up).

That being said...is RedHat a good distro to use for a desktop setting? I want a replacement for windows. They seem to have the friendliest installer I have come across. I thought about using slackware too since I can just blow the drive away at this point and install anything on it I want.

Any comments/thoughts/suggestions/solutions are, as always, appreciated.

B

Last edited by beanlover; 09-29-2003 at 11:30 AM.
 
Old 09-29-2003, 11:34 AM   #6
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
If installed LILO in the same place GRUB was, you should have cleared the MBR first. You can use a DOS bootdisk made by win9x to clear it, but you don't have a floppy drive. You might be able to use the dd command to clear it, but i'm not sure how.
 
Old 09-29-2003, 11:38 AM   #7
beanlover
LQ Newbie
 
Registered: Sep 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by aaa
If installed LILO in the same place GRUB was, you should have cleared the MBR first. You can use a DOS bootdisk made by win9x to clear it, but you don't have a floppy drive. You might be able to use the dd command to clear it, but i'm not sure how.
How about a boot from a Win98 CD?
 
Old 09-29-2003, 07:23 PM   #8
beanlover
LQ Newbie
 
Registered: Sep 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by aaa
You might be able to use the dd command to clear it, but i'm not sure how.
Anyone know how to do this?
 
Old 09-29-2003, 09:07 PM   #9
majter
LQ Newbie
 
Registered: Sep 2003
Location: BO
Distribution: RH9/RH7.2
Posts: 1

Rep: Reputation: 0
Try with a Boot Loader Utility

You could also try to boot both systems (W2K & Linux) with a MBR utility, there are some likely to be useful on the net.

I've been using for a while when having troubles with Windows and Linux (and to save time when needed) a utility called Master Booter (http://www.masterbooter.com), it's easy to use but you need to read its documentation. It only supports 3 operating system to boot from (shareware).

It can't harm your MBR (can be uninstalled & small). "While you can figure out how to fix the problem by reading other stuff about dual booting, you could use this utility".

If used, you will need Win98 Bootable CD-ROM or Floppy and the program "mrbooter.exe" (since it runs on DOS), it will detect all your operating system installed currently on your HDDs and let you boot from them once installed.

If you like the program you may try the full version, like I said "it's just to save you time while you figure out how to fix your MBR Loader to boot both systems".

Last edited by majter; 09-30-2003 at 10:04 AM.
 
Old 09-29-2003, 10:54 PM   #10
KenCo
Member
 
Registered: Sep 2003
Location: RI
Distribution: SuSE 9.1 pers.
Posts: 65

Rep: Reputation: 15
I have basicly the same dual boot prob., I tried MRBOOTER but it doesnt see linux


Last edited by KenCo; 09-30-2003 at 02:37 AM.
 
Old 09-30-2003, 03:36 AM   #11
captainstorm
Member
 
Registered: Jun 2003
Location: Oricola, Italy
Distribution: RH 9, so far
Posts: 261

Rep: Reputation: 30
As I know, there are two methods (options) to boot windows2000 and linux.

The first is to use the windows2000 bootloader to boot linux. This method has already been discussed for at least 10 times in this forum. Or search on google windows2000 linux boot you may find a lot of articles on this method, like austindad said. However, I never tried this method.

The second one is to let linux boot windows2000 (linux takes control first). You just allow linux to add lilo or grub to the MBR during the installation. BUT: I tried this method for a couple of times and found a NTFS windows2000 might have problems in this option and you risk not able to boot any system. But FAT32 is quite friendly. I tried 3 times and never failed.

As for the "it comes up and says "GRUB". I think you might find a dark screen and only GRUB: and wait for you to input something. In this case you do not have the graphical GRUB correctly installed, or destroied (whether initrd I am not sure). You can use the command line to use GRUB, google on the intenet there are some examples how to do it.(I could paste some later if I remember), and under linux check /etc/grub.conf and run #grub again could fix the problem.
 
Old 09-30-2003, 08:21 AM   #12
100fr
LQ Newbie
 
Registered: Sep 2003
Location: belgium
Posts: 3

Rep: Reputation: 0
Quote:
Originally posted by captainstorm

The second one is to let linux boot windows2000 (linux takes control first). You just allow linux to add lilo or grub to the MBR during the installation. BUT: I tried this method for a couple of times and found a NTFS windows2000 might have problems in this option and you risk not able to boot any system. But FAT32 is quite friendly. I tried 3 times and never failed.

had the same problem and switched to FAT32
no it works perfectly , but in my mbt linux is the default option, could you telll me hox to change it so that my Win2k is the default option? Or do i siply need to give my boot my win2K parameters and my other the linux parameters?

i now this question could be stupid but i don't want to fuck my system up now it finally works
 
Old 09-30-2003, 09:58 AM   #13
captainstorm
Member
 
Registered: Jun 2003
Location: Oricola, Italy
Distribution: RH 9, so far
Posts: 261

Rep: Reputation: 30
you can edit the /etc/grub.conf if using grub, or
/etc/lilo.conf if you use lilo. I remember in grub.conf simply change the "default" value, lilo is similar. There are a lot of manuals about lilo and grub on the internet in you are not sure.
Do not forget to install the bootloader after making the change. for grub: #grub-install <your device>
for lilo: #lilo
 
Old 09-30-2003, 11:36 AM   #14
KenCo
Member
 
Registered: Sep 2003
Location: RI
Distribution: SuSE 9.1 pers.
Posts: 65

Rep: Reputation: 15
fixed my prob., left W2k alone, installed MRBOOTER, added Linux even though it wasnt in yet but had linux partition undifined, loaded Linux w/ no MBR mod., rebooted and all is fine now w/ MRBOOTER
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I do a dual boot with Linux Suse Pro and win 2000 corp? dade2 Linux - Newbie 4 06-15-2004 06:31 PM
Dual Boot Problem: Win 2000 suggesting Linux Partitions Inconsistent!! Siddharthanant Linux - Hardware 1 03-30-2004 04:32 AM
RedHat on Dual boot(W98 & 2000) babasin Linux - Software 2 12-03-2003 07:54 AM
Lilo: Dual boot Debian & Win 2000 mudelf Linux - General 3 11-12-2003 02:55 AM
win 2000 and linux redhat 7.2 dual boot nandster Linux - Software 3 01-23-2003 12:00 PM


All times are GMT -5. The time now is 03:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration