LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 11-01-2010, 02:31 PM   #1
sgoldman
LQ Newbie
 
Registered: Sep 2005
Location: boston
Posts: 7

Rep: Reputation: 0
Question Install Grub2 and MBR on Linux Image


Hello,
Created an image of a Ubuntu 10.0. and Win 7:

with Acronic True Workstation -

Grub needs to be reloaded from the LIVE CD

1 mbr1 boot 102 nfts/hpfs
1 mbr2 8330m nfts/hpfs
1 mbr3 28885m unknown
1 mbr4 Prime

Working with the Desktop Live CD -

I have the information but not sure how to apply it;

I tried to install GRUB2 :
sudo grub-install --force --root-directory=/mnt /dev/sda3

Does not work - where does reinstalling the MBR come in ?

Thanks,
Stephen
 
Old 11-01-2010, 04:36 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Here is a GRUB 2 tutorial.

https://help.ubuntu.com/community/Grub2#Improvements

It is mentioned in the following post by Larry Webb.

http://www.linuxquestions.org/questi...8/#post4136708

GRUB2 is very different than the original GRUB.
 
1 members found this post helpful.
Old 11-01-2010, 05:20 PM   #3
sgoldman
LQ Newbie
 
Registered: Sep 2005
Location: boston
Posts: 7

Original Poster
Rep: Reputation: 0
grub2

thank you !
 
Old 11-01-2010, 05:28 PM   #4
sgoldman
LQ Newbie
 
Registered: Sep 2005
Location: boston
Posts: 7

Original Poster
Rep: Reputation: 0
Question Grub2 - Missing WIN7 install from Boot loader

Slowly moving forward-
Grub installed:
Ubuntu with Linux 2.6.35-22 generic
Memory Test
Memory Test
Windows 7 <loader> on /dev/sda1

Ubuntu is fine.

Windows not found - /dev/sda1 - points to the boot partition
Windows is installed on /dev.sda2

Selecting Windows 7 <loader> on /dev/sda1
Window BOOT MANAGER
Windows failed to start- Status 0XC000000e

Is this a question changing where to find WIN 7 ? Thanks!
 
Old 11-01-2010, 05:52 PM   #5
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
There is another recent thread about GRUB 2 not finding a windows system. It's a bit lengthy though.

http://www.linuxquestions.org/questi...5/#post4146049

It's not pretty. GRUB 2 is not pretty.

Note that the link as I posted it will bring you to reply #10 which has the answer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] GRUB2 after a minor update of GRUB2 /boot prefix no longer needed?? wikapuki Linux - Software 1 10-24-2010 03:39 PM
RHEL 5.2 image restore ,MBR not working salimshahzad Linux - Newbie 1 08-15-2010 01:22 PM
Win XP Install Overwrites MBR and Linux Rescue Fails to Recognize Linux Partitions carrlane Linux - Software 8 01-14-2004 08:49 AM
dumping the MBR to an image raven Linux - General 1 11-24-2002 07:01 PM


All times are GMT -5. The time now is 06:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration