LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-21-2012, 10:54 PM   #1
secondhandman
Member
 
Registered: May 2012
Posts: 60

Rep: Reputation: Disabled
Images won't load in reverse proxy!


I'm having trouble getting images to load in my reverse proxy setup. I'm using Ubuntu Server with LAMP (Apache2 2.2.17).

I'm not sure what modules I have enabled or how to check what one are.

Can I do this without modules? What steps should I take? Anyone know of a straignt forward tutorial?

This is the 000-default file:

<VirtualHost *:80>

ProxyRequests Off

ProxyPass /site1 http://192.168.0.2
ProxyPassReverse /site1 http://192.168.0.2

ProxyPass /site2 http://192.168.0.3
ProxyPassReverse /site2 http://192.168.0.3

ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>
 
Old 05-22-2012, 12:23 AM   #2
secondhandman
Member
 
Registered: May 2012
Posts: 60

Original Poster
Rep: Reputation: Disabled
It works now! All I had to do was put a / after the site names on ProxyPass and ProxyPassReverse in the 000-default file:

<VirtualHost *:80>

ProxyRequests Off

ProxyPass /site1/ http://192.168.0.2
ProxyPassReverse /site1/ http://192.168.0.2

ProxyPass /site2/ http://192.168.0.3
ProxyPassReverse /site2/ http://192.168.0.3

The problem I am now having is how to make it so that you can enter in the url as http://192.168.0.2/site1 without the final /.

http://192.168.0.2/site1 will not load the page but http://192.168.0.2/site1/ works perfectly when entered in a web browser to reach the site.

How can I make this work?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Reverse Proxy Volcano Linux - Newbie 4 05-03-2012 02:02 PM
Ajax framework failed to load + Reverse Proxy kumartnj SUSE / openSUSE 0 07-22-2011 03:15 AM
Reverse Proxy??? jantman Linux - Server 2 12-07-2007 07:01 PM
Squid as Reverse Proxy and LAN proxy? zivota Linux - Security 2 02-26-2007 06:00 PM
still trying to reverse proxy wildbob Linux - Networking 6 10-28-2003 10:12 AM


All times are GMT -5. The time now is 08:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration