LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2007, 07:59 AM   #1
SteveJ61
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Rep: Reputation: 0
Angry I cant read cd's or mp3 files


Thanks for the help on which version of linux to try

Im running Xubuntu on a compaq ep 450mHz P3 160meg ram

Im now having problems opening CD's and mp3 files

Iv put into the terminal - dmesg > ./dmesg.txt nano ./dmesg.txt

it has come up with this .. what do i do ??

[ 0.000000] Linux version 2.6.20-15-generic (root@palmer) (gcc version 4.1.2$
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] sanitize start
[ 0.000000] sanitize end
[ 0.000000] copy_e820_map() start: 0000000000000000 size: 000000000009fc00 e$
[ 0.000000] copy_e820_map() type is E820_RAM
[ 0.000000] copy_e820_map() start: 000000000009fc00 size: 0000000000000400 e$
[ 0.000000] copy_e820_map() start: 00000000000e0000 size: 0000000000020000 e$
[ 0.000000] copy_e820_map() start: 0000000000100000 size: 0000000009f00000 e$
[ 0.000000] copy_e820_map() type is E820_RAM
[ 0.000000] copy_e820_map() start: 00000000fffc0000 size: 0000000000040000 e$
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000000a000000 (usable)
[ 0.000000] BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
[ 0.000000] 0MB HIGHMEM available.
[ 0.000000] 160MB LOWMEM available.
[ 0.000000] Entering add_active_range(0, 0, 40960) 0 entries of 256 used
 
Old 09-26-2007, 08:07 AM   #2
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
When you insert the audio CD, do you get an icon appearing on your XFCE desktop?
 
Old 09-26-2007, 08:09 AM   #3
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: LinuxMint
Posts: 775

Rep: Reputation: 199Reputation: 199
As for the mp3's, have you installed the needed codecs?
 
Old 09-28-2007, 05:11 AM   #4
Pinkhippochic
LQ Newbie
 
Registered: Sep 2007
Location: Midlands, UK
Distribution: Xubuntu
Posts: 8

Rep: Reputation: 0
Hi guys. This post was put up by my dad. Iv now registered on here and would like to say thank you for the replies.
In response to matthew, I do get an error which says: No input plugin was found. Maybe the file does not exist or there is an error in the URL.
What do you suggest?
 
Old 09-28-2007, 05:29 AM   #5
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
When you get this message, "No input plugin was found", is there any identification of the application which is showing this message?
 
Old 09-28-2007, 06:02 AM   #6
Pinkhippochic
LQ Newbie
 
Registered: Sep 2007
Location: Midlands, UK
Distribution: Xubuntu
Posts: 8

Rep: Reputation: 0
yes it is gxine
 
Old 09-28-2007, 06:29 AM   #7
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
I'd just like you to clarify that there are two separate problems - playing audio CDs and playing mp3 files.

With the audio CD thing, you are inserting a CD, and gxine automatically loads and then you get this error message - am I correct? Is it a normal audio CD or a "copy protected" one?

In the case of mp3 files, how do you try to play them, and what happens? If you are trying to play then with gxine or another program which uses the libxine engine, try installing the package libxine1-ffmpeg. After installing that, make sure no instance of gxine is running, and then try again. That might not be the only package which is needed, I'm not sure yet. If it doesn't work, I have some other package names to try, but I'd you to try just with this one first so I can see if that is enough.
 
Old 09-28-2007, 08:07 AM   #8
Pinkhippochic
LQ Newbie
 
Registered: Sep 2007
Location: Midlands, UK
Distribution: Xubuntu
Posts: 8

Rep: Reputation: 0
Yes that is correct. Im loading the CD and it comes up with the error message, some CDs ignore this message and start playing in gxine but only the first track then it stops.

With the mp3's I'v tried loading them into both gxine and amarok.
gxine comes up with the same error as when loading a cd.
amarok brings up a window saying it cannot play mp3's then tries to load something and brings up KNotify-the KDE crasher handler
KNotify crashed and caused the signal 11 (SIGSEGV)

Do I put libxine1-ffmpeg into a terminal?
 
Old 09-28-2007, 10:20 AM   #9
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
You can install libxine1-ffmpeg by using the Synaptic Package Manager like this:
  1. In xubuntu, select "Synaptic Package Manager" from the Applications -> System menu.
  2. You will be prompted for your admin password - enter it.
  3. When synaptic loads, you select "search" from the menu bar and enter the name of the package: libxine1-ffmpeg.
  4. When the search results appear, click the little box next to the package listing, select "Mark for installation" from the context menu which appears.
  5. Confirm to mark the package in the confirmation dialog box.
  6. Click the "Apply" button on the tool bar, and click "apply" in the confirmation dialog.

It looks like a lot of steps, but it's really very simple - it is quite hard to describe interaction with GUIs without a lot of screen shots. Hence you will often see commands to enter into the terminal posted in forums like this. It's easier to get someone to copy-paste a command.

Incidentally, here's the terminal command to do the same thing as described above. (You do not need to do both of these - either install from Synaptic or using the terminal):

Code:
sudo aptitude install libxine1-ffmpeg
As you can see, it's a lot simpler to describe, but it's probably not as easy to learn and understand what is happening as using Synaptic.

Just for your information, the underlying package system ends up in more or less the same state whichever method you choose - both aptitude and synaptic (and others) are different interfaces to the same package management system. You will also see apt-get and adept mentioned. They are all different ways to talk to the underlying package management system.

Anyhoo...

That some CDs play and not others - this is odd. I can only imagine it is something to do with the CDs which do not play - such as that they are these "copy protected" audio CDs. The copy protection mechanisms work by having a CD with a slightly corrupted session table, which on computers causes them to fail to see the audio session, and more by luck than judgement audio cd players can still see it (not all the time though - especially high end car CD players).

So that is the first thing. Check on the cover of the CD and the insert for very small writing saying the CD is copy protected. If it is, complain to whoever you purchased the music from that you cannot play it and you will probably get a refund. This whole copy protection on Audio CDs thing has been a total disaster for all involved since some idiot had the idea to do it... I have a very nice story about it, but I will tell it later

If you have a CD which you think is not copy protected, we shall investigate further.

On the matter of gxine only playing the first track of an audio CD - I get the same thing. A simple, manual work around is to stop playback, and then go to File -> CD, and then all the tracks on the CD will be added to the play list.

This seems to be something silly in gxine. I found that VLC (another general purpose media player) does it properly. Here's how to set up your computer so that VLC is used to play audio CDs rather than gxine:
  1. Install the following packages using synaptic or aptitude: vlc vlc-nox libcdio6 libvcdinfo0
  2. Check that vlc will play your audio CD properly by entering this command in a terminal:
    Code:
    vlc cdda:///dev/cdrom
    Make sure you can skip forward tracks and so on.
  3. Open Applications -> Settings -> Settings Manager -> File Manager -> Advanced (tab) -> Configure (hyperlink) -> Multimedia (tab). You should see an option "play audio cds when inserted".
  4. In the "Command" text entry box under the "Play audio CDs when inserted" label, enter the vlc command:
    Code:
    vlc cdda:///dev/cdrom
  5. Close the Settings Manager, insert a CD and see if it works

Wow, excessively long post! Sorry about that.
 
Old 09-28-2007, 11:26 AM   #10
Pinkhippochic
LQ Newbie
 
Registered: Sep 2007
Location: Midlands, UK
Distribution: Xubuntu
Posts: 8

Rep: Reputation: 0
Talking

Thank You So Much !! Its all working properly now ... Thank You Thank You Thank You
 
Old 09-28-2007, 12:14 PM   #11
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
No problem. Glad to help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Memory Stick/MP3 Player (Can't read files) jasarien Linux - Hardware 12 08-27-2004 04:09 PM
Can't Read Files on CD's CarbonRods Mandriva 5 02-17-2004 08:56 AM
MP3 CD player can't read MP3 CD's burned in linux food188 Linux - Software 2 01-11-2004 04:55 PM
My XMMS can't seem to read my mp3 files timberwolf Linux - General 7 12-04-2003 08:11 AM
Trouble playing commercial audio cd's. MP3 cd's ok. barryww1956 Linux - General 7 12-17-2001 07:42 PM


All times are GMT -5. The time now is 02:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration