LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-24-2010, 09:55 PM   #1
BanSton
LQ Newbie
 
Registered: Aug 2010
Posts: 18

Rep: Reputation: 0
i can not up the wlan0


#ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

and

# rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
-----------------------------------------------------------------------
i use Archlinux
(#rfkill unblock all) can not solv this problem.
Hard blocked is still "yes"

and the wireless is enable in BIOS

-----------------------------------------------------------------------
my wireless card is LINK 5100
it worked great before 'pacman -Syu'

what should i do?thankkks.
 
Old 10-24-2010, 10:05 PM   #2
rfernandez
Member
 
Registered: Mar 2010
Location: Brazil
Distribution: Slackware64
Posts: 264

Rep: Reputation: 41
Which laptop do you have? Is there any physical switch? Is the wireless led indicator on?
 
Old 10-24-2010, 10:13 PM   #3
BanSton
LQ Newbie
 
Registered: Aug 2010
Posts: 18

Original Poster
Rep: Reputation: 0
i use HASEE HP870
and no these switch。
the problem just is that i can not let the wireless led indicator on…
 
Old 10-25-2010, 11:43 AM   #4
BanSton
LQ Newbie
 
Registered: Aug 2010
Posts: 18

Original Poster
Rep: Reputation: 0
nobody help?
plz……
thanks!
 
Old 10-25-2010, 11:44 AM   #5
BanSton
LQ Newbie
 
Registered: Aug 2010
Posts: 18

Original Poster
Rep: Reputation: 0
nobody help?
plz……
thanks!
 
Old 10-25-2010, 12:23 PM   #6
codegenie
LQ Newbie
 
Registered: Oct 2010
Distribution: Redhat
Posts: 24

Rep: Reputation: -3
I dont know if you have read this, if not check this out. It might help

http://axcoto.com/blog/article/tag/s...due-to-rf-kill
 
Old 10-26-2010, 02:38 AM   #7
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Do this

Code:
rfkill list
Hard blocked is when you turn off wifi button on laptop!
Soft blocked seems come from something like driver/module

Code:
rfkill unblock 0
Code:
rfkill unblock 1
Then try if it works:

Code:
sudo ifconfig  wlan0 up
Restart system, it get soft blocked again after reboot!

You need some flag in booting process to let system know that don’t block it,as given below:

vim /etc/modprobe.d/modprobe.conf

Quote:
options ath_pci rfkill=0
 
Old 10-26-2010, 02:58 AM   #8
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 390
Blog Entries: 3

Rep: Reputation: 25
configure you wireless in system
go to to networking.

see option there
 
0 members found this post helpful.
Old 10-26-2010, 03:16 AM   #9
BanSton
LQ Newbie
 
Registered: Aug 2010
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by prayag_pjs View Post
Hi,

Do this

Code:
rfkill list
Hard blocked is when you turn off wifi button on laptop!
Soft blocked seems come from something like driver/module

Code:
rfkill unblock 0
Code:
rfkill unblock 1
Then try if it works:

Code:
sudo ifconfig  wlan0 up
Restart system, it get soft blocked again after reboot!

You need some flag in booting process to let system know that don’t block it,as given below:

vim /etc/modprobe.d/modprobe.conf
i have done it,but it still block…
 
Old 10-26-2010, 03:18 AM   #10
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 390
Blog Entries: 3

Rep: Reputation: 25
Quote:
Originally Posted by banston View Post
i have done it,but it still block…
try to check your hardware if it is in good condition
 
Old 11-02-2010, 11:29 PM   #11
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 538

Rep: Reputation: 119Reputation: 119
Same thing here with my Atheros. The hard block only occurs when suspending to disk (hibernation) and "rfkill unblock all" don't release it. It started with kernel 2.6.36. Suspending to ram goes without problem. I had two options to bring wireless up again: rebooting or removing the modules and blacklisting rfkill before probing ath5k again, but I loose acer_wmi functionality.
 
Old 11-06-2010, 06:58 AM   #12
BanSton
LQ Newbie
 
Registered: Aug 2010
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by BrZ View Post
Same thing here with my Atheros. The hard block only occurs when suspending to disk (hibernation) and "rfkill unblock all" don't release it. It started with kernel 2.6.36. Suspending to ram goes without problem. I had two options to bring wireless up again: rebooting or removing the modules and blacklisting rfkill before probing ath5k again, but I loose acer_wmi functionality.
okay.~thanks~
 
Old 11-16-2010, 07:18 PM   #13
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 538

Rep: Reputation: 119Reputation: 119
@BanSton,

I was wrong about the kernel. First time I saw this error was shortly after I had 2.6.36 compiled. Playing recently with ConsoleKit I lost permission to manage power functions when starting KDE by console. Sent the system a "few" times to memory/disk and all came clean. The bug goes away... Sorry for misleading.
 
Old 11-16-2010, 08:35 PM   #14
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 390
Blog Entries: 3

Rep: Reputation: 25
check your bios
 
Old 11-17-2010, 07:13 AM   #15
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 538

Rep: Reputation: 119Reputation: 119
No changes made. If you have udev 1.6.4, yesterday I saw this on changelog (Slackware):
Quote:
...
a/udev-164-x86_64-2.txz: Rebuilt.
Set rfkill device writable by netdev group.
...
That 'rfkill' got my attention...

Last edited by BrZ; 11-17-2010 at 07:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no wlan0? cardboardtoast Slackware 2 04-04-2009 10:00 PM
Where's wlan0? msalesi988 Ubuntu 9 12-06-2005 05:21 AM
what is wlan0:9 ? dlocalized Linux - Wireless Networking 1 07-03-2005 02:57 PM
dhclient wlan0 - wlan0: not found nickleus Linux - Networking 1 05-10-2005 10:06 PM
Broadcom wireless with ndiswrapper: ifconfig wlan0 works; ifup wlan0 fails orangechicken Linux - Wireless Networking 2 04-17-2004 06:39 PM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration