LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-16-2005, 04:58 PM   #1
misunderstood
LQ Newbie
 
Registered: Nov 2005
Location: UK
Posts: 2

Rep: Reputation: 0
Unhappy HTTPD stops resonding until I use the console


Very odd... I have Apache running on Mandrake 10.1 kernel is 2.6.8.1-12mdk??

Everything works as expected for a while, pages are served etc. but after a period of inactivity on the console everything just stops, nothing gets served until I pop onto the console and hit return a couple of times. I guess this is probably down to a power saving feature but I have no idea where to start looking.

Any help would be greatly appreciated.
 
Old 11-17-2005, 02:37 AM   #2
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
what is the outputs of:
lsmod
lspci
dmesg
 
Old 11-17-2005, 03:50 PM   #3
misunderstood
LQ Newbie
 
Registered: Nov 2005
Location: UK
Posts: 2

Original Poster
Rep: Reputation: 0
Here it is:

[root@localhost root]# lsmod
Module Size Used by
nls_iso8859-1 3680 1
isofs 30104 1
md5 3552 1
ipv6 217508 22
af_packet 15400 2
eepro100 25388 0
mii 3968 1 eepro100
ide-cd 35104 1
cdrom 35100 1 ide-cd
loop 11720 0
nls_iso8859-15 4224 1
ntfs 137468 1
uhci-hcd 27184 0
usbcore 96580 3 uhci-hcd
ext3 110984 2
jbd 45112 1 ext3

[root@localhost root]# lspci
-bash: lspci: command not found
[root@localhost root]# find / -name lspci


[root@localhost root]# dmesg
Linux version 2.6.8.1-12mdk-i586-up-1GB (quintela@n5.mandrakesoft.com) (gcc vers ion 3.4.1 (Mandrakelinux (Alpha 3.4.1-3mdk)) #1 Fri Oct 1 12:36:44 CEST 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000004000000 (usable)
BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
64MB LOWMEM available.
On node 0 totalpages: 16384
DMA zone: 4096 pages, LIFO batch:1
Normal zone: 12288 pages, LIFO batch:3
HighMem zone: 0 pages, LIFO batch:1
DMI not present.
ACPI: Unable to locate RSDP
Built 1 zonelists
No local APIC present or hardware disabled
Initializing CPU#0
Kernel command line: BOOT_IMAGE=linux ro root=301 acpi=ht resume=/dev/hda5
PID hash table entries: 512 (order 9: 4096 bytes)
Detected 232.966 MHz processor.
Using tsc for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Memory: 61432k/65536k available (1713k kernel code, 3624k reserved, 580k data, 1 84k init, 0k highmem, 0k BadRAM)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 457.72 BogoMIPS
Security Scaffold v1.0.0 initialized
SELinux: Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: 008001bf 00000000 00000000 00000000
CPU: After vendor identify, caps: 008001bf 00000000 00000000 00000000
Intel Pentium with F0 0F bug - workaround enabled.
CPU: After all inits, caps: 008001bf 00000000 00000000 00000000
CPU: Intel Pentium MMX stepping 03
Checking 'hlt' instruction... OK.
init init/main.c:689
init init/main.c:702
init init/main.c:707
do_pre_smp_initcalls init/main.c:653
do_pre_smp_initcalls init/main.c:659
init init/main.c:711
init init/main.c:714
init init/main.c:716
init init/main.c:718
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
ACPI: Looking for DSDT in initrd ... not found!
Freeing initrd memory: 137k freed
init init/main.c:724
do_basic_setup init/main.c:634
do_basic_setup init/main.c:636
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xf1864, last bus=0
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040326
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
PnPBIOS: Disabled
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router VIA [1106/0586] at 0000:00:07.0
vesafb: probe of vesafb0 failed with error -6
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
audit: initializing netlink socket (disabled)
audit(1132000127.499:0): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
Activating ISA DMA hang workarounds.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:07.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt82c586b (rev 41) IDE UDMA33 controller on pci0000:00:07.1
ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdcio, hddio
Probing IDE interface ide0...
hda: ST32122A, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: WDC WD200BB-75CLB0, ATA DISK drive
hdd: CD-W54E, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 4124736 sectors (2111 MB), CHS=4092/16/63, UDMA(33)
/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 >
hdc: max request size: 128KiB
hdc: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(33)
/dev/ide/host0/bus1/target0/lun0: p1
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 4096 bind 8192)
NET: Registered protocol family 1
BIOS EDD facility v0.16 2004-Jun-25, 2 devices found
init init/main.c:726
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting. Commit interval 5 seconds
EXT3-fs: hda1: orphan cleanup on readonly fs
ext3_orphan_cleanup: deleting unreferenced inode 79238
ext3_orphan_cleanup: deleting unreferenced inode 15648
EXT3-fs: hda1: 2 orphan inodes deleted
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 184k freed
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.2
PCI: Found IRQ 11 for device 0000:00:07.2
uhci_hcd 0000:00:07.2: UHCI Host Controller
uhci_hcd 0000:00:07.2: irq 11, io base 00001020
uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
EXT3 FS on hda1, internal journal
Adding 217688k swap on /dev/hda5. Priority:-1 extents:1
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
NTFS driver 2.1.15 [Flags: R/O DEBUG MODULE].
NTFS volume version 3.1.
loop: loaded (max 8 devices)
hdd: ATAPI 32X CD-ROM CD-R/RW drive, 1280kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100. html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@sa w.sw.com.sg> and others
PCI: Found IRQ 11 for device 0000:00:04.0
eth0: 0000:00:04.0, 00:07:E9:0D:54:47, IRQ 11.
Board assembly a80897-003, Physical connectors present: RJ45
Primary interface chip i82555 PHY #1.
Secondary interface chip i82555.
General self-test: passed.
Serial sub-system self-test: passed.
Internal registers self-test: passed.
ROM checksum self-test: passed (0xd0a6c714).
NET: Registered protocol family 17
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02feb60(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
VFS: busy inodes on changed media.
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
eth0: no IPv6 routers present
eth0: no IPv6 routers present
hdd: tray open
end_request: I/O error, dev hdd, sector 112


Thanks for your help with this..

Rob
 
Old 11-17-2005, 03:56 PM   #4
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
on the lspci command that is a lowercase Lspci

my thought is a power management feature is shutting down the NIC to save power. looks like apm loads on your boot, check your bios and see if there are any settings about the power management and your NIC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sceensaver stops console commands Steel_J Linux - Newbie 0 10-19-2004 01:52 PM
service httpd status, results in httpd dead but subsys locked squadja Red Hat 2 09-11-2004 10:31 PM
VNC Works then stops! Reboot fixes but then it stops again! Leethal Linux - Software 1 02-26-2004 07:57 AM
httpd chokes on ScriptAlias line in Apache httpd.conf lhoff Linux - Software 1 07-14-2003 10:32 PM
Boot stops at Grub console? Mark Regler Linux - Newbie 7 05-28-2003 09:16 PM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration