LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2003, 08:12 AM   #16
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30

Thanks.I am sure that must be working for usual non-root users.bu i think i am unusual.see for yourself-
---------------------
bash-2.05$ pwd
/reccal/users/btech/mey2066
bash-2.05$ echo $HOME
/reccal/users/btech/mey2066
bash-2.05$ ls .fonts/
bng2-b.ttf dev2-n.ttf fonts.scale guj1-n.ttf knd1-n.ttf mal2-n.ttf ori1-n.ttf pnj2-n.ttf tlg2-n.ttf tml1-n.ttf
bng2-n.ttf fonts.dir guj1-b.ttf knd1-b.ttf mal2-b.ttf ori1-b.ttf pnj2-b.ttf tlg2-b.ttf tml1-b.ttf
bash-2.05$ mkfontdir .fonts
bash-2.05$ cd .fonts/
bash-2.05$ ttf
ttf2afm ttfinfo ttfinst.tk
bash-2.05$ ttmkfdir
36
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-ascii-0
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-fcd8859-15
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-iso8859-1
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-iso8859-15
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-ascii-0
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-fcd8859-15
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-iso8859-1
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-iso8859-15
dev2-n.ttf -altsys-AkrutiDev2-medium-r-normal--0-0-0-0-p-0-ascii-0
dev2-n.ttf -altsys-AkrutiDev2-medium-r-normal--0-0-0-0-p-0-iso8859-1
guj1-b.ttf -altsys-AkrutiGujL1-bold-r-normal--0-0-0-0-p-0-ascii-0
guj1-n.ttf -altsys-AkrutiGuj1-medium-r-normal--0-0-0-0-p-0-ascii-0
knd1-b.ttf -altsys-AkrutiKnd1-bold-r-normal--0-0-0-0-p-0-ascii-0
knd1-b.ttf -altsys-AkrutiKnd1-bold-r-normal--0-0-0-0-p-0-iso8859-1
knd1-n.ttf -altsys-AkrutiKnd1-medium-r-normal--0-0-0-0-p-0-ascii-0
knd1-n.ttf -altsys-AkrutiKnd1-medium-r-normal--0-0-0-0-p-0-iso8859-1
mal2-b.ttf -altsys-AkrutiMal2-bold-r-normal--0-0-0-0-p-0-ascii-0
mal2-n.ttf -altsys-AkrutiMal2-medium-r-normal--0-0-0-0-p-0-ascii-0
ori1-b.ttf -altsys-AkrutiOri1-bold-r-normal--0-0-0-0-p-0-ascii-0
ori1-b.ttf -altsys-AkrutiOri1-bold-r-normal--0-0-0-0-p-0-iso8859-1
ori1-n.ttf -altsys-AkrutiOri1-medium-r-normal--0-0-0-0-p-0-ascii-0
ori1-n.ttf -altsys-AkrutiOri1-medium-r-normal--0-0-0-0-p-0-iso8859-1
pnj2-b.ttf -altsys-AkrutiPnj2-bold-r-normal--0-0-0-0-p-0-ascii-0
pnj2-n.ttf -altsys-AkrutiPnj2-medium-r-normal--0-0-0-0-p-0-ascii-0
tlg2-b.ttf -altsys-AkrutiTlg2-bold-r-normal--0-0-0-0-p-0-ascii-0
tlg2-b.ttf -altsys-AkrutiTlg2-bold-r-normal--0-0-0-0-p-0-iso8859-1
tlg2-n.ttf -altsys-AkrutiTlg2-medium-r-normal--0-0-0-0-p-0-ascii-0
tlg2-n.ttf -altsys-AkrutiTlg2-medium-r-normal--0-0-0-0-p-0-iso8859-1
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-ascii-0
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-fcd8859-15
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-iso8859-1
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-iso8859-15
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-ascii-0
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-fcd8859-15
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-iso8859-1
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-iso8859-15
bash-2.05$ vim ~/.xinitrc
----------------~/.xinitrc---------------------
xset +fp $HOME/.fonts
---------------------------------------------------
restarted X.
--------------
bash-2.05$ xset -q
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
auto repeat delay: 660 repeat rate: 25
auto repeating keys: 00feffffdffffbbf
fa9fffffffdf2500
0000000000000000
0000000000000000
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 600 cycle: 600
Colors:
default colormap: 0x23 BlackPixel: 0 WhitePixel: 65535
Font Path:
/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/
DPMS (Energy Star):
Standby: 1200 Suspend: 1800 Off: 2400
DPMS is Disabled
Font cache:
Server does not have the FontCache Extension
-------------------------------
again,
-----------
bash-2.05$ xset +fp /reccal/users/btech/mey2066/.fonts/
xset: bad font path element (#37), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
bash-2.05$
----------------------
someone please help.
thanks again,
arun.
 
Old 10-09-2003, 11:18 AM   #17
sandy
Member
 
Registered: Aug 2002
Location: Mumbai,India
Distribution: Linux Mint 12, Gentoo
Posts: 230

Rep: Reputation: 30
Got the problem..

Go to your .fonts dir and look for a file fonts.dir in that .. That file should contain a list of all fonts in your .fonts directory.. For eg have a look at the following file
Code:
37
gautami.ttf -microsoft-Gautami-medium-r-normal--0-0-0-0-p-0-iso10646-1
mangal.ttf -microsoft-Mangal-medium-r-normal--0-0-0-0-p-0-iso10646-1
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-adobe-standard
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-ascii-0
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso10646-1
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-1
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-10
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-11
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-13
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-15
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-16
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-2
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-3
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-4
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-5
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-6
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-7
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-8
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-iso8859-9
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-koi8-r
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-koi8-ru
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-microsoft-ansi
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-microsoft-cp1250
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-microsoft-cp1251
micross.ttf -microsoft-Microsoft Sans Serif-medium-r-normal--0-0-0-0-p-0-microsoft-cp1252
The 37 in the first line is the total no of fonts that the ttf files contain ( Not the total number of ttf files) and there should be description for all the 37 fonts in the next lines... The fonts.dir should be in a format as above.. Otherwise delete it, go to home directory, execute that mkfontdir command again..

So If it doesn't work again ...., look for a fonts.scale file ( created by ttmkfontdir . here the step 4 comes to help) .. in the same directory. If it doesnt there just copy the output of your ttmkfdir to the file fonts.dir ( From the output poseted by you it seems that your ttmkfdir is an older version .. You may have to redirect the output to fonts.dir file )


Then do xset +fp $HOME/.fonts and check for any errors. If no errors restart X.

Hope it works this time...

Last edited by sandy; 10-09-2003 at 11:20 AM.
 
Old 10-10-2003, 01:15 AM   #18
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
thanks.
--------------------------
bash-2.05$
bash-2.05$
bash-2.05$ xset +fp ~/.fonts/
xset: bad font path element (#37), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
-----------------------------
-------------my ~/.fonts/fonts.dir-----------------
36
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-ascii-0
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-fcd8859-15
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-iso8859-1
bng2-b.ttf -altsys-AkrutiBng2-bold-r-normal--0-0-0-0-p-0-iso8859-15
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-ascii-0
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-fcd8859-15
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-iso8859-1
bng2-n.ttf -altsys-AkrutiBng2-medium-r-normal--0-0-0-0-p-0-iso8859-15
dev2-n.ttf -altsys-AkrutiDev2-medium-r-normal--0-0-0-0-p-0-ascii-0
dev2-n.ttf -altsys-AkrutiDev2-medium-r-normal--0-0-0-0-p-0-iso8859-1
guj1-b.ttf -altsys-AkrutiGujL1-bold-r-normal--0-0-0-0-p-0-ascii-0
guj1-n.ttf -altsys-AkrutiGuj1-medium-r-normal--0-0-0-0-p-0-ascii-0
knd1-b.ttf -altsys-AkrutiKnd1-bold-r-normal--0-0-0-0-p-0-ascii-0
knd1-b.ttf -altsys-AkrutiKnd1-bold-r-normal--0-0-0-0-p-0-iso8859-1
knd1-n.ttf -altsys-AkrutiKnd1-medium-r-normal--0-0-0-0-p-0-ascii-0
knd1-n.ttf -altsys-AkrutiKnd1-medium-r-normal--0-0-0-0-p-0-iso8859-1
mal2-b.ttf -altsys-AkrutiMal2-bold-r-normal--0-0-0-0-p-0-ascii-0
mal2-n.ttf -altsys-AkrutiMal2-medium-r-normal--0-0-0-0-p-0-ascii-0
ori1-b.ttf -altsys-AkrutiOri1-bold-r-normal--0-0-0-0-p-0-ascii-0
ori1-b.ttf -altsys-AkrutiOri1-bold-r-normal--0-0-0-0-p-0-iso8859-1
ori1-n.ttf -altsys-AkrutiOri1-medium-r-normal--0-0-0-0-p-0-ascii-0
ori1-n.ttf -altsys-AkrutiOri1-medium-r-normal--0-0-0-0-p-0-iso8859-1
pnj2-b.ttf -altsys-AkrutiPnj2-bold-r-normal--0-0-0-0-p-0-ascii-0
pnj2-n.ttf -altsys-AkrutiPnj2-medium-r-normal--0-0-0-0-p-0-ascii-0
tlg2-b.ttf -altsys-AkrutiTlg2-bold-r-normal--0-0-0-0-p-0-ascii-0
tlg2-b.ttf -altsys-AkrutiTlg2-bold-r-normal--0-0-0-0-p-0-iso8859-1
tlg2-n.ttf -altsys-AkrutiTlg2-medium-r-normal--0-0-0-0-p-0-ascii-0
tlg2-n.ttf -altsys-AkrutiTlg2-medium-r-normal--0-0-0-0-p-0-iso8859-1
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-ascii-0
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-fcd8859-15
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-iso8859-1
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-iso8859-15
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-ascii-0
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-fcd8859-15
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-iso8859-1
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-iso8859-15
--------------------------------------------
why on the hell is this ~/.fonts/fonts.dir missing for xset though it (and a fonts.scale) is present there???
thanks again,
arun.
 
Old 12-13-2003, 09:15 PM   #19
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
Thai fonts won't display correctly!

Hi!

I finally succeeded to install a bunch of Thai font in this folder:
/usr/X11R6/lib/X11/fonts/TTF

I just copied them directly in this folder and this work great in Open Offic Org, I can type and print, the result is perfect.

My problem is that these Thai fonts won't display correctly in other programs. A default font appears instead an the position of vowels is not correct.

I would like these thai fonts to work for all text Editors, Mozilla browser-composer-mail, messanger, etc...

HOW CAN i DO THAT?

Thank you.

 
Old 12-14-2003, 09:11 AM   #20
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
In firebird,there is an option like 'fonts and colours' in tools>settings.similarly in other browsers-just checkout.
 
Old 12-15-2003, 06:22 AM   #21
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
I checked out the possibilities of the browser but the Thai fonts won't appear in the menu.
 
Old 01-08-2004, 05:31 AM   #22
jogurt666
Member
 
Registered: Nov 2003
Location: Poland => Mazowieckie => Ok'a
Distribution: Gentoo
Posts: 176

Rep: Reputation: 30
but what about truetype/type1 form mozilla?

i've converted tff file to pfb and placed it under /usr/X11R6/lib/X11/fonts/Type1. i can use it in terminal now, or so. the same thing when i've copied tff font to ~/.fonts
but i still cannot use them with mozilla. all the fonts i've added were correctly described in ~/.fonts.cache-1. what should i do to use them with mozilla?
 
Old 03-01-2004, 07:44 AM   #23
John-e
LQ Newbie
 
Registered: Feb 2004
Distribution: SuSE 8.2 Professional
Posts: 15

Rep: Reputation: 0
Hi, I installed a whole collection of fonts as root with no problem at all. Thing is I log in as a user and absolutely ALL characters in KDE appear as white boxes (= not reading the fonts somehow). Could it have anything to do with file permissions??

thanx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install fonts tapanagkumar Linux - Newbie 5 12-03-2005 02:43 PM
Install fonts? Slovak Slackware 6 12-11-2004 02:44 AM
How to install new fonts? kpachopoulos Linux - Newbie 1 09-09-2004 05:02 PM
install fonts krilen Linux - Software 1 04-27-2004 10:38 AM
how to install new fonts? meshmesh Linux - Software 1 01-20-2004 10:15 AM


All times are GMT -5. The time now is 08:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration