LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-30-2003, 06:18 AM   #1
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Rep: Reputation: 15
How to install new Fonts!


Hi!

Who can indicate the procedure to install new fonts?

I have a few Thai fonts I would like to install in order to be able to use them in Openoffice, and other programmes. I think I located the font folder, but this is not possible to drag the fonts in it.

I would also like to know if there are fonts available for download and if it is posible to convert windoz fonts for Linux.

Thank you.

Michel

 
Old 09-30-2003, 07:00 AM   #2
micha
Member
 
Registered: Sep 2003
Location: Germany
Distribution: Ubuntu 8.04
Posts: 33

Rep: Reputation: 15
With Openoffice it is very simple. As ´root´ you can use spadmin which normally is located in your OpenOffice-program directory (e.g. /usr/local/Openoffice.../program on SuSE). Than click on ´fonts´ and install your desired fonts.

If you want to install fonts for your X than you have check first, which version of X you have. With 4.x it is quite simple with older version you have to make some more effort.

Next step is to make clear what kind of fonts you want to install. Type1, Truetype or what else.

It is too long to describe all variations here.

E.g for truetype fonts you will find a directory /usr/X11R6/lib/X11/fonts/truetype where the X11-Fonts are located. As well you will find for type1-fonts /usr/X11R6/lib/X11/fonts/type1. To handle them you´ll need software (fonttools, freetype, etc.) which depends on your distribution.

You also can try to use ´kfontinst´ which you might have on your installation.

If you want to know something specific. Please let me know.

Micha
 
Old 09-30-2003, 07:10 AM   #3
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
how can you install fonts without root permissions??(eg:in a LAN).
thanks,
arun
 
Old 09-30-2003, 07:37 AM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
easiest way:
throw them all in your $HOME/.fonts folders, if there isn't one, create one.
don't need to convert just copy your windows ttf fonts directly to it.
 
Old 09-30-2003, 02:18 PM   #5
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Rep: Reputation: 16
Thanks Demonbane - and you too, micha. I was wondering about that when I placed a search for "fonts" in this forum.
 
Old 10-02-2003, 07:18 AM   #6
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
Hi!

Thank you for your reply,

I tried the 2 possibilities which are to copy the fonts in the directory /usr/X11R6/lib/X11/fonts/truetype or to make a special folder for them placed in root (for alll users) /.fonts

The new font is there but I do not see it listed when I open Get it or Ooo. I do not find any tool to manage them. Did I miss something?

Tanks.

Michel
 
Old 10-02-2003, 09:15 AM   #7
micha
Member
 
Registered: Sep 2003
Location: Germany
Distribution: Ubuntu 8.04
Posts: 33

Rep: Reputation: 15
You have to update the fonts.dir and fonts.scale files in these directories. Use mkfontscale or ttmkfdir.

If you have put your fontfiles into a new directory you have to add the path to the FontPath in your XF86Config file which is located in /etc/ or /etc/X11/.

Have fun,
Micha
 
Old 10-04-2003, 11:32 AM   #8
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
I tried that and put the fonts in a special folder.

"" If you have put your fontfiles into a new directory you have to add the path to the FontPath in your XF86Config file which is located in /etc/ or /etc/X11/."""

I added the path in the file you say but I do not see any new font appearing in the list under a text editor or Ooo !!!

Any idea? Thanks.

 
Old 10-07-2003, 08:48 AM   #9
micha
Member
 
Registered: Sep 2003
Location: Germany
Distribution: Ubuntu 8.04
Posts: 33

Rep: Reputation: 15
You need to have two files in your font directory: fonts.dir and fonts.scale. If you only have one than create the other one as a symbolic link to the existing file. This procedure is only needed once.

Than please check, if "freetype" is loaded in the module section of XF86Config. Hopefully your freetype is of a newer version.

If you have XFree86 version 4 or newer than it should work now. If you have an older version you have the make more investigations.

Hope it will work now.

Micha
 
Old 10-07-2003, 08:59 AM   #10
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
i am in a lan without root permissions.
/etc/X11/XftConfig is
-------------------------
# $XFree86: xc/lib/Xft/XftConfig.cpp,v 1.5 2000/12/14 23:03:53 keithp Exp $

dir "/usr/X11R6/lib/X11/fonts/Type1"
dir "/usr/share/fonts/default/TrueType"
dir "/usr/share/fonts/default/Type1"
dir "/usr/share/fonts/ja/TrueType"


#
# alias 'fixed' for 'mono'
#
match any family == "fixed" edit family =+ "mono";

#
# Check users config file
#
includeif "~/.xftconfig"

#
# Use Lucidux fonts for default faces
#
match any family == "serif" edit family += "LuciduxSerif";
match any family == "sans" edit family += "LuciduxSans";
#and some similar entries.
----------------------------
so i created ~/.xftconfig
and added a line like
dir "~/.fonts"
and i copied some ttf fonts(which i had downloaded) to ~/.fonts.then i did 'ttmkfdir'.which gave me outputs like
----------------
tlg2-b.ttf -altsys-AkrutiTlg2-bold-r-normal--0-0-0-0-p-0-iso8859-1
tlg2-n.ttf -altsys-AkrutiTlg2-medium-r-normal--0-0-0-0-p-0-ascii-0
tlg2-n.ttf -altsys-AkrutiTlg2-medium-r-normal--0-0-0-0-p-0-iso8859-1
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-ascii-0
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-fcd8859-15
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-iso8859-1
tml1-b.ttf -altsys-AkrutiTml1-bold-r-normal--0-0-0-0-p-0-iso8859-15
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-ascii-0
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-fcd8859-15
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-iso8859-1
tml1-n.ttf -altsys-AkrutiTml1-medium-r-normal--0-0-0-0-p-0-iso8859-15
----------------------------------------
etc etc.
now,to get these fonts working with opera 7.11,what should i do??
thanks,
arun
 
Old 10-07-2003, 11:53 AM   #11
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi

which version and distro are you using. the newer method is

copy the fonts into /home/username/.fonts directory

enter there.

type fc-cache and your gtk and qt apps will recognise it. openoffice has its own font management system thou

regards
rahul sundaram
 
Old 10-08-2003, 02:12 AM   #12
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
hi rahul,
thanks for replying to my thread.
-------------------copied from Xterm---------------
bash-2.05$ cd ~
bash-2.05$ ls
bin etc flag_india.gif indiaflg.gif man share
downloads flag.gif GNUstep lib prozilla-1.3.6 t_3522.jpg
bash-2.05$ cd .fonts
bash-2.05$ ls
bng2-b.ttf fonts.scale knd1-n.ttf ori1-n.ttf tlg2-n.ttf
bng2-n.ttf guj1-b.ttf mal2-b.ttf pnj2-b.ttf tml1-b.ttf
dev2-n.ttf guj1-n.ttf mal2-n.ttf pnj2-n.ttf tml1-n.ttf
fonts.dir knd1-b.ttf ori1-b.ttf tlg2-b.ttf
bash-2.05$ fc-cache
bash: fc-cache: command not found
bash-2.05$
--------------ends here-----------
What should i do??(this is RH 7.1 in my college lan)
thanks,
arun
 
Old 10-08-2003, 01:55 PM   #13
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi

sorry. what i mentioned here was the newer font system. redhat 9 uses it. 7.3 is the older one. a bit tedious

here is a link i googled

http://lli.linux-bangalore.org/ttfonts.php
 
Old 10-09-2003, 01:29 AM   #14
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
hi rahul,thanks for the link.though the links says you have to be root for it,i tied it and got:
bash-2.05$ pwd
/reccal/users/btech/mey2066/.fonts
bash-2.05$ ls
bng2-b.ttf fonts.scale knd1-n.ttf ori1-n.ttf tlg2-n.ttf
bng2-n.ttf guj1-b.ttf mal2-b.ttf pnj2-b.ttf tml1-b.ttf
dev2-n.ttf guj1-n.ttf mal2-n.ttf pnj2-n.ttf tml1-n.ttf
fonts.dir knd1-b.ttf ori1-b.ttf tlg2-b.ttf
bash-2.05$ xset -fp $PWD
xset: warning, no entries deleted from font path.
bash-2.05$ xset -fp ~/.fonts/
xset: warning, no entries deleted from font path.
bash-2.05$ xset fp rehash
bash-2.05$
---------------------------------
and no new fonts have appeared in opera or gedit.
what should i do now??
thanks,
--arun
 
Old 10-09-2003, 05:11 AM   #15
sandy
Member
 
Registered: Aug 2002
Location: Mumbai,India
Distribution: Linux Mint 12, Gentoo
Posts: 230

Rep: Reputation: 30
A step-by-step guide to install fonts in opera and other applications.. ( for NON-ROOT users)
1. create a .fonts directory in your home directory
Code:
mkdir $HOME/.fonts
Copy all the ttf, .pcf etc fonts to that directory.

Note:- Make sure that all the fonts file are in small-letters. ( Heard that older version of tmkfontdir have got problems in Capital-letters in the font names )

2. While in your home directory do
Code:
mkfontdir $HOME/.fonts
3. then do
Code:
cd .fonts
. Check the .fonts-dir created in the directory and make sure that it contains the total number of fonts in the first line and a description of all the fonts after that.

Note:- If it contains no line or contains ony a zero in the first line restart again

4.
Code:
ttmkfdir .
< dont know whether this have any significance. >

5. Exit from the X-server if you are in X and edit your .xinitrc file ( create if you dont have one in your home directory) and add the line
Code:
xset +fp $HOME/.fonts
at the TOP.. < IMP>

Note:- You can add that line in your .Xclients file or .Xclient-default file also but be careful the command should be in the first line.

6. Restart your X-Server.

7. open -up a terminal and check whether the fonts directory is included in your font path.. by the command
Code:
xset q
( Search for a line Font Path in the output and check whether your .fonts dir is in the list)

8. You can also check by the command xfontsel or xlsfonts

9. Then start opera ( or whatever application you like to use your fonts ) and Woila!! Opera has detected those fonts.

So That's all folks
Signing off

Last edited by sandy; 10-09-2003 at 05:18 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install fonts tapanagkumar Linux - Newbie 5 12-03-2005 02:43 PM
Install fonts? Slovak Slackware 6 12-11-2004 02:44 AM
How to install new fonts? kpachopoulos Linux - Newbie 1 09-09-2004 05:02 PM
install fonts krilen Linux - Software 1 04-27-2004 10:38 AM
how to install new fonts? meshmesh Linux - Software 1 01-20-2004 10:15 AM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration