LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-19-2004, 09:58 PM   #1
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Rep: Reputation: 30
How to enable P4 Hyperthreading support with Redhat?


At the Grub bootscreen, I have two options to choose from; one with SMP, one without. But booting up with the SMP support will have the error : Only one processor found.

Please advise.

Thanks

Last edited by davidas; 03-19-2004 at 10:02 PM.
 
Old 03-20-2004, 03:08 AM   #2
Kovacs
Member
 
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 31
SMP is for multiple processors.
 
Old 03-20-2004, 07:46 AM   #3
MiscGeek
Member
 
Registered: Jan 2003
Location: Georgia, US
Distribution: RHEL WS4
Posts: 189

Rep: Reputation: 30
Sounds like you don't have hyperthreading enabled in the bios., which is odd. It was on by default with my box. I'm not sure where to find the setting though, although it should be fairly easy to find

Once it's enabled you should be able to run the SMP kernel. I'm running RedHat 9 so if you're running an older version it might make a difference.
 
Old 03-20-2004, 01:08 PM   #4
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
Hyperthreading is already enabled in the BIOS.

Thanks for the replies

Quote:
Originally posted by MiscGeek
Sounds like you don't have hyperthreading enabled in the bios., which is odd. It was on by default with my box. I'm not sure where to find the setting though, although it should be fairly easy to find

Once it's enabled you should be able to run the SMP kernel. I'm running RedHat 9 so if you're running an older version it might make a difference.
 
Old 03-20-2004, 01:48 PM   #5
MiscGeek
Member
 
Registered: Jan 2003
Location: Georgia, US
Distribution: RHEL WS4
Posts: 189

Rep: Reputation: 30
Quote:
Originally posted by davidas
Hyperthreading is already enabled in the BIOS.

Thanks for the replies
That's weird I didn't have to do anything special to get it going with my system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i enable 64 bit WEP support? ojasom Suse/Novell 0 10-30-2004 09:59 AM
P4 with Hyperthreading: Should the SMP support be enabled at kernel level? davidas Linux - Software 2 04-06-2004 12:32 AM
Enable module support help! robson8112 Linux - General 1 02-29-2004 12:18 PM
How-to enable ntfs support for kernal 2.4 cbjhawks Linux - General 2 12-21-2003 11:38 AM
redhat 9 + hyperthreading? gafami Linux - Hardware 3 08-18-2003 10:01 PM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration