LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-24-2008, 09:13 PM   #1
M$ISBS
Member
 
Registered: Aug 2003
Posts: 821

Rep: Reputation: 30
How do I disable fsck?


After installing slack I get this error message after the slackware logo appears:

Checking root filesystem.........
/sbin/e2fsck is a directory while trying to open / /:

The superblock could not be read or does not describe a correct ext2
filesystem.
An error occurred during the root filesystem check.

I am not using ext2 filesystem, I am using reiserfs.
If I disable fsck will this message go away?
I have aleady did fsck /dev/hda1 manually and it did not find any problems.

I do have another error on a like in fstab that I cannot fix because I can only login as read-only.
 
Old 12-24-2008, 09:32 PM   #2
rayfordj
Member
 
Registered: Feb 2008
Location: Texas
Distribution: Fedora, RHEL, CentOS
Posts: 475

Rep: Reputation: 73
I'm not familiar with slack but with the distros i've used, if you can get to a shell with the root filesystem mounted (even ro) you should be able to mount it rw to fix fstab. at least that has been my experience, depending on the problem may depend on success rate too.

Code:
mount -o remount,rw /
as far as the specific message regarding e2fsck being a dir, not sure. in fstab is where the fsck field is specified but i'd be more interested in if/why it lists ext2|ext3 instead of reiserfs for your root filesystem in fstab than having the fsck pass no. field set.
 
Old 12-24-2008, 10:17 PM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,049

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
Quote:
Originally Posted by rayfordj View Post
in fstab is where the fsck field is specified but i'd be more interested in if/why it lists ext2|ext3 instead of reiserfs for your root filesystem in fstab than having the fsck pass no. field set.
And for that reason the problem is probably in his /etc/fstab file. So, take a look at it, and double check that everything is ok.
 
Old 12-24-2008, 10:24 PM   #4
M$ISBS
Member
 
Registered: Aug 2003
Posts: 821

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by i92guboj View Post
And for that reason the problem is probably in his /etc/fstab file. So, take a look at it, and double check that everything is ok.
No its not ok, Theres a line that says "IN USE" under / I did not know that thats where fsck works from. I cannot change fstab because I can only log in as read only under root.

 
Old 12-24-2008, 10:46 PM   #5
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,049

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
Check if you can boot in single user mode, and see if that helps.

If not, just boot from a livecd, mount your root partition somewhere under /mnt (ie. /mnt/tmp or whatever), then edit /mnt/tmp/etc/fstab.

EDIT: About the relation between fstab and fsck, you might want to check the man page for fstab. Particularly, the part about the "sixth field".

Last edited by i92guboj; 12-24-2008 at 10:47 PM.
 
Old 12-25-2008, 12:36 AM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 11,478
Blog Entries: 4

Rep: Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527Reputation: 1527
Hi,
Quote:
Originally Posted by M$ISBS View Post
After installing slack I get this error message after the slackware logo appears:

Checking root filesystem.........
/sbin/e2fsck is a directory while trying to open / /:

The superblock could not be read or does not describe a correct ext2
filesystem.
An error occurred during the root filesystem check.

I am not using ext2 filesystem, I am using reiserfs.
If I disable fsck will this message go away?
I have aleady did fsck /dev/hda1 manually and it did not find any problems.

I do have another error on a like in fstab that I cannot fix because I can only login as read-only.
Just use your Slackware install cd/dvd to boot as single user then perform the maintenance on the filesystem. Whenever you want to perform maintenance on any filesystem you should be in 'single' user mode to prevent any conflicts no matter the filesystem type.
 
Old 12-25-2008, 11:46 AM   #7
M$ISBS
Member
 
Registered: Aug 2003
Posts: 821

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by onebuck View Post
Hi,


Just use your Slackware install cd/dvd to boot as single user then perform the maintenance on the filesystem. Whenever you want to perform maintenance on any filesystem you should be in 'single' user mode to prevent any conflicts no matter the filesystem type.
I did that and I still get this error message:


Checking root filesystem.........
/sbin/e2fsck is a directory while trying to open / /:

The superblock could not be read or does not describe a correct ext2
filesystem.
An error occurred during the root filesystem check.

I am using reiserfs, not ex2.
 
Old 12-25-2008, 12:15 PM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
well you better make sure you are using the huge kernel the rieserf is not suported anymore sence the guy that made it is doing 15 to life in a german prison. you need rieserf suport. this might help you reiserfsck and you will never get past single mode till you mount the drive it it has a super block unreadable then the out put is bad super block. boot a live cd and make the change to your fstab /dev/your drive / reiserfs . the big thing is if you installed the system I hope you pushed enter when asking for what ever kernel because if you chose another then you will need to make and initrd.img to load the riserfs support.
I hope this helps. and if you need the initrd.image just do a reinstall and go with a ext3

Last edited by Drakeo; 12-25-2008 at 12:23 PM.
 
Old 12-25-2008, 02:05 PM   #9
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,049

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
Post the entire contents of fstab and the output of fdisk -l.

Drakeo, reiserfs might be damned to death, but as long as it continues being shipped on the vanilla kernel, it must work. I don't advice to use it because I never liked it and has many problems, but that has nothing to do at all with the current topic. I wanted to point that out just to avoid confusion.

The error is very clear: an ext2 fs can't be found. That means that either fstab is incorrect (in one or another way), or the volume is corrupted. Period.
 
Old 12-25-2008, 02:33 PM   #10
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
Quote:
Originally Posted by i92guboj View Post
Post the entire contents of fstab and the output of fdisk -l.

Drakeo, reiserfs might be damned to death, but as long as it continues being shipped on the vanilla kernel, it must work. I don't advice to use it because I never liked it and has many problems, but that has nothing to do at all with the current topic. I wanted to point that out just to avoid confusion.

The error is very clear: an ext2 fs can't be found. That means that either fstab is incorrect (in one or another way), or the volume is corrupted. Period.
I know your right but if you do a search on this and the new 12.2 it has become an issue. not sure why. but check it out. I think some how during some of the installs they are not getting the right kernel to boot for the reisefs support. and if you look at Pat's read me initrd it always refers to the rieserfs as default wonder why.
Well of course that read me goes back to at least 10.2 what can you say it is a cut and paste world.
 
Old 01-03-2009, 03:18 PM   #11
M$ISBS
Member
 
Registered: Aug 2003
Posts: 821

Original Poster
Rep: Reputation: 30
If I partition, format and reinstall using ext3 instead of reiser, will that get rid of this error I am getting?
 
Old 01-03-2009, 03:46 PM   #12
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Rep: Reputation: Disabled
Quote:
Originally Posted by M$ISBS View Post
I did that and I still get this error message:


Checking root filesystem.........
/sbin/e2fsck is a directory while trying to open / /:

The superblock could not be read or does not describe a correct ext2
filesystem.
An error occurred during the root filesystem check.

I am using reiserfs, not ex2.
What, exactly, did you do? Are you saying that you get this message when you boot the cd/dvd, or after "fixing" and booting your system?

After you boot the install cd, you will need to mount your filesystem. Assuming that you installed to /dev/sda1 you would enter "mount /dev/sda1 /mnt". At that point you will need to edit the file /mnt/etc/fstab. It is almost certainly corrupted.

Brian
 
Old 01-03-2009, 03:57 PM   #13
M$ISBS
Member
 
Registered: Aug 2003
Posts: 821

Original Poster
Rep: Reputation: 30
This is exactly what happens.

I formatted, partitioned and installed Slack 12.2.

When I boot up the hard drive that I installed to, It looks as if its going

to boot up, then I get this message:

Checking root filesystem.........
/sbin/e2fsck is a directory while trying to open / /:

The superblock could not be read or does not describe a correct ext2
filesystem.
An error occurred during the root filesystem check.

I reboot, I set the bios to boot from the cd, insert disk one of the

install disks and boot the default kernel on the install disk. From this

point I have tried many different things, I cannot change fstab because I

can only access it read only. Somehow one time I was able to change it but

when I rebooted it returned back to the last settings.

I have ran fsck and it found no problems.

Last edited by M$ISBS; 01-03-2009 at 04:01 PM.
 
Old 01-03-2009, 04:47 PM   #14
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,167

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by M$ISBS View Post
Checking root filesystem.........
/sbin/e2fsck is a directory while trying to open / /:
This may be somewhat of a shot in the dark, but have you verified that the /sbin/e2fsck binary exists (and is not a directory)? Given that your root FS is Reiser, it shouldn't make a difference, but it seems like this is the first error message you get.
 
1 members found this post helpful.
Old 01-03-2009, 05:14 PM   #15
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Rep: Reputation: Disabled
When you boot from the install disk and log in, you will see a full filesystem including /etc/fstab. This is _not_ the same one that you have installed on your hard drive. In order to access your _real_ /etc/fstab you will need to mount your file system as I said in my earlier post. Then you will be able to access and edit your real /etc/fstab by editing /mnt/etc/fstab.

Brian
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disable automatic running of fsck Greebstreebling Debian 4 01-27-2008 11:31 AM
dbx command for corrosponding commands disable or disable on gdb bshankha AIX 0 09-26-2006 10:38 AM
what are the services i can disable, also disable ads, banners in konqueror? greythorne Suse/Novell 3 03-16-2005 09:30 AM
automatic fsck on boot. fsck errors. nixel Slackware 1 05-17-2004 08:51 AM
How to disable auto fsck during boot for specific volumes mansonmuni Linux - General 5 12-21-2003 10:54 PM


All times are GMT -5. The time now is 06:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration