LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 12-20-2003, 10:23 PM   #1
mansonmuni
Newbie
 
Registered: Oct 2003
Distribution: Redhat 9
Posts: 16

Rep: Reputation: 0
How to disable auto fsck during boot for specific volumes


RH 9

After 39 mounts of my 240 GB logical volume consisting of two 120GB SATA's, my initscripts decide that my SATA volume should get fsck'ed. Well this takes about an hour and I can't figure out where this '39' frequency is configured or how to disable it.

Very simply, I would like to know how to disable the forced fsck invocation, during boot, after 39 mounts of my ATA drives. This is an exceedingly long process that I would like to do on my own schedule. So far what I've done is to use noauto in my fstab in order to not accumulate so many mounts, since I only use this volume for multimedia storage. But how can I exclude my SATA's from this configuration so that fsck is not invoked automatically for them.

Thanks you for your kind assistance.

2600 XP+ Athlon on a A7N8X board. 2 WD 120GB ATA drives.

uname -a
Linux washdc3-ar8-4-62-073-033.washdc3.dsl-verizon.net 2.4.20-24.9 #1 Mon Dec 1 11:43:36 EST 2003 i686 athlon i386 GNU/Linux
 
Old 12-21-2003, 12:48 AM   #2
Technoslave
Member
 
Registered: Dec 2003
Location: Northern VA
Posts: 493

Rep: Reputation: 30
Ok, here's the short and skinny.

man fstab

No, seriously :-D

Now for the cheating way

/dev/md1 /var ext3 defaults 1 2
/dev/md2 swap swap defaults 0 0

See the 1 2 and the 0 0

It's the last number in your fstab that you want to set to 0, you won't get any more fscks on the volume. At least if I understand the man pages correctly.

For information purposes the number before the last one deals with dumps.
 
Old 12-21-2003, 01:19 AM   #3
stuNNed
Member
 
Registered: Aug 2003
Distribution: Gentoo/Ubuntu
Posts: 134

Rep: Reputation: 15
yeah i think if you change the last number to 0 it shouldn't check upon boot
 
Old 12-21-2003, 04:16 PM   #4
mansonmuni
Newbie
 
Registered: Oct 2003
Distribution: Redhat 9
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks guys. I actually did read the man pages first -- selectively that is. I thought those trailing numbers had to do with dismount orders or something so I selectively skipped over that part.
 
Old 12-21-2003, 04:37 PM   #5
stuNNed
Member
 
Registered: Aug 2003
Distribution: Gentoo/Ubuntu
Posts: 134

Rep: Reputation: 15
actually, i wasn't just aware of it until checked the manpage, this will come in useful with a laptop where i don't want to have it run fsck upon boot but for a server or workstation i would think it would be ok unless you're rebooting often, like a dual boot system.
 
Old 12-21-2003, 09:54 PM   #6
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
>It's the last number in your fstab that you want to set to 0, you won't get any more fscks on the volume.

I suspect this will prevent the volume being checked if it is not cleanly unmounted as well as stoping the
maximal mount count check. That seems like a bad idea to me.

> I can't figure out where this '39' frequency is configured or how to disable it.
You can change the number of mounts between check with tune2fs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
is it possible to disable specific driver which is rezzie Linux - Newbie 1 09-13-2005 10:17 AM
X start auto for specific user iotc247 Slackware 13 05-30-2004 02:54 PM
automatic fsck on boot. fsck errors. nixel Slackware 1 05-17-2004 07:51 AM
Problem with auto-loading modules on boot (2.6.0, but not specific) Emp202 Fedora 5 01-02-2004 10:26 AM
What file contains auto-mount for fsck cbjhawks Linux - Software 1 09-18-2003 07:02 PM


All times are GMT -5. The time now is 07:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration