LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-24-2002, 09:34 PM   #1
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Rep: Reputation: 30
How do I compile drivers?


How do I get the dhcp on madrake 7.1 to work. I set it up but it still doesn't work. I have a 3c509b and I cannot tell if its working properly in Mandrake. If this nic requires extra drivers how do I install them?
 
Old 04-24-2002, 10:16 PM   #2
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 58
Old ISA NICs are a bit more of a hastle under Linux. You probably don't have to compile any drivers, they're already on there. Try the command: "lsmod"

If 3c509 isn't listed, then its no big deal. Try:

cat /proc/interrupts

Choose a number that isn't listed

modprobe 3c509 irq=x

Where X is that chosen number. If you get a pile of errors... try a different IRQ. Eventually you'll get the card to register (You'll just get another prompt and no errors). Then try:

dhcpcd eth0

Luck,

Finegan
 
Old 04-25-2002, 12:33 PM   #3
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
The 3c509 is there. I did the dhcpcd eth0 as u ssuggested but it says its allrdy running if not to delte a file, and retry I did this and still not working. Its a cable modem connection if that will change anything. Since the nic showed up in lsmod does that mean it is working properly? thanx
 
Old 04-25-2002, 03:14 PM   #4
Syncrm
Member
 
Registered: Aug 2001
Location: Lansing, Michigan
Distribution: slackware8+
Posts: 472

Rep: Reputation: 30
your nic sounds like it's working alright. might wanna try a couple other things.

type "ifconfig etho up" to bring up your eth0 interface.

i'd double to make sure it's not something with your cable. a lot of cable companies restrict their networks based on mac address of your card. meaning, that if you put in a new nic, then you won't be able to access the network. my service used to be like that, and i changed nics all the time... so it was kinda irritating.

hope this helps. :-)
 
Old 04-25-2002, 03:43 PM   #5
aliensub
Member
 
Registered: Apr 2002
Location: Denmark
Distribution: OS X
Posts: 306

Rep: Reputation: 30
I also use the 3c509b isa. And under mandy 8.1 & 8.2 i havent had any problems with it. I just went into the control center and used the wizard. In debian i just told it to use the 3c509 driver in the kernel (2.2) and set up the /etc/network/interfaces for the network. Heres my config if you can use it:

iface lo inet loopback

iface eth0 inet dhcp
gateway 192.168.x.x
 
Old 04-25-2002, 03:46 PM   #6
aliensub
Member
 
Registered: Apr 2002
Location: Denmark
Distribution: OS X
Posts: 306

Rep: Reputation: 30
i once had a 3c509b combo-E (or something like that) isa. And for some reason i never got that running(worked fine under win98) You can see your model on the card in the top left corner.

Last edited by aliensub; 04-25-2002 at 03:47 PM.
 
Old 04-25-2002, 04:22 PM   #7
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 58
Okay, hopefully its not one of those grumpy cable companies... From the ground up though. First, to make sure the card is kosher. Try:

dmesg | more

and spacebar through that some. Its the list of everything the kernel recognizes as it loads (including what it recognizes from modules being loaded). In there should be some goop about 3com and eth0. Are there any errors near those lines?

If not, step 2, try:

dhcpcd eth0
ifconfig

Is there an entry for eth0 and does it have an IP address?

If so, then this is probably one of those funky cable companies that requires that you use their hostname or somesuch before their server will forward any packets. Oh, who is it?

Luck,

Finegan
 
Old 04-25-2002, 06:10 PM   #8
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
I am using Cox Cable. Is the command

dhcpcd eth0
ifconfig

one command or 2?

Thanx

Last edited by gonus; 04-25-2002 at 06:14 PM.
 
Old 04-25-2002, 06:16 PM   #9
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
2.

The first command will try to get eth0 up using DHCP, the second command should show you statistics for eth0, indicating whether or not it is up and running.

If things still don't seem to be working, post the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 and /etc/sysconfig/network.

Last edited by DMR; 04-25-2002 at 06:27 PM.
 
Old 04-25-2002, 11:01 PM   #10
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
Just loaded turbolinux which is quite a bit faster than mandrake 7.1. I am still having the same problem though, and

DHCPcd eth0

isn't recognized as a command. The 3c509 is there and there are no errors on boot, and wheni run the network diagnostics test it says it up and good but still, no connections. I have downloaded and printed the manual but its networking section is not that great. Any more ideas that I can do? Will posting those scripts put me at risk by showing my network settings and such? Sorry but I am linux newb. Thanx

Gonus
 
Old 04-26-2002, 01:47 AM   #11
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Quote:
DHCPcd eth0 isn't recognized as a command
Turbolinux may use the other popular DHCP client "pump". Also, you typed part of the command name in caps in your post; Linux is case-sensitive, so if you typed it that way at the prompt, you would have gotten an error.

You still haven't posted the output of ifconfig; please do. If ifconfig shows no stats for eth0, try ifconfig -a. The "-a" option tells ifconfig to report all cards, even those that are inactive.

Quote:
Will posting those scripts put me at risk by showing my network settings and such?
No, and it's a pretty standard request from people trying to troubleshoot networking issues. The only thing that would really be of use to anyone with malicious intent would be your IP and perhaps your hostname. Since you're using DHCP, your IP is subject to change; and as far as the hostname, you can fill some of that in with "x"s if you don't want to give us the whole thing. You can do the same for the IP if you like; all we're trying to determine from the contents of these files is the fact that you're getting valid IP/subnet/gateway/etc values from your ISP via DHCP. If the contents of one of those files shows a valid IP address, try to ping it:
ping -c 5 xxx.xxx.xxx.xxx (replace xxx.xxx.xxx.xxx with the IP; the -c 5 tells ping to send 5 requests and then quit)
For that matter, you should get positive responses from:
ping -c 5 127.0.0.1

Since you're having the same problem under two different distros, it's possible that your basic network config might actually be OK, but we're missing a piece of critical info supplied by your ISP which allows you to connect to their DHCP server. What information in terms of host name, domain name, IP addresses, etc. did they give you?
 
Old 04-27-2002, 05:42 PM   #12
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
ok here they are
eth0

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

network

NETWORKING=yes
PROFILENAME="No_Profile"
HOSTNAME=cowan233
DOMAINNAME=cowan233
GATEWAY=68.7.xxx.1
GATEWAYDEV=cable modem
FORWARD_IPV4=yes
IPX=no


thanx for explaining it to me.
 
Old 04-27-2002, 07:25 PM   #13
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
OK, that looks good (although you left out half of the important info in /etc/sysconfig/network-scripts/ifcfg-eth0).

Post the results you get from my other suggestions:
Quote:
You still haven't posted the output of ifconfig; please do. If ifconfig shows no stats for eth0, try ifconfig -a. The "-a" option tells ifconfig to report all cards, even those that are inactive.
Quote:
If the contents of one of those files shows a valid IP address, try to ping it: ping -c 5 xxx.xxx.xxx.xxx (replace xxx.xxx.xxx.xxx with the IP; the -c 5 tells ping to send 5 requests and then quit)
For that matter, you should get positive responses from: ping -c 5 127.0.0.1
If ifconfig or the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 show that you've been assigned a valid IP, you should at least be able to ping that address. If so:
- try to ping the IP of the gateway (the address on the "GATEWAY=" line in /etc/sysconfig/network).
If that works, then you're getting the correct basic information from the DHCP server.

-try to ping 66.218.71.80. If that works, you can at least "see" the Internet

-try to ping www.yahoo.com. If thid fails, look in /etc/resolv.conf; it should look very similar to this:
Code:
domain your_ISP's_domain.com
nameserver 216.148.227.68
nameserver 204.127.202.4
By the way, in /etc/sysconfig/network file, the GATEWAYDEV entry doesn't look right. Open the file in a text editor and change "cable modem" to "eth0".

Remember that when you make chnges to network settings, you usually have to restart network services, or reset your NIC to have the changes take effect. Do this as root.
To restart the network service:
service network restart

To reset your NIC:
/sbin/ifdown eth0
/sibin/ifup eth0
Or:
/sbin/ifconfig eth0 down
/sbin/ifconfig/eth0 up
 
Old 04-28-2002, 03:57 PM   #14
gonus
Member
 
Registered: Apr 2002
Location: Huntsville, Alabama
Distribution: Ubuntu 9.04
Posts: 445

Original Poster
Rep: Reputation: 30
in the /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

thats all that is there. Should there be more?

when I input ifconfig yes it shows eth0. It even states that it is up and show the mac address but does not give an IP.

I get 100% reply when I ping the loopback.

I forgot to ping the gateway address will tryafter I post this then correct it

Could not ping any internet addresses.

resolv.conf is exactly like what u posted except mine has search local domans, between isps domain and name server

I saw what you meant with the gateway device. and I changed it to eth0

Turbolinux actually restarts the services after you playwith the settings, but I went ahead ans restarted them with

/sbin/ifconfig eth0 down
/sbin/ifconfig eth0 up

Thanx will post the gateway in a bit.
 
Old 04-29-2002, 05:42 AM   #15
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
^
^
^
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compile drivers help! Itachi Linux - Hardware 2 09-21-2005 08:49 AM
Can't Compile ALSA Drivers AFI_Flame Linux - General 3 07-01-2004 03:59 PM
Aureal drivers won't compile CyberMacro Linux - General 0 08-19-2003 06:19 AM
re-compile Nvidia drivers niton Linux - Newbie 2 07-20-2002 07:58 PM
Compile Kernal with New Drivers...How to add drivers? scgadgets Linux - General 4 09-19-2001 10:27 PM


All times are GMT -5. The time now is 12:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration