LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-13-2004, 12:20 AM   #1
pguru
LQ Newbie
 
Registered: Jun 2004
Posts: 29

Rep: Reputation: 15
how do i change my runlevel


i believe i am in a runlevel other than 3, which I think is default. i cannot get into gnome this, i need help. I am running Mandrake. There is a story behind this problem, but basically i just need to switch the runlevel.
 
Old 08-13-2004, 12:28 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: how do i change my runlevel

Quote:
Originally posted by pguru
i believe i am in a runlevel other than 3, which I think is default. i cannot get into gnome this, i need help. I am running Mandrake. There is a story behind this problem, but basically i just need to switch the runlevel.
Edit the file /etc/inittab and change the line for the default runlevel in Debian it looks like this.

Code:
# The default runlevel.
id:2:initdefault:
You need to re-boot for this to take effect if you are just at the console as root and you want to get to say runlevel 5 without rebooting then use init 5 and it should start that runlevel for you.
 
Old 08-13-2004, 12:30 AM   #3
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
Can use init 5

or edit /etc/inittab and change the line that has

#id:3:initdefault:

to

#id:5:initdefault:

this will get you to GUI at bootup.
 
Old 08-13-2004, 12:46 AM   #4
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
if you aren't happy with the run level you are in, you can (as root) run

init X

replace X with the run level you want to be in (generally people gravitate between 3 and 5 (or 3 and 4 - eg Slackware))

Alternatively, edit /etc/inittab (again as root), as already mentioned above

Incidentally, it's a neat thing to default to 3 because if you startx from the console, you can be in a terminal as su, and run X based software from there, which you normally can't because if you start in 4 (or 5) the X session is locked to you (without going into too much detail).

Mind you that's only really useful if you work in the console alot and change things
 
Old 08-13-2004, 09:37 AM   #5
pguru
LQ Newbie
 
Registered: Jun 2004
Posts: 29

Original Poster
Rep: Reputation: 15
ok, a couple of things. i am in init 5 and i want to be in 3. that is what i usually am in, i think. but maybe not. the other thing that i need happen is my login screen does not come up anymore, so in console i do 'startx' and start KDE and go to 'configure computer' and 'system' or somehting and go to 'login properties' (Sorry i am at work right now, and i don't remember the names exactly) and the function that logged in automatically was turned off. i need this back on, and i don't know if this is altered by this, or by the runlevel. this is what i need and don't have:

when i sign on it should be GUI and log me right into gnome (i cannot get into gnome at all right now).

i should have the ability to switch between any GUI desktop on my computer that i want (right now when i log out of KDE it just brings me to the console mode)

if the two things that i mentioned earlier help this, let me know, otherwise let me know what else i can do.




edit: also i have already found the inittab file and changed it, but i logged off and signed into windows and when i came back it was just at init 5 again. so by running 'init 3' and changing inittab to 3, will it be permanent?

Last edited by pguru; 08-13-2004 at 09:40 AM.
 
Old 08-13-2004, 01:51 PM   #6
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 38
You have to start at runlevel 5 to access the UI - you can read a bit about runlevels here.
In Mandrake, you can choose whether or not to log on automatically, and with which window manager. It is a setting in the Control Center, which you acces with the term command drakconf.

Last edited by mjjzf; 08-13-2004 at 01:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change runlevel on boot? Randall Slack Slackware 6 06-30-2005 03:30 PM
Change runlevel in FC3 FinalFlash Linux - Newbie 3 05-15-2005 11:01 AM
Change runlevel Quiber Linux - Software 1 01-10-2005 11:27 PM
Change runlevel under GRUB prompt? _tracyy Linux - Software 2 07-23-2004 12:49 AM
some services down after a change of runlevel zovres Linux - Newbie 5 10-15-2003 07:48 PM


All times are GMT -5. The time now is 07:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration