LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2011, 05:31 PM   #1
anemone42
LQ Newbie
 
Registered: Jun 2011
Posts: 25

Rep: Reputation: Disabled
Hibernate and automatic shutdown does not work


I have installed Ubuntu as wubi (next to windows 7). When I expect the computer to shut down (either to hibernate or as part of, you know, shutdown), it doesn't. All the programs end, I am logged out, but I still have a picture on the screen (ubuntu default picture).

Help!
 
Old 06-29-2011, 06:49 PM   #2
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 40
Does it work if you shutdown in terminal?

Either open terminal by click System>Accessories>Terminal
-or-
CTRL+ALT+F2

Try using the commands:
Code:
sudo reboot

sudo pm-hibernate

sudo shutdown -h now
 
Old 06-29-2011, 06:54 PM   #3
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Go to System>Preferences>Powermanagement check your settings.
 
Old 06-29-2011, 07:51 PM   #4
anemone42
LQ Newbie
 
Registered: Jun 2011
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Hevithan View Post
Does it work if you shutdown in terminal?
I get the same result every time: screen freezes, but doesn't turn off.
 
Old 06-29-2011, 07:54 PM   #5
anemone42
LQ Newbie
 
Registered: Jun 2011
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
Go to System>Preferences>Powermanagement check your settings.
Uhm, not quite sure what I should look for. "Hibernate" and "Shutdown" should do what they imply, not leave the computer running, and I don't see an option that changes that.

There's actually a state, I didn't expect: suspend. Is that hibernate?
 
Old 06-29-2011, 08:02 PM   #6
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 40
Suspend leaves the computer running but kills all un-necessary process (If you have a browser window up or program it will leave that running) and blanks the screen, Hibernate stores everything in memory and pretty much shuts off the computer, But when you resume it will start back up from memory.
 
Old 06-30-2011, 09:43 AM   #7
anemone42
LQ Newbie
 
Registered: Jun 2011
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
Go to System>Preferences>Powermanagement check your settings.
The result is, that I can not choose hibernate automatically, only suspend.
 
Old 06-30-2011, 10:00 AM   #8
anemone42
LQ Newbie
 
Registered: Jun 2011
Posts: 25

Original Poster
Rep: Reputation: Disabled
Okay, stating my original problem again. When I expect the computer to shut down, because I chose shutdown, it does not.
 
Old 10-06-2011, 08:11 PM   #9
anemone42
LQ Newbie
 
Registered: Jun 2011
Posts: 25

Original Poster
Rep: Reputation: Disabled
Okay, current state of affairs:

Code:
lisea@ubuntu:~$ bin/rtcheck.sh 
-----------------------------------------------
SUSPEND_MODULES="rt2800pci"
-----------------------------------------------
blacklist rt2800pci
-----------------------------------------------
parport_pc             32111  0 
rt2860sta             494649  1 
crc_ccitt              12595  1 rt2860sta
parport                36746  3 parport_pc,ppdev,lp
-----------------------------------------------
lisea@ubuntu:~$ 
lisea@ubuntu:~$ cat bin/rtcheck.sh 
#/bin/sh

echo "-----------------------------------------------"
cat /etc/pm/config.d/config 
echo "-----------------------------------------------"
tail -n 1 /etc/modprobe.d/blacklist.conf
echo "-----------------------------------------------"
lsmod | grep rt
echo "-----------------------------------------------"
In part this was achieved through these commands:

Code:
sudo modprobe -rf rt2800pci
sudo modprobe -rf rt2860sta
sudo modprobe rt2860sta
I blacklisted rt2800pci first (meaning it won't be loaded in the future), then removed it right now with the 3 commands above. The computer froze as a result of the last command, but after boot it finally did what it was supposed to do.

Success! My computer finally understands how a shutdown works!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 'Hibernate, Sleep, Restart, Shutdown' panel disappeared. William B Mauk Linux - Newbie 1 01-02-2011 06:10 PM
What Should Ubuntu Look Like At Shutdown and Hibernate? Teasdale Linux - Newbie 1 02-02-2008 06:50 AM
Edgy Shutdown, Restart, Hibernate Issue on IBM T60 catfishk Ubuntu 6 07-28-2007 05:15 PM
Gnome Logout dialog, shutdown and hibernate options have disappeared trainpic Ubuntu 2 04-04-2006 08:06 PM
How to setup Standby and Hibernate as options during shutdown murkin Linux - Distributions 0 09-08-2005 01:16 PM


All times are GMT -5. The time now is 09:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration