LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-25-2005, 01:32 PM   #1
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Rep: Reputation: 0
hd knoppix 3.6 stops during boot


hi,

i installed knoppix 3.6 in hard disk 2 days before and iam getting issues with it..
its not booting.. i mean that i get the following

modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.27/modules.dep

insmod: Note: /etc/modules.conf is more recent than lib/modules/2.4.27/modules.dep



The screen jus stops showing above text. Nothign happens even if i wait for more than 30 mins

The same knoppix booted neatly before 2 days and now i get this error, which is wierd.

anyhelp in this regard wil e appreciated greatly...

Thanks,
Archu.
 
Old 08-25-2005, 02:44 PM   #2
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
Do you have a live cd to boot up? if so, mount your root partition and

post both files in here

/mnt/<where you mounted it>/lib/modules/2.4.5/modules.dep
/mnt/<where you mounted it>/etc/modules.conf


Last edited by bosewicht; 08-25-2005 at 03:28 PM.
 
Old 08-25-2005, 03:19 PM   #3
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Original Poster
Rep: Reputation: 0
i think u asked me to post ls -l to chk for the permissions :-S

here is it
knoppix@ttyp0[2.4.27]$ ls -l modules.dep
-rw-r--r-- 1 root root 109318 Jul 29 00:02 modules.dep
knoppix@ttyp0[2.4.27]$ ls -l /mnt/hda6/etc/modules.conf
-rw-r--r-- 1 root root 8162 Aug 21 2004 /mnt/hda6/etc/modules.conf

iam booting from knoppix inorder to reply your question..
wat is possibly wrong?
 
Old 08-25-2005, 03:23 PM   #4
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
no, post the contents of the two files in here.

Last edited by bosewicht; 08-25-2005 at 09:18 PM.
 
Old 08-25-2005, 03:32 PM   #5
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Original Poster
Rep: Reputation: 0
the contents of the files exceed the limits of the post here..
wat ami supposed to do? any sugessions?
 
Old 08-25-2005, 03:47 PM   #6
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Original Poster
Rep: Reputation: 0
this is modules.conf file

----------------
### This file is automatically generated by update-modules"
#
# Please do not edit this file directly. If you want to change or add
# anything please take a look at the files in /etc/modutils and read
# the manpage for update-modules.
#
### update-modules: start processing /etc/modutils/0keep
# DO NOT MODIFY THIS FILE!
# This file is not marked as conffile to make sure if you upgrade modutils
# it will be restored in case some modifications have been made.
#
# The keep command is necessary to prevent insmod and friends from ignoring
# the builtin defaults of a path-statement is encountered. Until all other
# packages use the new `add path'-statement this keep-statement is essential
# to keep your system working
keep

### update-modules: end processing /etc/modutils/0keep

### update-modules: start processing /etc/modutils/actions
# Special actions that are needed for some modules

# The BTTV module does not load the tuner module automatically,
# so do that in here
post-install bttv insmod tuner
post-remove bttv rmmod tuner


### update-modules: end processing /etc/modutils/actions

### update-modules: start processing /etc/modutils/aliases
# Aliases to tell insmod/modprobe which modules to use

# Uncomment the network protocols you don't want loaded:
# alias net-pf-1 off # Unix
# alias net-pf-2 off # IPv4
# alias net-pf-3 off # Amateur Radio AX.25
# alias net-pf-4 off # IPX
# alias net-pf-5 off # DDP / appletalk
# alias net-pf-6 off # Amateur Radio NET/ROM
# alias net-pf-9 off # X.25
# alias net-pf-10 off # IPv6
# alias net-pf-11 off # ROSE / Amateur Radio X.25 PLP
alias net-pf-17 af_packet # Packet socket (tcpdump)
# alias net-pf-19 off # Acorn Econet

alias via82cxxx via82cxxx_audio
alias char-major-10-175 agpgart
alias char-major-10-200 tun
alias char-major-81 bttv
alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

# Crypto modules (see http://www.kerneli.org/)
alias loop-xfer-gen-0 loop_gen
alias loop-xfer-3 loop_fish2
alias loop-xfer-gen-10 loop_gen
alias cipher-2 des
alias cipher-3 fish2
alias cipher-4 blowfish
alias cipher-6 idea
alias cipher-7 serp6f
alias cipher-8 mars6
alias cipher-11 rc62
alias cipher-15 dfc2
alias cipher-16 rijndael
alias cipher-17 rc5

# Name inconsistency in 2.4 Kernel series
alias ide_cs ide-cs
alias usbcore off
alias autofs autofs4

# If both mousedev and usbmouse are insmodded, neither of them works right.
# Adding solution proposed by Kai Lehmann:
alias usbmouse mousedev
# Same for USB keyboards, which should be used in hid generic mode instead
alias usbkbd hid

### update-modules: end processing /etc/modutils/aliases

### update-modules: start processing /etc/modutils/apm
# alias char-major-10-134 apm
alias char-major-10-134 off
alias /dev/apm_bios /dev/misc/apm_bios
alias /dev/misc/apm_bios apm
options apm power_off=1

### update-modules: end processing /etc/modutils/apm

### update-modules: start processing /etc/modutils/autofs
probe autofs autofs4 autofs

### update-modules: end processing /etc/modutils/autofs

### update-modules: start processing /etc/modutils/bluez
# BlueZ modules
alias net-pf-31 bluez
alias bt-proto-0 l2cap
alias bt-proto-2 sco
alias bt-proto-3 rfcomm
alias bt-proto-4 bnep
alias bt-proto-5 cmtp
alias bt-proto-6 hidp
alias tty-ldisc-15 hci_uart
alias char-major-10-250 hci_vhci

### update-modules: end processing /etc/modutils/bluez

### update-modules: start processing /etc/modutils/ftape-util
#
# load ftape/zftape automatically
#

# valid for all versions with zftape

alias char-major-27 zftape

# Bleeding edge ftape driver from ftape-module

options ftape ft_fdc_driver=ftape-internal,none,none,none
options ftape-internal ft_fdc_base=0x3f0 ft_fdc_irq=6 ft_fdc_dma=2
pre-install ftape-internal /usr/bin/swapout 15

# ftape driver from 2.2 kernel (Comment previous three lines and uncomment the next one)

# options ftape ft_fdc_rate_limit=1000 ft_fdc_threshold=16 ft_fdc_base=0x360 ft_fdc_irq=9 ft_fdc_dma=3

# You may need to fine tune the parameters. See the ftape documentation for more details

### update-modules: end processing /etc/modutils/ftape-util

### update-modules: start processing /etc/modutils/ipx.aliases
alias net-pf-4 ipx

### update-modules: end processing /etc/modutils/ipx.aliases

### update-modules: start processing /etc/modutils/irda
alias tty-ldisc-11 irtty
# The following is for new kernel.
alias char-major-161 ircomm-tty

# The following is for old kernel.
alias char-major-60 ircomm_tty

# To be able to attach some dongles
alias irda-dongle-0 tekram
alias irda-dongle-1 esi
alias irda-dongle-2 actisys
alias irda-dongle-3 actisys
alias irda-dongle-4 girbil
alias irda-dongle-5 litelink
alias irda-dongle-6 airport
alias irda-dongle-7 old_belkin

# FIR device drivers.
# options smc-ircc ircc_irq= ircc_dma=
# alias irda0 smc-ircc
# options toshoboe max_baud=
# alias irda0 toshoboe
# options w83977af_ir io= io2= irq= qos_mtt_bits=
# alias irda0 w83977af_ir

# To use the NSC driver on a Thinkpad laptop: uncomment the following:
# options nsc-ircc dongle_id=0x09
# alias irda0 nsc-ircc

### update-modules: end processing /etc/modutils/irda

### update-modules: start processing /etc/modutils/linux-wlan-ng
# Aliases to tell insmod/modprobe which module to use when bringing up the
# wlan0 interface.

# Uncomment the line corresponding to the type of prism2 device you have.
#alias wlan0 prism2_pci
alias wlan0 prism2_usb
#alias wlan0 prism2_cs
#alias wlan0 prism2_plx


### update-modules: end processing /etc/modutils/linux-wlan-ng

### update-modules: start processing /etc/modutils/madwifi
# Alias to load into the kernel
alias ath0 ath_pci

### update-modules: end processing /etc/modutils/madwifi

### update-modules: start processing /etc/modutils/mt-st
# Reset the st driver on module insertion...
post-install st /etc/init.d/mt-st modload > /dev/null 2> /dev/null

### update-modules: end processing /etc/modutils/mt-st

### update-modules: start processing /etc/modutils/options
options sbp2 sbp2_serialize_io=1

### update-modules: end processing /etc/modutils/options

### update-modules: start processing /etc/modutils/paths
# This file contains a list of paths that modprobe should scan,
# beside the ones that are compiled into the modutils tools
# themselves.


### update-modules: end processing /etc/modutils/paths

### update-modules: start processing /etc/modutils/ppp
alias /dev/ppp ppp_generic
alias char-major-108 ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

### update-modules: end processing /etc/modutils/ppp

### update-modules: start processing /etc/modutils/raidtools2
alias md-personality-1 linear
alias md-personality-2 raid0
alias md-personality-3 raid1
alias md-personality-4 raid5

### update-modules: end processing /etc/modutils/raidtools2

### update-modules: start processing /etc/modutils/setserial
#
# This is what I wanted to do, but logger is in /usr/bin, which isn't loaded
# when the module is first loaded into the kernel at boot time!
#
#post-install serial /etc/init.d/setserial start | logger -p daemon.info -t "setserial-module reload"
#pre-remove serial /etc/init.d/setserial stop | logger -p daemon.info -t "setserial-module uload"
#
alias /dev/tts serial
alias /dev/tts/0 serial
alias /dev/tts/1 serial
alias /dev/tts/2 serial
alias /dev/tts/3 serial
post-install serial /etc/init.d/setserial modload > /dev/null 2> /dev/null
pre-remove serial /etc/init.d/setserial modsave > /dev/null 2> /dev/null

### update-modules: end processing /etc/modutils/setserial

### update-modules: start processing /etc/modutils/arch/i386
alias parport_lowlevel parport_pc
alias char-major-10-144 nvram
alias binfmt-0064 binfmt_aout
alias char-major-10-135 rtc
# no warnings to stderr on KNOPPIX
insmod_opt=-q

### update-modules: end processing /etc/modutils/arch/i386
---------------
 
Old 08-25-2005, 04:05 PM   #7
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
What disc are you booting up with? the same you installed with?
 
Old 08-25-2005, 04:08 PM   #8
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Original Poster
Rep: Reputation: 0
yes the same..
 
Old 08-25-2005, 04:12 PM   #9
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
Have you updated or anything since you installed?

try from a terminal

mv /mnt/<where you mounted it>/etc/modules.conf /mnt/<where you mounted it>/etc/modules.conf.old

Then cp /etc/modules.conf /mnt/<where you mounted it>/etc/modules.conf

then try rebooting. if this works, then try update-modules from a terminal.
 
Old 08-25-2005, 04:16 PM   #10
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Original Poster
Rep: Reputation: 0
ok.. wil chk that and get back..
 
Old 08-25-2005, 04:32 PM   #11
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Original Poster
Rep: Reputation: 0
hey it booted..
but there are few stuffs that are odd..
my firefox menu bar is having quite big font size.. so i opened mozilla, which too has bigger fonts for its menus..
anyway iam happy that it booted..
iam typing this from the booted version of knoppix 3.6
thanks bosewicht

let me know if i can do anythign to set the menu bar fonts right..
konqueror is having it fine...
 
Old 08-25-2005, 04:33 PM   #12
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
only firefox has the font problem?
 
Old 08-25-2005, 04:37 PM   #13
archu
LQ Newbie
 
Registered: Jun 2003
Location: Chennai, India
Distribution: Knoppix 3.6, Fedora core 4, Debian Sarge 3.01
Posts: 16

Original Poster
Rep: Reputation: 0
mozilla and firefox.. both
 
Old 08-25-2005, 09:16 PM   #14
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Sounds like it may be corrupted libraries or other files. Have you had any unclean shutdowns lately? Can you run fsck on your hard drive partitions manually (from a LiveCD) and see if there are any errors?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slax stops in the middle of boot-up aquilolumen Slackware 13 08-15-2005 12:09 AM
boot stops at grub> promicro Linux - General 1 03-11-2005 04:54 PM
Boot up stops at setting up eth0 zmanea Linux - General 15 04-01-2004 07:54 PM
Boot stops at Grub console? Mark Regler Linux - Newbie 7 05-28-2003 09:16 PM
Boot stops with two video adaptors Ed-Slack Slackware 2 01-06-2003 01:08 AM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration