LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-09-2005, 11:49 AM   #1
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Rep: Reputation: 15
slax stops in the middle of boot-up


after a few moments in verbose mode, slax freezes, discontinuing the boot.

Code:
Warning: ATI  RAdeon IGP Northbridge is not yet fully tested
several lines later:
Code:
ALI15X3: not 100% native mode: will probe irqs later
     ide0: [some stuff]...
     ide1: [some stuff]...
and it stops there.

does anyone know what the problem is?

++ some specs that i think might be relevant:
eMachines notebook, M5313
Mobile AMD Athlon™ XP-M 2500+ Processor
ATI® Mobility RADEON™ 320M
 
Old 08-09-2005, 11:51 AM   #2
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
What does the [some stuff] say?
What is the error when it hangs?
 
Old 08-09-2005, 12:38 PM   #3
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
[some stuff] reads as following:

Code:
ide0: BM-DMA at 0x8080-0x8087, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0x8080-0x808f, BIOS settings: hda:DMA, hdb:pio
i don't know what the error is, except that it stops going any further at that point. i went away for 20 minutes to see if anything would happen, and nothing did.
 
Old 08-10-2005, 02:29 AM   #4
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
What Slax are you using, and is it stock or custom? MySlaxCreator is still kinda buggy.
 
Old 08-10-2005, 07:38 PM   #5
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
slax 5.0.6, stock.

i suspect that some cheatcodes are in order? if so, i wouldn't know which ones to employ...
 
Old 08-11-2005, 04:28 PM   #6
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Cheatcodes can be found at http://slax.linux-live.org/cheatcodes.php, but I would try:
boot: slax noagp
first because of where your system got hung at.
(Not that I know what the hell I'm talking about.)
 
Old 08-12-2005, 02:28 PM   #7
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
i did "boot: noagp", and it froze in the same place.
 
Old 08-12-2005, 09:02 PM   #8
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
What about the other cheatcodes? How did they do?
 
Old 08-13-2005, 04:26 PM   #9
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
"boot: slax acpi=off" worked! i got into gui okay...

next problem: network and mouse. i have a logitech mouse connected to USB. i went to control center > peripherals > mouse, but it froze. i suppose that doesn't matter because i can use the touchpad easily enough...

i'm not sure how i should configure the wireless network... the 'wizard' looks different than what i've seen. so, at this point, i don't know how you can help me. but thanks very much for the tips above.
 
Old 08-14-2005, 01:08 AM   #10
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Well done.

I have no idea what to do about your usb mouse, I don't have one.
As to your wireless nic, Slax has no problems autoconfiguring for the cards in my desktop and my wife's laptop. Curious that yours won't.
 
Old 08-14-2005, 06:01 PM   #11
ddpicard
Member
 
Registered: Oct 2001
Location: Texas
Distribution: Slackware 13
Posts: 214

Rep: Reputation: 31
aquilolumen, what kind of laptop are you using? I have a Compaq Presario 2100 and have Slax 5.0.6. I have to configue the wireless manually, but it works perfectly.

Ok, sorry, I did not see your specs. Can you tell me what wireless card that laptop uses? You get the windos xp driver and then you can use NDISWRAPPER to get it going.

Dave

Last edited by ddpicard; 08-14-2005 at 06:03 PM.
 
Old 08-14-2005, 06:20 PM   #12
ddpicard
Member
 
Registered: Oct 2001
Location: Texas
Distribution: Slackware 13
Posts: 214

Rep: Reputation: 31
Ok, go to eMachines website and download the wireless driver:

http://www.emachines.com/support/pro...es&model=M5313

Once you get this I'll walk you through what I do with my laptop and see if it works for you.

Dave
 
Old 08-15-2005, 12:06 AM   #13
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
ok, i downloaded the wireless driver at the emachines link. the wireless is an ethernet card.

what is the windows xp driver and NDISWRAPPER?

*edit: i also downloaded NDISWRAPPER, so now i have ndiswrapper-1.2.tar (ndiswrapper) and BCM_3_70_RC17.exe (emachines wireless driver) sitting on my desktop.

Last edited by aquilolumen; 08-15-2005 at 07:12 PM.
 
Old 08-15-2005, 12:09 AM   #14
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Ndiswrapper homepage: http://ndiswrapper.sourceforge.net/
It tells you what is it there.

The Windows XP driver, well is the Windows XP Driver, there's no other definition for that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can boot slax from fat/mp3 player jabka General 9 10-14-2005 11:11 AM
Installation stops in the middle of bootup (on new machine) lostinpurdy Linux - Newbie 4 10-05-2005 09:12 PM
Cannot boot into Slax with grub... fannymites Linux - Software 4 08-10-2005 03:50 PM
cron stops in the middle of the script djzanni Linux - Newbie 6 06-02-2005 05:29 PM
Why my installation stops in middle vivek007 Red Hat 3 10-31-2003 11:00 AM


All times are GMT -5. The time now is 09:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration