LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-30-2008, 11:59 AM   #1
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Rep: Reputation: 0
GRUB stage1.5 ignoring Linux


Hello

I'm not necessarily a newby but I guess my question fits this board best.

I have three partitions on my computer with SuSE10, winXPpro and winXPhome respectively.

I've been using Linux without problems for some time now, however since some days after I selected the command to reboot into windows it automaticly boots into windows everytime i start the computer.

It starts loading GRUB, then blinks up for a short peace of a second and afterwards just procedes booting windows.

I suppose this was caused by my computer shuting down while rebooting that one time (I don't remember this for sure) and the setting got fixed somewhere in the system.

Any help is appreciated.
 
Old 04-30-2008, 12:25 PM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
grub stage1.5 ignoring linux

I think Grub has been damaged .
Try in the first place to repair it using the repair mode of suse
cd or dvd

all the best
 
Old 04-30-2008, 06:32 PM   #3
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,880

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Try booting the Suse installation cd/dvd. You should have a menu of choices: install, boot from hard drive, memtest; something like that. Choose 'boot from hard drive'. It will boot the Suse installation. Once you are booted into Suse, open a console, su to root, and run grub-install to repair the grub installation.

If you get any errors, write them down and report them here.
 
Old 04-30-2008, 07:40 PM   #4
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks a lot, the first suggestion worked for me - did an automatic repair.
The second suggested way wouldn't have worked though as after clicking "boot from harddrive" it just went on starting up windows.
 
  


Reply

Tags
grub


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB Loading stage1.5 :: Puppy Linux :: 2 Errors Dark Jaguar Linux - Newbie 2 03-20-2008 12:10 PM
detect stage1.5 in GRUB Amouse Programming 5 08-10-2006 08:24 AM
Grub install error 31 while setting up stage1.5 netadptr0719 Linux - Software 1 01-21-2006 03:51 PM
grub error 21 stage1.5 wxman2 SUSE / openSUSE 2 08-27-2005 10:45 AM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 08:13 PM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration