LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2010, 07:07 PM   #1
Mrich
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Rep: Reputation: 0
Gnome Not Shutting Down Properly


Hello Everyone, I'm using Gnome 2.30.2 with Ubuntu 10.4 would like to shut down X Windows properly. Using sudo init 3 from console 1 or a terminal on the Gnome desktop results nothing. There are a bunch of ways of doing accomplishing this that I've seen, but the most recommended methods each cause the same errors. The methods that I’ve used are sudo service gdm stop, sudo stop gdm && sudo pkill X, and sudo /etc/init.d/gdm stop. After these commands are run I receive the following message: gdm stop/waiting. Then I switch to console 7 & notice that the screen is frozen & has the following information:

fsck from util-linux-ng 2.17.2 /dev/sda5: clean, 172062/7864320 files, 2712422/314552232 blocks (check in 4 mounts)
* Starting AppArmor profiles [OK]
* Setting sensor limits [OK]
* Speech-dispatcher configured for user session [OK]
* Starting common unix printing system: cupsd [OK]
* PulseAudio configured for per-user sessions [OK]
* Enabling additional executable binary formats binfmt-support [OK]
* Checking battery status...

There is a blinking cursor below this message & the terminal does not respond to any command including Ctrl z. These are the same messages that are normally quickly displayed when linux normally boots.

I disabled the battery power option in & removed other unnecessary startup processes from System, Preferences, Startup Applications. I've tried running the gdm stop commands from terminals 1 & 2 as well as consoles in X Windows & it produces the same results. For some reason though, the gdm commands do work when I used the restart option.
Any ideas would be great. Thanks Mark

Last edited by Mrich; 08-23-2010 at 07:09 PM.
 
Old 08-24-2010, 08:51 AM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,552

Rep: Reputation: 339Reputation: 339Reputation: 339Reputation: 339
Ubuntu doesn't use runlevel 3 for console mode the way Fedora (and others?) do. Uninstalling gdm and any other display manager that might be present seems to help things (I like to start in text mode so the lach of a graphical startup doesn't bother me).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
netbook not shutting down properly eddiemcg Linux - Newbie 2 06-08-2009 06:17 AM
Fedora 6 (Gnome) shutting down after about an hour jdpacheco Linux - Software 1 03-19-2007 01:41 PM
Shutting down properly with PCMCIA card mattp Linux - Hardware 0 01-16-2006 01:01 AM
Properly shutting down thorman82 Mandriva 1 12-02-2003 09:02 PM
gnome system menu logo and shutting down X Cahelo Linux - Newbie 3 05-08-2003 03:01 AM


All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration